Skittles Nov 16, 2013 @ 9:48pm
Gmod Linux Missing client.so
i've tried verifying and reinstalling but it doesn't seem to make a difference. I am told the following every time i try to play.

"Couldn't load: \home\schmichy\.local\share\Steam\SteamApps\common\GarrysMod\garrysmod\bin\client.so
Reason: \home\schmichy\.local\share\Steam\SteamApps\common\GarrysMod\garrysmod\bin\client.so cannot open shared object: No such file or directory"
Showing 1-15 of 58 comments
< >
Shigutso Dec 5, 2013 @ 10:11am 
I'm having the same problem. Any help? Thanks
plakatmannen Dec 5, 2013 @ 10:43am 
This also happened to me. The file is where it should be, but it looks like Steam can't find it. Maybe because it tries to load the path with backslashes instead of forward slashes?

Edit: Here's the error I get when launching it from Steam: http://i.imgur.com/LnChxtX.png
Last edited by plakatmannen; Dec 5, 2013 @ 10:44am
Shigutso Dec 5, 2013 @ 11:10am 
Originally posted by plakatmannen:
Edit: Here's the error I get when launching it from Steam: http://i.imgur.com/LnChxtX.png

Yes, exactly this same error. I'm using Ubuntu 13.04 32bits.
Arcus Dec 5, 2013 @ 11:18am 
I can only agree with me, unfortunately. Yesterday I was able to start it. But after the little update from today the error message appears. The Dev-beta does not work, too. Just like validate game data, or a new installation of GMod.
Ubuntu 13.10 64bit (the installation is only 2 days ago)
GianfrixMG Dec 5, 2013 @ 1:40pm 
Same error to me. WTF, earlier today I was able to play!
Gabmus Dec 5, 2013 @ 2:02pm 
Same here, don't know what to do really
Agustin Dec 5, 2013 @ 2:59pm 
Same error here, on elementaryOS Luna.
simon Dec 5, 2013 @ 3:11pm 
Same error here, Debian Jessie multiarch on amd64. client.so is where it is supposed to be.
simon Dec 5, 2013 @ 3:15pm 
Can someone explain what the real problem is? (Since the "no such file or directory" message seems unapropried)
Agustin Dec 5, 2013 @ 3:16pm 
This is expanding like the plague, there is a way to inform it to the developers?
simon Dec 5, 2013 @ 3:29pm 
Free the source code... I'll fix the slashes, I promise :)
Last edited by simon; Dec 5, 2013 @ 3:29pm
F123AKZ01D Dec 5, 2013 @ 5:19pm 
Same problem here.
SuperCraftSister Dec 5, 2013 @ 5:26pm 
Same here. Couldn't load client.so.
Erık Dec 5, 2013 @ 6:09pm 
This can be worked around by setting LD_LIBRARY_PATH before launch, but Valve really needs to fix it.
Last edited by Erık; Dec 5, 2013 @ 6:33pm
DJ Wolf Dec 5, 2013 @ 6:14pm 
Same on Ubuntu 12.04 LT http://i.imgur.com/vYpK6eE.png
Showing 1-15 of 58 comments
< >
Per page: 15 30 50