zequav Nov 16, 2013 @ 10:58am
Steam BPM doesn't detect Xbox controller (NOT permissions related)
Ok, I've read a lot of info about this problem, but in all the cases I've read it was caused by bad permissions in /dev/input/eventX. This is not my case. My xbox controller is event6, and it has 666 permissions. Also /dev/input/js0, just in case. I'm using xboxdrv --silent --mimic-xpad. I can cat /dev/input/event6 and /dev/input/js0 as any user, and they both print output as I move the joysticks or push the buttons. Stealth ♥♥♥♥♥♥♥ Deluxe, And Yet It Moves, Shatter, they all work great with my controller. But Steam BPM prints "No controller detected".

Is there any way to debug the controller detection to understand why in hell Steam refuses to see it?
Showing 1-2 of 2 comments
< >
Ultimoore Nov 16, 2013 @ 2:59pm 
This is why I use the Logiteck F710. I works right out of the box and has the same figure as a 360 controller. Also you can switch its settings from Xbox controller to plaiin USB gamepad controller. It is really worth a buy if you wanna use a controller.
OldeFartz [Linux] Nov 20, 2013 @ 9:09pm 
Which Linux distro? If Debian based (Ubuntu, Mint, etc.) install joystick and jstest-gtk packages and see if jstest in terminal or jstest-gtk in X shows response to all buttons and levers.

The Logitech F710 that I got to qualify for Steam OS hardware beta test worked out of the box for Big Picture and games in 64-bit Ubuntu 12.04. Although, in one game everything worked switched to 360 mode, except Dpad only partially worked (worked for circular menu, but not in game for zoom or switching weapon slots). Since the game had no gui menu for configuring the gamepad, but did for keyboard, I programmed some unused keyboard settings using the Dpad, then transferred those settings from the text config file for keyboard to config file for gamepad. So now everything works in that game.

Although, I only use the gamepad in outer space and keyboard/mouse on the ground.
Showing 1-2 of 2 comments
< >
Per page: 15 30 50