Gerry Adams Dec 22, 2013 @ 10:32am
Regular segmentation faults
I'm running Ubuntu 13.10 and the Steam client regularly crashes. When I run it through terminal it'll crash for seemingly no reason with the output in terminal telling me there was a segfault on line 755 of steam.sh.

Anyone have any idea what might be causing this?
Showing 1-15 of 27 comments
< >
Kranky K. Krackpot Sr. Dec 22, 2013 @ 11:16am 
Your system info? Steam's terminal output? What game you try to play? Does it crash if run without terminal? steam.sh is a shell script, it can't segfault...
Last edited by Kranky K. Krackpot Sr.; Dec 22, 2013 @ 11:32am
Gerry Adams Dec 23, 2013 @ 3:19am 
I'm running Ubuntu 13.10 on a Dell Inspiron 15 with a hybrid graphics setup consisting of an Intel 4000 card and an AMD Radeon 7730M. It doesn't occur if I try to run a game. It occurs when I try to do anything. If I try to open the store, if I try to open a chat window, if I launch steam for the first time... it's all random and nothing in particular causes the crash. It crashes if ran outside terminal. I just run it through terminal because it gives me output.

The terminal message I get is here[pastebin.com].


Kranky K. Krackpot Sr. Dec 23, 2013 @ 6:05am 
Your Ubuntu is 32 or 64 bit? The terminal message is only last few lines, normally it's waaaay longer... Can you post it in full? Did you update your Steam client to the last release?
Anyway, I see this suspicious:
[1223/111524:ERROR:nss_ocsp.cc(588)] No URLRequestContext for OCSP handler.
It looks like network security system doesn't like something... But at the moment I have no idea how it can be fixed...
Did you try to reinstall Steam with "steam --reset" (really, I hate this advice)
Gerry Adams Dec 23, 2013 @ 7:15am 
The original terminal output was longer but it seemed to be just regular output. I'll paste a full log the next time it crashes and I'll try a reset. I'm running 64 bit Ubuntu.
Kranky K. Krackpot Sr. Dec 24, 2013 @ 2:52am 
Originally posted by Horny Nanor:
The original terminal output was longer but it seemed to be just regular output. I'll paste a full log the next time it crashes and I'll try a reset. I'm running 64 bit Ubuntu.
Hmm... Maybe it just needs 32-bit libnss... I found somehow similar in Google:
Bei Problemen mit Spielen im LAN oder über VPN, empfiehlt es sich, die libnss-mdns zu installieren. Unter Debian/Ubuntu/etc. mit "sudo apt-get install libnss-mdns:i386". Das :i386 teilt apt mit, dass ihr auch die i386-Variante der Lib installieren wollt, ansonsten wird nur die amd64-Variante installiert, was euren Spielen meistens nix bringt.
http://www.mrgreen.info/viewtopic.php?f=105&t=2322
Do you have ordinary connection, without firewalls, closed ports and such? Can you check if you have nss installed ("apt-cache -n search nss" shouldl show all names containing "nss").

Anyway, the problem might well be with ATI drivers or elsewhere... Go figure, they say...
Gerry Adams Dec 24, 2013 @ 6:20am 
Here's[pastebin.com] what happens when i run the apt-cache search command. Am I missing necessary libs? Also I managed to segfault again by opening steam this morning. Here's[pastebin.com] the output for that.
Kranky K. Krackpot Sr. Dec 24, 2013 @ 10:51am 
Your new output doesn't show any problems with nss this time... It seems your random crashes are really random... You seem to have problem with fonts, but it shouldn't lead to a crash though.
You might check if you have any libs missing, with this command:
cd ~/.local/share/Steam/ubuntu12_32
LD_LIBRARY_PATH=".:${LD_LIBRARY_PATH}" ldd $(file *|sed '/ELF/!d;s/:.*//g')|grep 'not found'|sort|uniq
https://wiki.archlinux.org/index.php/Steam#Using_native_runtime
Also try "STEAM_RUNTIME=1 steam".
Honestly, at the moment I don't have more meaningful ideas...
PS. Also it'd be worth testing to disable "In-game" access.
Last edited by Kranky K. Krackpot Sr.; Dec 26, 2013 @ 4:53am
Vortex (Combaticon) Dec 26, 2013 @ 1:27am 
I'm running Ubuntu 12.04.3 LTS (no compositing, none of that 3D desktop rendering stuff, clean) and it WAS solid up until some recent update sometime early-to-mid December. After that, it's been less and less stable. It JUST crashed on my a few seconds after joining a TF2 server.

IANKALOU21 killed wisteriaa-ルスキ with market_gardener. (crit)
m_face->glyph->bitmap.width is 0 for ch:12523 Nimbus Sans L
m_face->glyph-ERROR: ld.so: object '/home/miles/.local/share/Steam/ubuntu12_64/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
Uploading dump (out-of-process) [proxy '']
/tmp/dumps/crash_20131226034627_1.dmp
CGameStreamThread: Added instance ID xxxxx for appid xxx
/home/miles/.local/share/Steam/SteamApps/common/Team Fortress 2/hl2.sh: line 67: 30243 Segmentation fault (core dumped) ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"
Game removed: AppID xxx "Team Fortress 2", ProcID xxxxx

(the x's are mine--in case those are uniquely identifyable to me, since I don't know what it's reporting there)

Seems as if some international characters caused a glyph error somewhere in the game and keeps crashing TF2.
Kranky K. Krackpot Sr. Dec 26, 2013 @ 4:46am 
Originally posted by Vortex (Combaticon):
Seems as if some international characters caused a glyph error somewhere in the game and keeps crashing TF2.
If it's really about characters, I've heard that Steem somehow needs corefonts (MS fonts). Nimbus Sans is an alternative to Arial, as far as I know, but Arial is UTF and Nimbus is not. Although, I'm not quite sure...
Gerry Adams Dec 26, 2013 @ 5:13am 
There are about a dozen missing libraries when I run that command. Should I install them all? Steam in game has been disabled already.
Kranky K. Krackpot Sr. Dec 26, 2013 @ 5:27am 
Originally posted by Horny Nanor:
There are about a dozen missing libraries when I run that command. Should I install them all? Steam in game has been disabled already.
Hmm... Generally, Steam must have all libs it needs. Practically, I also have 4-5 "not found" libs when I run that command on my system, but my Steam doesn't crash (it might lack some features, though). So, it depends...
Can you put your "not-founds" here? Did you try it with STEAM_RUNTIME=1?
Last edited by Kranky K. Krackpot Sr.; Dec 26, 2013 @ 5:32am
Gerry Adams Dec 26, 2013 @ 6:40am 
Here[pastebin.com] are my not founds. I'm confused how I run with STEAM_RUNTIME =1. Do I put that in a config file somewhere?
Kranky K. Krackpot Sr. Dec 26, 2013 @ 9:04am 
It all looks more and more strange to me... Do you really have 32-bit libs installed? Check if you have /lib32 and /usr/lib32 dirs and libs in them, and also "apt-cache policy ia32-libs". It looks like Steam misses some 32-bit libs, but doesn't clearly tell anything about it, only segfaults silently. Particularly, this looks very suspicious to me:
libnss3.so => not found
Try "ls /lib32/libnss*" and "ls /usr/lib32/libnss*", it'll show if you have them.
We definitely need someone who knows multiarch on Ubuntu better than me...

And in terminal simply run Steam as "STEAM_RUNTIME=1 steam", i.e. as single line. Maybe it helps, who knows...
Gerry Adams Dec 27, 2013 @ 8:58am 
I have /usr/lib32. apt-cache policy ia32-libs gives me this:

ia32-libs:
Installed: (none)
Candidate: (none)
Version table:

Running STEAM_RUNTIME = 1 doesn't help either.
Kranky K. Krackpot Sr. Dec 27, 2013 @ 1:33pm 
Hmm... It seems you don't have ia32-libs installed, maybe you're on multiarch. Actually, I don't know what exactly 13.10 uses by default now. Do you have nss libs in /usr/lib32 ("ls -l /usr/lib32/libnss*")? If not, I think you should install 32-bin nss libs.
Showing 1-15 of 27 comments
< >
Per page: 15 30 50