Steam for Linux > Limited Beta > Details van topic
dscharrer 27 nov 2012 om 1:01vm
Issue Report: Custom skins don't show up in the settings dialog
Skins placed into the `skins` folder are not listed under Steam -> Setting -> Interface.

This is because Steam tries to access the skin relative to the current directory instead of relative to the skins directory. Relevant part of the strace ('noframe' is the skin name here):
access("/home/dscharrer/Games/Steam/skins", F_OK) = 0
stat64("/home/dscharrer/Games/Steam/skins", {st_mode=S_IFDIR|0700, st_size=4096, ...}) = 0
openat(AT_FDCWD, "/home/dscharrer/Games/Steam/skins", O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY|O_CLOEXEC) = 68
getdents64(68, /* 4 entries */, 32768) = 120
getdents64(68, /* 0 entries */, 32768) = 0
close(68) = 0
access("skins_readme.txt", F_OK) = -1 ENOENT (No such file or directory)
access("skins_readme.txt", F_OK) = -1 ENOENT (No such file or directory)
access("skins_readme.txt", F_OK) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, ".", O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY|O_CLOEXEC) = 68
getdents64(68, /* 43 entries */, 32768) = 1432
getdents64(68, /* 0 entries */, 32768) = 0
close(68) = 0
stat64("skins_readme.txt", 0xffffffffff947aa0) = -1 ENOENT (No such file or directory)
access("noframe", F_OK) = -1 ENOENT (No such file or directory)
access("noframe", F_OK) = -1 ENOENT (No such file or directory)
access("noframe", F_OK) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, ".", O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY|O_CLOEXEC) = 68
getdents64(68, /* 43 entries */, 32768) = 1432
getdents64(68, /* 0 entries */, 32768) = 0
close(68) = 0
stat64("noframe", 0xffffffffff949bd0) = -1 ENOENT (No such file or directory)
access("..", F_OK) = 0
stat64("..", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
access(".", F_OK) = 0
stat64(".", {st_mode=S_IFDIR|0700, st_size=4096, ...}) = 0
access("/home/dscharrer/.steam/registry.vdf", F_OK) = 0
stat64("/home/dscharrer/.steam/registry.vdf", {st_mode=S_IFREG|0600, st_size=2552, ...}) = 0

It is possible to work a round this bug by creating a symlink:
$ cd ~/.steam/root/ && ln -s skins/noframe ./

Once the skin is selected, Steam will load it even without the symlink in the steam root.

I previously reported this as part of this post, but felt a separate post was in order as it wasn't in the beta subforum and this an unrelated issue.
Laatst bewerkt door dscharrer; 27 nov 2012 om 1:02vm
Geplaatst op: 27 nov 2012 om 1:01vm
Aantal berichten: 0