Steam for Linux > Limited Beta > Topic Details
[LoD]Sleekit Nov 26, 2012 @ 8:34pm
Issue Report: PROBLEM: You appear to have OpenGL 1.4.0, but we need at least 2.0.0!
I believe I've now gone through all the drivers in the universe repo;

nvidia-current
nvidia-current-dev
nvidia-current-updates
nvidia-current-updates-dev
nvidia-experimental-304
nvidia-experimental-304-dev
nvidia-experimental-310
nvidia-experimental-310-dev

Currently only 310.14 (nvidia-experimental-310) or 310.19 (straight from nvidia) gives me a working kernel - any of the drivers mentioned I can't even boot past splash.

Currently running:

willwh@win:~$ dpkg -l | grep nvidia
ii nvidia-experimental-310 310.14-0ubuntu1 amd64 Experimental NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-settings-experimental-310 310.14-0ubuntu1 amd64 Tool for configuring the NVIDIA graphics driver

I get:

"You appear to have OpenGL 1.4.0, but we need at least 2.0.0!" When I try to launch TF2.

Please let me know if there is any further info I can provide.

Processor Information:
Vendor: GenuineIntel
Speed: 3701 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.10 (64 bit)
Kernel Name: Linux
Kernel Version: 3.5.0-18-generic
X Server vendor: The X.Org Foundation
X Server release: 11300000

Video Card:
Driver: NVIDIA Corporation GeForce GTX 460/PCIe/SSE2

Driver Version: 1.4 (2.1.2 NVIDIA 310.14)
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID: 0x10de
DeviceID: 0xe22
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1680 x 1050
Desktop Resolution: 1680 x 1050
Primary Display Size: 18.66" x 11.65" (21.97" diag)
47.4cm x 29.6cm (55.8cm diag)
Primary Bus: PCI Express 16x
Primary VRAM Not Detected
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: Realtek ALC889

Memory:
RAM: 7969 Mb

Miscellaneous:
UI Language: English
LANG: en_CA.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 75897 Mb
Largest Free Hard Disk Block: 49977 Mb

Installed software:


willwh@win:~$ glxinfo | grep "version"
server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
OpenGL version string: 4.3.0 NVIDIA 310.14
OpenGL shading language version string: 4.30 NVIDIA via Cg compiler

willwh@win:~$ locate libGL.so.1
/usr/lib/i386-linux-gnu/mesa/libGL.so.1
/usr/lib/i386-linux-gnu/mesa/libGL.so.1.2.0
/usr/lib/nvidia-experimental-310/libGL.so.1
/usr/lib/x86_64-linux-gnu/mesa/libGL.so.1
/usr/lib/x86_64-linux-gnu/mesa/libGL.so.1.2.0
/usr/lib32/nvidia-experimental-310/libGL.so.1
Showing 1-12 of 12 comments
< >
[LoD]Sleekit Nov 26, 2012 @ 8:45pm 
I'm usually kicking around in #ubuntu-steam on freenode IRC.
aka Nov 27, 2012 @ 9:48am 
Did you tried adding the “Ubuntu-X” team ~ X Updates PPA?
It includes several graphical related updates.
https://launchpad.net/~ubuntu-x-swat/+archive/x-updates

I do not think, that Nvidia's proprietary driver includes any OpenGL.
Unit3 Nov 27, 2012 @ 10:30am 
Originally posted by aka:
I do not think, that Nvidia's proprietary driver includes any OpenGL.

Of course it does, why else would you even install the proprietary driver, when the open source driver works fine for 2D usage?

Nvidia's proprietary driver always includes OpenGL support, and newer ones often include OpenCL support as well.
[Linux] timopm Nov 27, 2012 @ 11:05am 
I also wonder why people always mention to add a PPA when the asker clearly is using a newer version than the one provided in that PPA. Sorry about the offtopic, it just happens way too much and bugs me...
[LoD]Sleekit Nov 27, 2012 @ 3:04pm 
timopm - have to agree - that ppa's latest is the 304 drivers, not 310.

Like I said - also tried the latest 310.19 installer from nvidia too :/
[LoD]Sleekit Nov 27, 2012 @ 6:25pm 
http://www.ubuntuupdates.org/ppa/xorg-edgers currently has 310.19 for 12.10.

Running the .run from Nvidia I had issues with, the PPA seems to work very nicely, yay!

Remove your old drivers first:

sudo apt-get remove [nvidia-whatever-you're-using] && [nvidia-settings-whatever-you're-using]

Add PPA & install 310.19

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings
sudo reboot

TF2 running - woot! \o/
Last edited by [LoD]Sleekit; Nov 27, 2012 @ 6:37pm
mindkeep Dec 7, 2012 @ 9:40am 
I encountered this problem on arch linux. Arch has a package titled "extra/libgl" that (conflicts with and )is replaced by "extra/nvidia-utils". What is not immediately obvious is that for a 64 bit system, steam doesn't really care about these.

There is a steam client available in AUR "aur/steam". For x86_64, this package pulls in "multilib/lib32-libgl". With that installed, I see the error "You appear to have OpenGL 1.4.0, but we need at least 2.0.0!" (also encountered when trying to run TF2. The more concerning error was the line before, where it said "Could not find required OpenGL entry point ‘glGetError’!" If you're seeing this also, you probably need the 32 bit version of nvidia-utils.

For Arch, this required installing "multilib/lib32-nvidia-utils" (which replaces "multilib/lib32-libgl"). Hope that helps others.
Last edited by mindkeep; Dec 7, 2012 @ 9:43am
Ghost Missingno. Dec 7, 2012 @ 3:21pm 
I'm not seeing any such package in Ubuntu's repos.
immanetize Dec 7, 2012 @ 3:54pm 
I'm seeing this issue as well. The cause is readily identified from the error given:

Originally posted by bash -x hl2.sh:
SDL failed to create GL compatibility profile (whichProfile=0!
PROBLEM: You appear to have OpenGL 1.4.0, but we need at least 2.0.0!
Could not find required OpenGL entry point 'glGetError'! Either your video card is unsupported, or your OpenGL driver needs to be updated.

The application is hard coded to look for a newer version of OpenGL than the system can provide. The previous post suggest that using the nvidia binary for the 310.19 version of the driver will provide the required libraries.

Are there really *required* features in OpenGL>2.0.0 - or is this an arbitrary check? It doesn't seem sane to me to have a hardcoded dependency on a driver before the community has time to test and package the driver!

*Editing to clarify:
By "community" I'm not referring to PPAs. I can appreciate the work of the hundreds of people out there putting together their own personal package archives, but shipping a production gaming platform that *depends* on PPAs isn't sane. Most distributions have an ideal, default, or otherwise widely accepted third party repository for graphics drivers.

Steam, please let us test your software against known good video drivers. Don't let the success of this beta depend on the users' ability to select the correct PPA.
Last edited by immanetize; Dec 7, 2012 @ 4:03pm
baccilus Dec 7, 2012 @ 7:16pm 
Originally posted by willwh:
http://www.ubuntuupdates.org/ppa/xorg-edgers currently has 310.19 for 12.10.

Running the .run from Nvidia I had issues with, the PPA seems to work very nicely, yay!

Remove your old drivers first:

sudo apt-get remove [nvidia-whatever-you're-using] && [nvidia-settings-whatever-you're-using]

Add PPA & install 310.19

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings
sudo reboot

TF2 running - woot! \o/
This thing worked for me. I am on Linux Mint 14 64 Bit. I have a GTX 560Ti graphic card and had previously installed the driver from nVidia website and was getting the mentioned error. Now my TF2 runs fine. But I must mention that I couldn't fidure out how to install the previous driver. I simply installed the driver from the edgers PPA on top of the previous driver. Everything seems to be working fine.
ErunamoJAZZ Dec 10, 2012 @ 7:48pm 
I previously had installed the .bin nvidia driver, and installed over that, the driver of that repository.
After doing so I could run steam and download TF2, but ... I got the error on this issue, and even reinstalling I could not make it work.

For some reason, he thinks he has OpenGL1.4 instead of OpenGL4.3.

But after deleting the folder ~./.local/share/Steam (making backup of SteamApps folder to avoid losing new TF2), and re-download Steam, it worked.


Thx for the support :)

PD: My System:
AMD Sempron 140 (C2)
4GB ram
GeForce GT430 with driver 310.19
LinuxMint Maya(12.04) amd64
Last edited by ErunamoJAZZ; Dec 10, 2012 @ 7:49pm
adray Dec 12, 2012 @ 1:25am 
Originally posted by mindkeep:
For Arch, this required installing "multilib/lib32-nvidia-utils" (which replaces "multilib/lib32-libgl"). Hope that helps others.
Thanks! worked for me:
Arch x64_86
GTX 560Ti 310.19
Showing 1-12 of 12 comments
< >
Per page: 15 30 50
Date Posted: Nov 26, 2012 @ 8:34pm
Posts: 12