Steam for Linux

Steam for Linux

Steam for Linux > Limited Beta > 제목 정보
Jubei 2012년 11월 26일 오전 8시 27분
Issue Report: TF2 will not start + other issues.
Apologies for consolidating what may be unrelated issues, in one post.

TF2 refuses to start with the error message "There was an error communicating with the steam servers. Make sure you're signed on to steam and try again later." Steam is up and running and is logged in and connected yet TF2 cannot start. I found an old Mac OSX related thread that says this is probably related to the TF2 process cannot communicate with the Steam process but I don't know how to resolve this. They are both run as the same user.

I don't know if it's related but the game spends an awful lot of time stuck on this screen:

I'm pretty sure it's unrelated but my steam client does not display text on the settings menus or small popup windows (like the one when steam is first starting up or the cloud sync window at shutdown) and also on the chat-related windows. Also on pull-down selection boxes the box width is only a few pixels and unreadable.

I tried to access About --> Harware but seeing as there was no text I couldn't navigate the menus, here's the output of my sudo lshw command:
I'm on 12.10 32-bit with Nvidia Quadro FX 4600 and the 310.19 driver.

Finally if I start steam from a terminal window the console window is flooded with the following message:
surface_opengl.cpp (845) : Assertion Failed: !"Current texture not set"
surface_opengl.cpp (505) : Assertion Failed: GetTextureForString failed
Jubei님이 마지막으로 수정; 2012년 11월 29일 오후 2시 47분
< >
1-55개 댓글 표시
aka 2012년 11월 26일 오전 10시 04분 
Try to revalidate the cache files for TF2.
Jubei 2012년 11월 26일 오후 9시 52분 
After revalidation of the cache I now have a TF2 icon on my desktop but otherwise everything is the same.

btw I noticed some interesting error messages:
[1127/] Failed to load /home/jubei/Steam/SteamApps/grjubei/Team Fortress 2/cef_gtk.pak
Some features may not be available.
[1127/] Failed to call method: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.NetworkManager was not provided by any .service files
[1127/] PAC support disabled because there is no system implementation

I have uninstalled network manager and have my own network configuration, could that be the cause?
Jubei님이 마지막으로 수정; 2012년 11월 26일 오후 9시 59분
Ampuj4 2012년 12월 25일 오전 9시 02분 
I have been experiencing very same problem as you. Im currently running chakra linux. Game "starts" fine but cannot connect to anywhere or even start offline game. As it errors that key not active etc...
Jubei 2012년 12월 25일 오후 4시 10분 
Ampuj4: I downgraded to Ubuntu 10.04 and at that point games worked ONCE, then after an update of the steam client I'm back to this error. Let's hope they'll resolve it.
Ampuj4 2012년 12월 26일 오후 12시 05분 
Jubei: Hope so too. Before official launch
< >
1-55개 댓글 표시
페이지당 표시 개수: 15 30 50

Steam for Linux > Limited Beta > 제목 정보