Steam for Linux > Limited Beta > Details van topic
vasi 24 nov 2012 om 6:36nm
Issue Report: Osmos missing libGLU
If I start Osmos, I just get the "Preparing to launch Osmos" dialog, and then nothing happens. No error message is reported, but Osmos doesn't run. This is on Ubuntu 12.10 Quantal.

Running ldd against the Osmos.bin32 binary shows that libGLU.so.1 is not found. Once this is fixed by installing libglu1-mesa:i386, Osmos runs without problems.
1-6 van 6 reacties weergegeven
< >
mmatt 8 dec 2012 om 4:00nm 
I've noticed the same thing... Steam logs the error:
./Osmos.bin32: error while loading shared libraries: libGLU.so.1: cannot open shared object file: No such file or directory

This is on 64-bit Ubuntu 12.04, fresh install.
Sir Garbagetruck 8 dec 2012 om 5:52nm 
The issue I have found is that libGLU (.so.1) is a 32 bit library; yours more than likely is 64bit only. (Mine was, on a fresh Lubuntu 12.10 / upgraded from fresh 12.4)

My solution was to go back to Arch, which I prefer - and then configure multilib there.

But for those of you using Ubuntu/Slackware/Gentoo/Crunchbang/whatever: You should look at how your distro handles multilib, and be sure you have 32 bit libraries as well as 64bit. Most of the games are still 32 bit, and thus you'll need that compatibility/multilib stuff.
Sir Garbagetruck 8 dec 2012 om 5:53nm 
(Incidentally, I do plan on installing Lubuntu in a dualboot config just to be able to compare/debug with both an environment I prefer, and the "supported" environment. So I will eventually have a working multilib 64/32 ubuntu environment for testing as well.)
mmatt 8 dec 2012 om 6:45nm 
I'm also something of an Arch fan, but figured I'd switch to the officially supported platform for the beta... At least I assume 64-bit is supported...
As you've guessed, the issue is that the 32-bit library doesn't seem to be installed as a dependency, which is why vasi (and now I) had to install libglu1-mesa:i386 manually.
As an aside, I actually prefer Ubuntu's handling of multilib to Arch's - lib32-* is a bit ungainly IMO.
mmatt 8 dec 2012 om 6:47nm 
For anyone finding this that isn't clear on how to solve it, type the following into a terminal:
sudo apt-get install libglu1-mesa:i386
kmh42 11 dec 2012 om 1:05nm 
Origineel geplaatst door mmatt:
For anyone finding this that isn't clear on how to solve it, type the following into a terminal:
sudo apt-get install libglu1-mesa:i386

This fix work well on elementaryOS
1-6 van 6 reacties weergegeven
< >
Per pagina: 15 30 50
Geplaatst op: 24 nov 2012 om 6:36nm
Aantal berichten: 6