Steam for Linux

Steam for Linux

Steam for Linux > Limited Beta > 제목 정보
powrtoch 2012년 11월 24일 오전 8시 15분
Issue Report: Trine 2 startup window isn't rendered properly when run through Steam
Distro: ArchLinux 32-bit

When running Trine 2 through Steam the startup window (in which you change video graphics settings) isn't rendered properly.
It should be noted that none of the components on the launcher are shown until the the cursor moves over them.

When running the game using trine2.sh launcher it works/renders great, however.

See this:
http://imgur.com/a/9f6rw

My system information
Processor Information: Vendor: GenuineIntel Speed: 2997 Mhz 2 logical processors 2 physical processors HyperThreading: Unsupported FCMOV: Supported SSE2: Supported SSE3: Supported SSSE3: Supported SSE4a: Unsupported SSE41: Supported SSE42: Unsupported Network Information: Network Speed: Operating System Version: "Arch Linux" (32 bit) Kernel Name: Linux Kernel Version: 3.6.6-1-ARCH X Server vendor: The X.Org Foundation X Server release: 11300000 Video Card: Driver: NVIDIA Corporation GeForce GTX 460/PCIe/SSE2 Driver Version: 4.3.0 NVIDIA 310.19 Desktop Color Depth: 24 bits per pixel Monitor Refresh Rate: 59 Hz VendorID: 0x10de DeviceID: 0xe22 Number of Monitors: 2 Number of Logical Video Cards: 1 Primary Display Resolution: 1680 x 1050 Desktop Resolution: 2960 x 1050 Primary Display Size: 17.05" x 10.67" (20.08" diag) 43.3cm x 27.1cm (51.0cm diag) Primary Bus: PCI Express 16x Primary VRAM: 1023 MB Supported MSAA Modes: 2x 4x 8x 16x Sound card: Audio device: Realtek ALC883 Memory: RAM: 3287 Mb Miscellaneous: UI Language: English LANG: en_GB.UTF-8 Microphone: Not set Total Hard Disk Space Available: 420642 Mb Largest Free Hard Disk Block: 256256 Mb Installed software:
powrtoch님이 마지막으로 수정; 2012년 11월 24일 오전 8시 21분
< >
1-88개 댓글 표시
PvtTUX 2012년 11월 24일 오후 3시 14분 
I also have a similar issue, window is drawn correctly but if you lose focus or drag another window past then it's not redrawn correctly.
I also have the same GPU 460 GTX 1gb
johndrinkwater [🐧︀ 🎮] 2012년 11월 26일 오전 9시 03분 
Same issue, 310.14 drivers, NVIDIA Corporation GeForce GT 630/PCIe/SSE2.
Loader opens fine, but if the window gets shaded & unshaded, the contents are not drawn and must be hovered/tabbed to find the UI components
Barnaby 2012년 11월 26일 오전 9시 24분 
This happened to me a few days ago, but today when I tried it again, its working completely fine.
powrtoch 2012년 12월 7일 오전 7시 31분 
This problem persists on the newest update of Steam.

EDIT: Could a moderator please move this to the correct subforum?
powrtoch님이 마지막으로 수정; 2012년 12월 7일 오전 7시 32분
Michael 2012년 12월 9일 오전 1시 42분 
I notice it doesn't happen if you do

cd ~/Steam/SteamApps/common/Trine 2
LD_LIBRARY_PATH=./lib/lib32 ./bin/trine2_linux_launcher_32bit

So presumably something steam hooks onto the launcher breaks it.
garisboing 2012년 12월 9일 오전 5시 15분 
johndrinkwater님이 먼저 게시:
Same issue, 310.14 drivers, NVIDIA Corporation GeForce GT 630/PCIe/SSE2.
Loader opens fine, but if the window gets shaded & unshaded, the contents are not drawn and must be hovered/tabbed to find the UI components
I confirm. Launcher displays fine but if the window is minimized contents fail to draw correctly
I'm on Fedora 17 KDE 32 bit with nvidia GTX 560 Ti driver version : 304.64
hvr 2012년 12월 11일 오전 5시 40분 
fyi, this seems to be caused by the in-game steam community overlay feature; if you disable it in the steam client settings the launcher works properly
Niko 2012년 12월 16일 오전 4시 58분 
hvr님이 먼저 게시:
fyi, this seems to be caused by the in-game steam community overlay feature; if you disable it in the steam client settings the launcher works properly
thanks for the method, it works! Waiting, when steam in-game will works correctly
Niko님이 마지막으로 수정; 2012년 12월 16일 오전 4시 58분
< >
1-88개 댓글 표시
페이지당: 15 30 50

Steam for Linux > Limited Beta > 제목 정보