Steam for Linux > Limited Beta > 主题详情
Skomli 2012年11月23日上午8:12
Issue Report: Cubemen closes right after start
When starting Cubemen, a window opens and the company logo is shown. Then it fades away. Right after that the window closes. Tried to run it from command line:

bheil@XTR:~/Steam/SteamApps/common/Cubemen$ ./startgame.sh
Found path: /home/bheil/Steam/SteamApps/common/Cubemen/Cubemen
Mono path[0] = '/home/bheil/Steam/SteamApps/common/Cubemen/Cubemen_Data/Managed'
Mono path[1] = '/home/bheil/Steam/SteamApps/common/Cubemen/Cubemen_Data/Mono'
./startgame.sh: Zeile 17: 31490 Abgebrochen (Speicherabzug geschrieben) "${GAMEROOT}"/${GAMEEXE} "$@"

This happens when starting from within Steam or "startgame.sh" or "Cubemen" from command line. Perhaps I'm blind but I can't find the written core dump anywhere. O.o
Something else I can do debug this thing?

Systeminfo from Steam:
Prozessor:
Hersteller: GenuineIntel
Geschwindigkeit: 3301 MHz
4 logische Prozessoren
4 technische Prozessoren
HyperThreading: Nicht unterstützt
FCMOV: Unterstützt
SSE2: Unterstützt
SSE3: Unterstützt
SSSE3: Unterstützt
SSE4a: Nicht unterstützt
SSE41: Unterstützt
SSE42: Unterstützt

Netzwerk-Informationen:
Netzwerk-Geschwindigkeit:

Betriebssystem:
Ubuntu 12.04.1 LTS (64 Bit)
Kernel-Name: Linux
Kernel-Version: 3.2.0-33-generic
X-Server-Vendor: The X.Org Foundation
X-Server-Release: 11103000

Grafikkarte:
Treiber: ATI Technologies Inc. AMD Radeon HD 6800 Series

Treiber-Version: 4.2.11978 Compatibility Profile Context
Desktop-Farbtiefe: 24 Bit per Pixel
Monitor-Aktualisierungsrate: 60 Hz
Anbieterkennung: 0x1002
Gerätekennung: 0x6738
Anzahl der Monitore: 1
Anzahl der logischen Grafikkarten: 1
Prim. Anzeigeauflösung: 1920 x 1080
Desktop-Auflösung: 1920 x 1080
Prim. Anzeigegröße: 52,1 cm x 29,3 cm (59,7 cm diag.)

Kein prim. VRAM entdeckt

Soundkarte:
Audiogerät: 20K1

Speicher:
RAM: 7958 MB

Weitere Daten:
UI-Sprache: Deutsch (Deutsch)
LANG: de_DE.UTF-8
Mikrofon: Not set
Verfügbarer Festplattenspeicher insgesamt: 86399 MB
Größter freier Festplattenspeicherblock: 40583 MB

Installierte Software:
正在显示第 1 - 15 条,共 30 条留言
< >
Meatball 2012年11月29日下午6:03 
I had the same thing happen.

I ran the binary with gdb:

$ cd ~/.local/share/Steam/SteamApps/common/Cubemen
$ LD_LIBRARY_PATH=./:Cubemen_Data/Plugins gdb ./Cubemen

... and got this:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xf79ae700 (LWP 7355)]
0xf35da849 in ?? () from /usr/lib32/fglrx/dri/fglrx_dri.so
(gdb) bt
#0 0xf35da849 in ?? () from /usr/lib32/fglrx/dri/fglrx_dri.so
#1 0x0b137170 in ?? ()
#2 0xf3553390 in ?? () from /usr/lib32/fglrx/dri/fglrx_dri.so
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Which... doesn't say much.

I'm using the AMD beta drivers from precise-backports. Package name: fglrx-experimental-9; Version: 2:9.010-0ubuntu0.1.
nou しにがみ 2013年1月15日上午3:59 
I can confirm this issue. I run it with gdb like Meatball and got same backtrace. Ubuntu 12.04, radeon 5850 latest catalyst 12.11 beta 11.
最后由 nou しにがみ 编辑于; 2013年1月15日上午4:00
Dr0zD[SVK] 2013年1月15日上午9:34 
Same issue here. I'm going to check GitHub (if not duplicate) and post it also there.

EDIT: ok, I've created issue report on GitHub https://github.com/ValveSoftware/steam-for-linux/issues/712

UPDATE: Issue closed. Valve member said we should contact developer. I will do it and give you update.
最后由 Dr0zD[SVK] 编辑于; 2013年1月15日上午9:55
Dr0zD[SVK] 2013年1月15日下午1:48 
I e-mailed support and they respond and it seems like Ati related problem with Unity game engine. They contacted Unity (game engine) Tech Linux team. When any news arrive i will update this thread.
juifeng 2013年1月19日上午10:55 
Works for me. Ubuntu 12.10 64bit, fglrx from Ubuntu repos (currently Catalyst 12.10). Possibly a regression in catalyst 12.11 beta 11? Anyone tried with 13.1 yet?
Dr0zD[SVK] 2013年1月19日上午11:49 
I tried with 13.1 and it's still not working. I'm going to try downgrade to 12.10.
Dr0zD[SVK] 2013年1月19日下午1:12 
Update: I tried 12.8 and 12.10, with both the game is working. It probably really is regression. I e-mailed developer with additional info.
SeonR 2013年1月19日下午1:30 
Hy Guys. All of these details have seen sent to Unity for their Linux team to look over. Yes, the ATI driver situation on Linux is far from ideal... not just a Cubemen specific issue, but I am sure the Unity devs will sort this out as soon as they can.

Thanks everyone for the effort in both reporting this issue and testing out different driver versions and posting your findings here. It's super helpful.
nou しにがみ 2013年1月20日上午7:56 
linux|epic failaments 2013年1月20日下午11:25 
I've got the problem with the crash on the launch in the intro but I don't have Unity, I'm using KDE on openSUSE, I've got an ATI card though.
SeonR 2013年1月21日上午1:59 
Can you please send me your game logs? it is in ~/.config/unity3d/3 Sprockets/Cubemen

Please use my support page... http://cubementd.com/support/

Thanks
linux|epic failaments 2013年1月21日上午2:12 
@seonR

Thank you for your effort, glad to see some devs care about their ports.
I've just sent my report with my hardware info and the player.log
Dr0zD[SVK] 2013年1月21日上午9:06 
@epic fail@linux
You probably encounter same bug as all of us. It's related to Unity Game engine (which the game is based on), not Unity desktop environment.
linux|epic failaments 2013年1月21日上午11:14 
Ah all right, I thought u guys were talking about the desktop (:
Yeah the error message looked similar.
SeonR 2013年1月21日下午6:08 
@epic fail@linux
Thanks for the log, I have passed it on to the Unity Game Engine devs. They have confirmed the issue, but it seems it is going to have to be up to AMD to fix the ATI driver bug as every test so far shows that ATI broke things with their latest drivers and some older drivers are working.

The main issue here is if Unity put a fix in for the bug and then ATI fix it, it might break Unity again and I dont think they are prepared to do that with AMD breaking drivers so often.
正在显示第 1 - 15 条,共 30 条留言
< >
每页显示数: 15 30 50