Steam for Linux > Limited Beta > Détails du sujet
Skomli 23 nov 2012 à 8h12
Issue Report: Cubemen closes right after start
When starting Cubemen, a window opens and the company logo is shown. Then it fades away. Right after that the window closes. Tried to run it from command line:

bheil@XTR:~/Steam/SteamApps/common/Cubemen$ ./
Found path: /home/bheil/Steam/SteamApps/common/Cubemen/Cubemen
Mono path[] = '/home/bheil/Steam/SteamApps/common/Cubemen/Cubemen_Data/Managed'
Mono path[1] = '/home/bheil/Steam/SteamApps/common/Cubemen/Cubemen_Data/Mono'
./ Zeile 17: 31490 Abgebrochen (Speicherabzug geschrieben) "${GAMEROOT}"/${GAMEEXE} "$@"

This happens when starting from within Steam or "" or "Cubemen" from command line. Perhaps I'm blind but I can't find the written core dump anywhere. O.o
Something else I can do debug this thing?

Systeminfo from Steam:
Hersteller: GenuineIntel
Geschwindigkeit: 3301 MHz
4 logische Prozessoren
4 technische Prozessoren
HyperThreading: Nicht unterstützt
FCMOV: Unterstützt
SSE2: Unterstützt
SSE3: Unterstützt
SSSE3: Unterstützt
SSE4a: Nicht unterstützt
SSE41: Unterstützt
SSE42: Unterstützt


Ubuntu 12.04.1 LTS (64 Bit)
Kernel-Name: Linux
Kernel-Version: 3.2.0-33-generic
X-Server-Vendor: The X.Org Foundation
X-Server-Release: 11103000

Treiber: ATI Technologies Inc. AMD Radeon HD 6800 Series

Treiber-Version: 4.2.11978 Compatibility Profile Context
Desktop-Farbtiefe: 24 Bit per Pixel
Monitor-Aktualisierungsrate: 60 Hz
Anbieterkennung: 0x1002
Gerätekennung: 0x6738
Anzahl der Monitore: 1
Anzahl der logischen Grafikkarten: 1
Prim. Anzeigeauflösung: 1920 x 1080
Desktop-Auflösung: 1920 x 1080
Prim. Anzeigegröße: 52,1 cm x 29,3 cm (59,7 cm diag.)

Kein prim. VRAM entdeckt

Audiogerät: 20K1

RAM: 7958 MB

Weitere Daten:
UI-Sprache: Deutsch (Deutsch)
Mikrofon: Not set
Verfügbarer Festplattenspeicher insgesamt: 86399 MB
Größter freier Festplattenspeicherblock: 40583 MB

Installierte Software:
Affichage des commentaires 1 à 15 sur 30
< >
Meatball 29 nov 2012 à 18h03 
I had the same thing happen.

I ran the binary with gdb:

$ cd ~/.local/share/Steam/SteamApps/common/Cubemen
$ LD_LIBRARY_PATH=./:Cubemen_Data/Plugins gdb ./Cubemen

... and got this:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xf79ae700 (LWP 7355)]
0xf35da849 in ?? () from /usr/lib32/fglrx/dri/
(gdb) bt
#0 0xf35da849 in ?? () from /usr/lib32/fglrx/dri/
#1 0x0b137170 in ?? ()
#2 0xf3553390 in ?? () from /usr/lib32/fglrx/dri/
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Which... doesn't say much.

I'm using the AMD beta drivers from precise-backports. Package name: fglrx-experimental-9; Version: 2:9.010-0ubuntu0.1.
nou 死神 15 jan 2013 à 3h59 
I can confirm this issue. I run it with gdb like Meatball and got same backtrace. Ubuntu 12.04, radeon 5850 latest catalyst 12.11 beta 11.
Dernière modification de nou 死神; 15 jan 2013 à 4h00
Dr0zD[SVK] 15 jan 2013 à 9h34 
Same issue here. I'm going to check GitHub (if not duplicate) and post it also there.

EDIT: ok, I've created issue report on GitHub

UPDATE: Issue closed. Valve member said we should contact developer. I will do it and give you update.
Dernière modification de Dr0zD[SVK]; 15 jan 2013 à 9h55
Dr0zD[SVK] 15 jan 2013 à 13h48 
I e-mailed support and they respond and it seems like Ati related problem with Unity game engine. They contacted Unity (game engine) Tech Linux team. When any news arrive i will update this thread.
juifeng 19 jan 2013 à 10h55 
Works for me. Ubuntu 12.10 64bit, fglrx from Ubuntu repos (currently Catalyst 12.10). Possibly a regression in catalyst 12.11 beta 11? Anyone tried with 13.1 yet?
Dr0zD[SVK] 19 jan 2013 à 11h49 
I tried with 13.1 and it's still not working. I'm going to try downgrade to 12.10.
Dr0zD[SVK] 19 jan 2013 à 13h12 
Update: I tried 12.8 and 12.10, with both the game is working. It probably really is regression. I e-mailed developer with additional info.
SeonR 19 jan 2013 à 13h30 
Hy Guys. All of these details have seen sent to Unity for their Linux team to look over. Yes, the ATI driver situation on Linux is far from ideal... not just a Cubemen specific issue, but I am sure the Unity devs will sort this out as soon as they can.

Thanks everyone for the effort in both reporting this issue and testing out different driver versions and posting your findings here. It's super helpful.
nou 死神 20 jan 2013 à 7h56 
b4cki ❤ Katzii3 20 jan 2013 à 23h25 
I've got the problem with the crash on the launch in the intro but I don't have Unity, I'm using KDE on openSUSE, I've got an ATI card though.
SeonR 21 jan 2013 à 1h59 
Can you please send me your game logs? it is in ~/.config/unity3d/3 Sprockets/Cubemen

Please use my support page...

b4cki ❤ Katzii3 21 jan 2013 à 2h12 

Thank you for your effort, glad to see some devs care about their ports.
I've just sent my report with my hardware info and the player.log
Dr0zD[SVK] 21 jan 2013 à 9h06 
@epic fail@linux
You probably encounter same bug as all of us. It's related to Unity Game engine (which the game is based on), not Unity desktop environment.
b4cki ❤ Katzii3 21 jan 2013 à 11h14 
Ah all right, I thought u guys were talking about the desktop (:
Yeah the error message looked similar.
SeonR 21 jan 2013 à 18h08 
@epic fail@linux
Thanks for the log, I have passed it on to the Unity Game Engine devs. They have confirmed the issue, but it seems it is going to have to be up to AMD to fix the ATI driver bug as every test so far shows that ATI broke things with their latest drivers and some older drivers are working.

The main issue here is if Unity put a fix in for the bug and then ATI fix it, it might break Unity again and I dont think they are prepared to do that with AMD breaking drivers so often.
Affichage des commentaires 1 à 15 sur 30
< >
Par page : 15 30 50