Steam for Linux > Limited Beta > Détails du sujet
AIRMAN 22 nov 2012 à 15h21
Issue Report: Font glyphs not displaying in TF2
Without setting any environment variables I get the following when starting tf2:
http://i.imgur.com/iqsmz.png, basically a black screen (my window manager, dwm, maintains focus on the steam client)

When calling steam with `SDL_AUDIODRIVER=alsa LC_NUMERIC=POSIX steam steam://rungameid/440` I get:
http://i.imgur.com/3mEzP.png

`locale -a` gives
C
en_GB.utf8
POSIX

I've had a look around the thread but can't find anything relevant, any ideas?

System Specs:
Processor Information:
Vendor: GenuineIntel
Speed: 2668 Mhz
8 logical processors
4 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
"Arch Linux" (64 bit)
Kernel Name: Linux
Kernel Version: 3.6.6-1-ARCH
X Server vendor: The X.Org Foundation
X Server release: 11300000

Video Card:
Driver: X.Org Gallium 0.4 on AMD CYPRESS

Driver Version: 3.0 Mesa 9.0.1
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x1002
DeviceID: 0x6898
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 20.51" x 11.54" (23.50" diag)
52.1cm x 29.3cm (59.7cm diag)
Primary VRAM Not Detected

Sound card:
Audio device: AV200

Memory:
RAM: 5964 Mb

Miscellaneous:
UI Language: English
LANG: en_GB.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 41927 Mb
Largest Free Hard Disk Block: 17112 Mb

Installed software:
Affichage des commentaires 1 à 9 sur 9
< >
AIRMAN 27 nov 2012 à 4h29 
Forgot to add, running dwm as my WM with no DE.

Anyone got any ideas?
mikesart 29 nov 2012 à 22h09 
This still happening? I've seen this exact thing when you do "mat_showmiplevels 1". We fixed it, but that won't get out until next week. Have you done anything like that by any chance?
AIRMAN 8 déc 2012 à 6h54 
I may have, I by default hooked up my cfg folder from my windows install which uses chris's maxframes config. I've recently wiped arch and am trying with xubuntu to see what happens.

If you'd like me to load arch back on and provide any more information let me know.
mikesart 8 déc 2012 à 18h05 
I'll try to install Arch here - I need to give it a try. Thanks for the help.
AIRMAN 9 déc 2012 à 7h14 
I've reverted to arch, clean install, no configs.

On my last try I'd copied the .gcf files from my windows install to my linux SteamApps folder. I figure this wont be a problem, but just so everything is clean I've kept my cfg folder open and am installing TF2 from steam without copying the gcf's.

I'll let you know how I go.
AIRMAN 9 déc 2012 à 10h26 
It seem for the clean install that it works fine, no font glyph issues.

It loads of up in what appears to be 640x480. The only problem I'm now having is the the onscreen mouse position doesn't map to where the game seems to think it is, and the mouse is locked to travelling within the game screen so there are some buttons that can;'t be clicked (i.e. the "continue" from the motd when you first join a server).

Changing the launch options to `-sw -w 1280 -h 960` allows me to change the resolution and fixes the mapping of the mouse pointer, so I assume it's just a full screen problem.
Dernière modification de AIRMAN; 9 déc 2012 à 10h28
mikesart 15 déc 2012 à 7h43 
Are you saying it loaded up fullscreen at 640x480 and there were mouse issues?
AIRMAN 15 déc 2012 à 12h48 
Yes, ignored the launch options for fullscreen as well.

The onscreen position -> game menu position mapping was off.
AIRMAN 16 déc 2012 à 7h11 
Sorry , I'll be more clear.

On a clean install it loaded up in fullscreen at 640x480 and there were mouse issues (mapping of on screen cursor position to where the in-game menu registered it).

Adding launch option '-w 1280 -h 960' had no effect, it still loads in 640x480 in full screen and the mouse issues are still present

Adding launch options '-sw -w 1280 -h 960' sovles the problems, it launches in windowed mode at the correct resolution and there are no mouse issues.
Affichage des commentaires 1 à 9 sur 9
< >
Par page : 15 30 50