Steam for Linux > Limited Beta > Topic Details
whiskydotjar Nov 22, 2012 @ 8:26am
Issue Report: Serious Sam 3: BFE very low performance
:( AMD...
Showing 1-15 of 25 comments
< >
AlenL Nov 22, 2012 @ 12:58pm 
Nice. Very descriptive. :)
noname Nov 22, 2012 @ 12:59pm 
Same. Radeon HD 6870, Phenom II X4 955. 16 GB RAM. SSD. fglrx 12.10.

Get about 50-70 fps in Windows and about 10-25 in Linux (ie. unplayable). I also tried with the public beta, the performance was about the same.

Is there any hope for the AMD cards or should I just go buy an nvidia card? :/

What performance is people with Intel CPUs and/or Nvidia GPUs getting?
Last edited by noname; Nov 22, 2012 @ 1:15pm
keks Nov 22, 2012 @ 1:45pm 
Fredrik, did you try to disable Cool'N'Quiet or PowerNow in your bios? That should improve your performance a bit. You could also try to decrease some graphics options and find out what's causing the slowdown. Also, please post your Sam3.log file (after running public beta, as that has more useful info in the log)
Last edited by keks; Nov 22, 2012 @ 1:46pm
LinuxFanatic[Russia] Nov 22, 2012 @ 2:21pm 
Agree, you should turn off Cool and Quiet or Power Now + enable Turbo Core technology (for processors that's supporting it) inside BIOS to fix that problem.
noname Nov 22, 2012 @ 2:21pm 
Originally posted by keks:
Fredrik, did you try to disable Cool'N'Quiet or PowerNow in your bios? That should improve your performance a bit. You could also try to decrease some graphics options and find out what's causing the slowdown. Also, please post your Sam3.log file (after running public beta, as that has more useful info in the log)

Disabling Cool 'n Quiet did not have any effect on the frame rate. As far as performance options go nothing but the GPU options had any effect.

The things that did most for the performance were anti aliasing, ambient occlusion and no dynamic lighting. (Perhaps not so surprising). The other stuff had little to no effect, at least not on the map I'm on (the first one). If I disable these three things I get a framerate somewhere between 20 and 40 fps.

As for the log file, what's the preferred way of submitting it? It's quite long. Some pastebin?

The most interesting part from it is probably

22:50:17 WRN: Cannot load PCI library; GPU vendor and device ID are unknow!

I did get an error-window about this the first time I started the public beta. Some 32/64 bit issue I believe?

It also seems to believe that I have 512 MB RAM with 0 MB free.

22:50:17 LOG: * Memory...
22:50:17 LOG: Total physical memory: 512 MB
22:50:17 LOG: Free physical memory: 0 MB
Last edited by noname; Nov 22, 2012 @ 2:22pm
cheveedodd Nov 22, 2012 @ 5:44pm 
No surprise, near zero performance on an i5 with Intel HD integrated. The game actually loads, but textures don't. Kinda neat to walk around in an unshaded, all white landscape... just not at ~1fps. :-)
ThOR27 Nov 22, 2012 @ 5:53pm 
Originally posted by fredrik.hultin:
22:50:17 WRN: Cannot load PCI library; GPU vendor and device ID are unknow!

sudo apt-get install libpci3:i386

noname Nov 22, 2012 @ 10:48pm 
Originally posted by ThOR27:
sudo apt-get install libpci3:i386

Thanks, I'll try that later today and report back.
noname Nov 24, 2012 @ 9:22am 
Ok, so I installed libpci3 and it got rid of the message in the log about unknown GPU vendor. It didn't noticeably change the performance though. I'm still seeing 10-25 fps in Linux and 50-70 fps in windows with everything set to high.

That's almost 3X the performance in Windows over Linux.

Here's the latest log
http://hastebin.com/gesobapoho.vbs
SkaarjZR Dec 15, 2012 @ 6:00am 
I get 10-15 FPS while playing and I'm not happy with it :(

Processor Information:
Vendor: AuthenticAMD
Speed: 3100 Mhz
2 logical processors
2 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.04.1 LTS (64 bit)
Kernel Name: Linux
Kernel Version: 3.2.0-34-generic
X Server vendor: The X.Org Foundation
X Server release: 11103000

Video Card:
Driver: NVIDIA Corporation GeForce 9600 GT/PCIe/SSE2

Driver Version: 3.3.0 NVIDIA 310.14
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x10de
DeviceID: 0x622
Number of Monitors: 2
Number of Logical Video Cards: 1
Primary Display Resolution: 1280 x 1024
Desktop Resolution: 2560 x 1024
Primary Display Size: 13,31" x 10,63" (17,01" diag)
33,8cm x 27,0cm (43,2cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 512 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: Realtek ALC888

Memory:
RAM: 2003 Mb

Miscellaneous:
UI Language: English
LANG: ru_RU.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 480069 Mb
Largest Free Hard Disk Block: 404036 Mb

Installed software:

Recent Failure Reports:
Beamboom [Linux] Dec 15, 2012 @ 6:15am 
For whatever it's worth, it's running smooth here on a 64bit Ubuntu 12.04.
GPU: GeForce GTX-460. I can't compare it to Windows though, cause I have no Windows partition on this machine.

keks Dec 15, 2012 @ 7:21am 
Originally posted by SkaarjZR:
I get 10-15 FPS while playing and I'm not happy with it :(
Please post your Sam3.log file here.
SkaarjZR Dec 15, 2012 @ 7:25am 
keks Dec 15, 2012 @ 10:03am 
You can try disabling cpu power saving in your bios, that should improve your performance. You can also try to use lower graphics and cpu speed preferences in the game.
SkaarjZR Dec 15, 2012 @ 11:02am 
Thank you!
I've switched cool&quite off and changed all performances to low.
FPS raised to ~30.
Showing 1-15 of 25 comments
< >
Per page: 15 30 50