Steam for Linux > Limited Beta > Detalhes do tópico
p4dev 22 Nov, 2012 às 4:57
Ubuntu 12.04 - Optirun - Nvidia Experimental 310
I have a notebook, DELL XPS L502X with an Nvidia GT540m 2gb.
In it, I'm using Ubuntu 12.04 x64, along with Bumblebee / Optirun experimental Nvidia driver (310) - recommended by Steam.

The problem so far is:
In Windows (dual boot), I run Trine 2 for 50 ~ 70 FPS.
On Linux, it runs at 10 ~ 15 FPS.

With that I'm not sure if the "optirun" is working (already tested the optirun and is working)

> Optirun glxspheres
Polygons in scene: 62464
Visual ID of window: 0x21
Context is Direct
OpenGL Renderer: GeForce GT 540M/PCIe/SSE2
106.644392 frames / sec - 119.015141 Mpixels / sec
126.806494 frames / sec - 127.738350 Mpixels / sec
127.081138 frames / sec - 123.952909 Mpixels / sec

I have also tested it with the "primusrun" and is working well.

But on Steam, everything is extremely slow.
You know why?
A mostrar 1-10 de 10 comentários
< >
Fantu 22 Nov, 2012 às 6:34 
I also tried running game with optirun but probably run with optirun only steam, not game and need some tweak for running games with optirun (probably searching the .sh of the games and modify it)
Someone that have already optirun working on game can give a correct soluction please?
kukimane 22 Nov, 2012 às 10:57 
which repo are you using for that? Are you using the "nvidia-graphics-drivers-experimental-310" https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-experimental-310
p4dev 22 Nov, 2012 às 11:46 
Originalmente postado por kukimane:
which repo are you using for that? Are you using the "nvidia-graphics-drivers-experimental-310" https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-experimental-310

Yep, this exactly!
p4dev 22 Nov, 2012 às 11:46 
Originalmente postado por Fantu:
I also tried running game with optirun but probably run with optirun only steam, not game and need some tweak for running games with optirun (probably searching the .sh of the games and modify it)
Someone that have already optirun working on game can give a correct soluction please?

I don't know my friend, but, the games run soo slow for me.
iskeledz 22 Nov, 2012 às 11:56 
It might be possible to optirun games, but it won't work this way. You have to find the executable of the game (in home/steam/steamapps) and try to optirun it. I also have an Optimus laptop and I simply gave up because I couldn't get it to work with the Nvidia card.
Fiftybottles 22 Nov, 2012 às 16:50 
As far as I know, it's not even possible to get the experimental 310 drivers working with Bumblebee. When I tried to, it compeltely ignored Bumblebee and gave me no hardware acceleration. If you did, however, figure out a way to get this working please let us know how!

In addition, iskeledz is right, the games need to be launched from their directory with the command.
Ethuil 6 Dez, 2012 às 16:28 
Try to run across terminal, like:
optirun bash
steam
-----
Steam running like app in bash that runned with bumblebee, and all apps that steam will run will use bumblebee too.
That worked for me in steam across wine, need to check how it works with native, just received access.
JaySee 9 Dez, 2012 às 12:54 
The trick you gave above doesn't work. Output below:

jon@linux ~ $ optirun bash
jon@linux ~ $ steam
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
Installing breakpad exception handler for appid(steam)/version(1354925460_client)
Xlib: extension "NV-GLX" missing on display ":0".
SteamUpdateUI: An X Error occurred
X Error of failed request: BadAlloc (insufficient resources for operation)

Then it just hangs til i kill it
WhatYouSeeIsWhatYouGet 9 Dez, 2012 às 13:20 
Guys,
You need to manually hack Bumblebee's configuration to get it to recognise Ubuntu's nvidia-experimental-310 package, otherwise it defaults to using the nvidia-current package's kernel driver.
See here for instructions: http://www.webupd8.org/2012/12/use-nvidia-experimental-drivers-310.html
Also remember that Primus will give you better performance than Bumblebee because it doesn't use VirtualGL.
Última alteração por WhatYouSeeIsWhatYouGet; 9 Dez, 2012 às 13:21
BuD 10 Dez, 2012 às 1:33 
Launching glxspheres in my Ivy Bridge Laptop with latest Nvidia Experimental 310 and primusrun prints this:

user@computername:~$ vblank_mode=0 glxspheres
Polygons in scene: 62464
ATTENTION: default value of option vblank_mode overridden by environment.
ATTENTION: default value of option vblank_mode overridden by environment.
Visual ID of window: 0xae
Context is Direct
OpenGL Renderer: Mesa DRI Intel(R) Ivybridge Mobile
144.947420 frames/sec - 141.172699 Mpixels/sec
146.315654 frames/sec - 142.505301 Mpixels/sec
148.580116 frames/sec - 144.710793 Mpixels/sec
148.820109 frames/sec - 144.944536 Mpixels/sec

user@computername:~$ vblank_mode=0 primusrun glxspheres
Polygons in scene: 62464
ATTENTION: default value of option vblank_mode overridden by environment.
ATTENTION: default value of option vblank_mode overridden by environment.
Visual ID of window: 0xae
ATTENTION: default value of option vblank_mode overridden by environment.
ATTENTION: default value of option vblank_mode overridden by environment.
Context is Direct
OpenGL Renderer: GeForce GT 630M/PCIe/SSE2
primus: sorry, not implemented: glXUseXFont
130.591689 frames/sec - 127.190820 Mpixels/sec
133.792229 frames/sec - 130.308012 Mpixels/sec
134.886381 frames/sec - 131.373670 Mpixels/sec
133.962257 frames/sec - 130.473612 Mpixels/sec


This is shocking, Intel's stills going a bit faster, is this possible?

By the way: Yes, I edited primusrun scripts and bumblebee.conf following this instructions: http://www.webupd8.org/2012/12/use-nvidia-experimental-drivers-310.html
Última alteração por BuD; 10 Dez, 2012 às 1:35
A mostrar 1-10 de 10 comentários
< >
Por página: 15 30 50
Postado a: 22 Nov, 2012 às 4:57
Comentários: 10