Steam for Linux > Limited Beta > Emneoplysninger
whiskydotjar 22. nov 2012 kl. 3:46am
Issue Report: Main window title is "Unnamed Window"
Shouldn't it be "Steam for Linux"?
Viser 1-11 af 11 kommentarer
< >
SUSEd 22. nov 2012 kl. 3:54am 
Same on Ubuntu and openSUSE. It causes that gnome-shell shows ugly lo-res steam icon instead cool iPad-like hi-res Faenza icon.
Not only main window, all steam windows unnamed.
Sidst redigeret af SUSEd; 22. nov 2012 kl. 3:56am
Nevon 22. nov 2012 kl. 4:59am 
I can confirm that this happens in gnome-shell 3.6.1 in Ubuntu 12.10. It only started happening after the last update.
johndrinkwater [🐧︀ 🎮] 22. nov 2012 kl. 5:16am 
This should be fixed with the next update, mentioned here http://steamcommunity.com/app/221410/discussions/1/882965118613110112/#c882966056664860137
Sidst redigeret af johndrinkwater [🐧︀ 🎮]; 22. nov 2012 kl. 9:07am
Spacefish 22. nov 2012 kl. 8:40am 
Can confirm this, but i think its trivial to fix and does not impact the functionality of the application.
Netsu 7. dec 2012 kl. 1:12am 
I'm also experiencing the issue, all Steam windows are named 'Untitled', I'm running Arch Linux with Compiz+Tint2.
whiskydotjar 7. dec 2012 kl. 1:14am 
Update the client! It fixed!
Netsu 7. dec 2012 kl. 1:19am 
It didn't fix it for me unfortunately. Steam info says I'm using version v012 built Dec 5 2012 at 13:13:48.
I did install it from the Arch User Repository and not through Ubuntu though, is it possible that the initial installation source can cause this or should I be able to always keep my client up-to-date by using the built in update feature?
mruuh 7. dec 2012 kl. 1:26am 
Seems to work fine here. xprop reports:
WM_NAME(UTF8_STRING) = "Steam"
WM_CLASS(STRING) = "Steam", "Steam"

I have the same Steam build as you.
Netsu 7. dec 2012 kl. 1:47am 
Oh, haven't thought about checking with xprop, it gives the same results as yours.
Although looking at other applications I use they seem to have titles set up like this:

WM_NAME(STRING) = "Title"
_NET_WM_NAME(UTF8_STRING) = "Title"

While steam only provides WM_NAME and uses UTF8 in this field. I don't know if there are any standards that dictate how this should be set up but it seems the problem stems from Steam doing it differently than everything else.
Sidst redigeret af Netsu; 7. dec 2012 kl. 1:47am
mruuh 7. dec 2012 kl. 2:16am 
You know, you're right. Spec says that _NET_WM_NAME should be set by client: http://standards.freedesktop.org/wm-spec/latest/ar01s05.html#id2760156
Viser 1-11 af 11 kommentarer
< >
Per side: 15 30 50
Dato postet: 22. nov 2012 kl. 3:46am
Indlæg: 11