Steam for Linux > Limited Beta > Emnedetaljer
imamdxl8805 21. nov, 2012 @ 10:37pm
Steam on Intel GMA only starts with Mesa 9
the console dump when running Steam with Mesa 7.11.2

/home/emamk/Steam/steam.sh: line 132: gksudo: command not found
Installing breakpad exception handler for appid(steam)/version(1353457964_client)
Installing breakpad exception handler for appid(steam)/version(1.0)
unlinked 0 orphaned pipes
Installing breakpad exception handler for appid(steam)/version(1.0)
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
[1122/170549:WARNING:proxy_service.cc(646)] PAC support disabled because there is no system implementation
Installing breakpad exception handler for appid(steam)/version(1.0)
Installing breakpad exception handler for appid(steam)/version(1.0)
Installing breakpad exception handler for appid(steam)/version(1.0)
Installing breakpad exception handler for appid(steam)/version(1.0)
Process 2502 created /ValveIPCSharedObjects3
Installing breakpad exception handler for appid(steam)/version(1.0)
Uploading dump (in-process) [proxy '']
/tmp/dumps/crash_20121122170551_1.dmp
success = yes
response: CrashID=bp-d9107eba-dd5d-4c4f-9340-798792121121

/home/emamk/Steam/steam.sh: line 255: 2502 Segmentation fault (core dumped) $DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"

if I install Mesa 9 again launch steam it runs then.

On Intel GMA 4500 MHD, many games still fail to run with Mesa 9 due to major bugs in the driver but Mesa 7.11.2 runs those games fairly well.

Serious Sam BFE does not show anything when running with Mesa 9, only sound can be heard. But if I install Mesa 7.11.2 without closing steam and run Serious Sam BFE than it runs fine.

Closing steam and launching again with Mesa 7.11.2, steam fails to start showing above terminal output. Installing Mesa 9 lets steam run again.

Why Steam crashes with Mesa 7.11.2 since many games are not playable on Mesa 9 but with Mesa 7.11.2 for Intel GMA 4500

major Mesa 9 bugs still not fixed:

https://bugs.freedesktop.org/show_bug.cgi?id=47169
https://bugs.freedesktop.org/show_bug.cgi?id=56632
https://bugs.freedesktop.org/show_bug.cgi?id=56705


I have driver for Mesa 9 and 7.11.2 on the following site

http://www.youtube.com/watch?v=9klAxeQsHlQ&feature=channel&list=UL

Mesa 9: http://www.mediafire.com/?2rj8ltahhawxsdn
Mesa 7.11: http://www.mediafire.com/?szd93k4v6626afj


System:

Ubuntu 12.10
Linux 3.5 (both 32 and 64 bit)
X.Org X Server 1.13.0
xf86-video-intel 2.20.10
libdrm 2.4.39
Mesa 9 and 7.11.2

Hardware: Intel GMA 4500 MHD (device id 2a42)

Regards,
Emamdxl
Dato lagt ut: 21. nov, 2012 @ 10:37pm
Innlegg: 0