Steam for Linux > Limited Beta > 제목 정보
CondescendingOwl 2012년 11월 21일 오후 10시 11분
Extra overhead in TF2 causes reduced graphics performance until restart
This issue occurs in both linux and windows, but to a much greater extent in the linux version.

It is likely primarily a hardware issue, which Valve can't address, but software clearly contributes. The purpose of this report is to 1) see if there are others with this issue, and gather support for a software/firmware fix (if possible) and 2) suggest that further optimizations have an immediate practical benefit, even for discrete graphics users.

Description: Team Fortress 2 starts fine and plays well for a very short while, causing extreme load to the gpu even under the most conservative settings (with DX9). This load causes overheating.

In windows, this can be largely averted by preventing gpu overheating with a manual fan override to full speed. The same override in linux is not sufficient to prevent the overheating, indicating a relatively larger load. Nothing short of a restart returns normal playing conditions, at least temporarily.

Again, this is most likely to be a hardware issue. The hardware is a Thinkpad T520 with switchable graphics, set to discrete graphics mode in the BIOS (nVidia Quadro NVS 4200m card). This is a somewhat common set of linux hardware, as Thinkpads are linux-friendly.

Thanks for reading! I appreciate any replies or suggestions on how to proceed, and hope this is a helpful report.
2개 중 1-2 표시중
< >
Vash 2012년 11월 21일 오후 10시 53분 
This doesn't sound like a software issue at all, it sounds like either your video card driver and/or PC OEM fan setup was insufficient for the hardware or something is wrong with how they're operating in Linux. A properly designed system should be able to handle full load power draw on all components without issue.

If you want to lighten the load on your system, you could always set fps_max to something lower to reduce GPU load, this works in both Windows and Linux.

Short version: A game properly loading your system to use as much of your system's resources as available for peak performance is a good thing. If you want to save energy, set your own framerate caps and turn down settings.
XeroA SenSei 2012년 12월 9일 오전 6시 26분 
Well, as to what i know, Quadro graphics chipsets have a slight different instruction set as GEforce does. That can cause isntruction overhead, cause it needs to do more calculations to achieve the same effect. It is also possible your cooling fans are malfunctioning. Try to run diagnostics on your GPU and you gpu/system fans to ascertain this.
2개 중 1-2 표시중
< >
페이지당: 15 30 50
게시된 날짜: 2012년 11월 21일 오후 10시 11분
게시글: 2