Steam for Linux > Limited Beta > Detaily tématu
rose 21. lis. 2012 v 10.08 odp.
PROBLEM: You appear to have OpenGL 0.0.0, but we need at least 2.0.0!
I'm running the 310 experimental nVidia driver. Latest kernel. Keep getting this error.
The following comes from the console.

ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
SDL video target is 'x11'
SDL video target is 'x11'
SDL failed to create GL compatibility profile (whichProfile=0!
PROBLEM: You appear to have OpenGL 0.0.0, but we need at least 2.0.0!
Could not find required OpenGL entry point 'glGetError'! Either your video card is unsupported, or your OpenGL driver needs to be updated.
Zobrazeno 1-15 z 20 komentářů
< >
CondescendingOwl 21. lis. 2012 v 10.19 odp. 
If this is while loading a game, which game is it? And which linux distribution + release?
rose 21. lis. 2012 v 10.25 odp. 
Sorry. I should have been more specific
Team Fortress 2. Xubuntu 12.04

Also, system information:

Processor Information:
Vendor: GenuineIntel
Speed: 3401 Mhz
8 logical processors
4 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.04.1 LTS (64 bit)
Kernel Name: Linux
Kernel Version: 3.2.0-34-generic
X Server vendor: The X.Org Foundation
X Server release: 11103000

Video Card:
Driver: NVIDIA Corporation GeForce GT 520/PCIe/SSE2

Driver Version: 4.3.0 NVIDIA 310.14
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 0 Hz
VendorID: 0x10de
DeviceID: 0x1040
Number of Monitors: 1
Number of Logical Video Cards: 2
Primary Display Resolution: 5440 x 1661
Desktop Resolution: 5440 x 1661
Primary Display Size: 53.86" x 16.46" (56.30" diag)
136.8cm x 41.8cm (143.0cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 1023 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: Realtek ALC892

Memory:
RAM: 7951 Mb

Miscellaneous:
UI Language: English
LANG: en_AU.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 205326 Mb
Largest Free Hard Disk Block: 84784 Mb

The video card information is a tad confused because I actually have two video cards with three monitors but am running them as one large virtual desktop.

Also the sound card which is actually being used is a USB Razer Megalodon.
rose 21. lis. 2012 v 11.39 odp. 
I downgraded to nvidia-current-updates and TF2 runs perfectly. Before it refused to launch. I guess the experimental drivers aren't always the solution. :\
johndrinkwater [🐧︀ 🎮] 22. lis. 2012 v 3.58 dop. 
Does this problem happen with other games in the Beta, Serious Sam 3 for instance? its good to hear it might be a regression in the 310 update, but please test with the 310.14 driver for the other games.
Naposledy upravil johndrinkwater [🐧︀ 🎮]; 22. lis. 2012 v 4.04 dop.
rose 22. lis. 2012 v 3.59 dop. 
I'll get back to you on that. Currently downloading it.
Plagman 26. lis. 2012 v 12.28 odp. 
Hi,

Could it be that you ended up with two copies of the libGL client library installed? Can you run nvidia-bug-report.sh and upload the output somewhere when the issue is happening? Additionally, can you double-check which copy of libGL TF2 loads by running something like 'pmap `pidof hl2_linux`' when it's in that error state?

Thanks,
- Pierre-Loup
torbjoern.o 9. pro. 2012 v 8.33 dop. 
Hi BAU,

I have almost exactly the same problem as you. For me the solution when running on Nvidia 310.19 was to remove one of the graphic cards. I have one old and one really old card.

After removing the really old card (a GeForce 8500GT) it works again.
I TELL YOU HWHUT 10. pro. 2012 v 5.22 odp. 
Yup, I have the same problem. Running nVidia 304.64, FC17, Linux 3.6.8.
Brano 13. pro. 2012 v 2.02 odp. 
Yup, I have the same problem. Running nVidia 304.64, FC17, Linux 3.6.8.

Hi, try to install 32bit nvidia libraries:
yum install xorg-x11-drv-nvidia-libs.i686
I TELL YOU HWHUT 13. pro. 2012 v 5.52 odp. 
@Brano, thank you, it has gotten me further. Now, the game just dies silently.

/home/user/Steam/SteamApps/steamname/Team Fortress 2/hl2.sh: line 72: 2497 Segmentation fault (core dumped) ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"
mikesart 18. pro. 2012 v 10.47 dop. 
Can you post the CrashID you're getting? Thanks.
vggonz 18. pro. 2012 v 2.34 odp. 
Same problem to me, even with the Steam Client version of Dec 14. My only "strange" video configuration are two monitors (1 Flat screen and 1 TV) attached to my video card sharing desktop. It says I have a screen resolution of 2960 x 1050, but my principal monitor is only 1680x1050.

Sorry for my english.

Información sobre el procesador:
Fabricante: GenuineIntel
Velocidad: 2800 Mhz
Procesadores lógicos 2
Procesadores físicos 2
HyperThreading: No compatible
FCMOV: Compatible
SSE2: Compatible
SSE3: Compatible
SSSE3: Compatible
SSE4a: No compatible
SSE41: Compatible
SSE42: No compatible

Información sobre la red:
Velocidad de la red:

Versión de Windows:
Ubuntu 12.04.1 LTS (32 bits)
Nombre de kernel: Linux
Versión de kernel: 3.2.0-25-generic-pae
Editor de X Server: The X.Org Foundation
Versión de X Server: 11103000

Tarjeta de vídeo:
Controlador: NVIDIA Corporation GeForce 9600 GT/PCIe/SSE2

Versión de controlador: 3.3.0 NVIDIA 310.14
Densidad de color del escritorio: 24 bits por píxel
Frecuencia de actualización del monitor: 0 Hz
Identificador del fabricante: 0x10de
Identificador del dispositivo: 0x622
Número de monitores: 1
Número de tarjetas de vídeo lógicas: 1
Resolución de pantalla principal: 2960 x 1050
Resolución de escritorio: 2960 x 1050
Tamaño de pantalla principal: 29,88" x 10,71" (31,73" diag)
75,9cm x 27,2cm (80,6cm diag)
Bus principal: PCI Express 16x
Memoria VRAM principal: 512 MB
Modos MSAA compatibles: 2x 4x 8x 16x

Tarjeta de sonido:
Dispositivo de sonido: Realtek ALC1200

Memoria:
RAM: 4027 Mb

Varios:
Idioma de la IU: Español
LANG: es_ES.UTF-8
Micrófono: Not set
Espacio total en disco disponible: 76194 MB
Bloque libre más grande en el disco: 29471 MB

Software Instalado:

Recent Failure Reports:
mikesart 18. pro. 2012 v 4.15 odp. 
There should be something like "CrashID=bp-fb6b404e-6cd3-4527-a2c8-cd5892121218". Please post what that is and I can look at the backtrace to see where it's crashing. Unless it's exiting without crashing?
$torM!@Linux! 19. pro. 2012 v 11.38 dop. 
Same issue here, running nVidia v310.19 drivers on arch linux with a 9800GT card. pmap output: http://www.jpirie.com/files/pmap-output console output: http://www.jpirie.com/files/console-output . Any hints and tips much welcomed :)
Naposledy upravil $torM!@Linux!; 19. pro. 2012 v 11.39 dop.
mikesart 19. pro. 2012 v 11.56 dop. 
As my good friend Pierre-Loup from nVidia says, that's a symptom of not having a sane GL install. Can you install the mesa-utils package and send us the glxinfo output? And does glxgears run? Perhaps someone with some Arch experience can help you out hopefully...
Zobrazeno 1-15 z 20 komentářů
< >
Na stránku: 15 30 50