Steam for Linux > Limited Beta > Topic Details
› Rio Nov 21, 2012 @ 9:44pm
Issue Report: TF2 ingame voice issue
Outbound voice in game does not work when the server being played on is using "sv_use_steam_voice 0". No errors appear in either the console or command line.

Steps to reproduce this issue:

- Open the console and enter in sv_use_steam_voice 0. This can be done either in a locally hosted game or in the main menu for TF2

- Go to voice chat options and test microphone using the voice chat tester. Alternatively if in a match you can open up the console and enter in voice_loopback 1 to test the microphone.

-Switch between sv_use_steam_voice 0 and sv_use_steam_voice 1 via the console. Outbound voice works when 1 is set. Outbound voice stops working when 0 is set.

System Information:

Processor Information:
Vendor: AuthenticAMD
Speed: 3400 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.04.1 LTS (32 bit)
Kernel Name: Linux
Kernel Version: 3.2.0-33-generic-pae
X Server vendor: The X.Org Foundation
X Server release: 11103000

Video Card:
Driver: NVIDIA Corporation GeForce GTX 560/PCIe/SSE2/3DNOW!

Driver Version: 4.3.0 NVIDIA 310.14
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x10de
DeviceID: 0x1201
Number of Monitors: 2
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 3360 x 1080
Primary Display Size: 20.04" x 11.26" (22.95" diag)
50.9cm x 28.6cm (58.3cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 1023 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: Nvidia GPU 16 HDMI/DP

Memory:
RAM: 8072 Mb

Miscellaneous:
UI Language: English
LANG: en_AU.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 120187 Mb
Largest Free Hard Disk Block: 91177 Mb

Installed software:




Showing 1-4 of 4 comments
< >
› Rio Nov 23, 2012 @ 5:18pm 
So does anyone else experience this issue or is it just me?
Frank Nov 30, 2012 @ 2:14pm 
Rio, we have had voice issues in the past so we'll look into it with this new information.
Last edited by Frank; Nov 30, 2012 @ 2:14pm
Electrifry Dec 13, 2012 @ 8:40pm 
I am having the exact same problem, and fiddling with sv_use_steam_voice yielded similar results. I have an external and internal microphone, with steam set to use my external. When in game, I tried using both of my microphones just to see if tf2 was defaulting to my internal mic when sv_use_steam_voice was 0, but neither worked. Here's my system information:


Processor Information:
Vendor: GenuineIntel
Speed: 2401 Mhz
8 logical processors
4 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.10 (64 bit)
Kernel Name: Linux
Kernel Version: 3.5.0-19-generic
X Server vendor: The X.Org Foundation
X Server release: 11300000

Video Card:
Driver: Intel Open Source Technology Center Mesa DRI Intel(R) Ivybridge Mobile x86/MMX/SSE2

Driver Version: 3.0 Mesa 9.0
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x10de
DeviceID: 0xde9
Number of Monitors: 1
Number of Logical Video Cards: 2
Primary Display Resolution: 1600 x 900
Desktop Resolution: 1600 x 900
Primary Display Size: 15.04" x 8.46" (17.24" diag)
38.2cm x 21.5cm (43.8cm diag)
Primary VRAM Not Detected

Sound card:
Audio device: Intel PantherPoint HDMI

Memory:
RAM: 7875 Mb

Miscellaneous:
UI Language: English
LANG: en_CA.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 930852 Mb
Largest Free Hard Disk Block: 860506 Mb

Installed software:
Aloz1 Dec 16, 2012 @ 8:53pm 
I'm also getting the same problem. As the previous 2 people have suggested, changing sv_use_steam_voice to 1 fixes the issue. Here is my hardware info:


Processor Information:
Vendor: GenuineIntel
Speed: 2401 Mhz
8 logical processors
4 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
"Arch Linux" (64 bit)
Kernel Name: Linux
Kernel Version: 3.6.10-1-ARCH
X Server vendor: The X.Org Foundation
X Server release: 11300902

Video Card:
Driver: ATI Technologies Inc. AMD Radeon HD 6900M Series

Driver Version: 4.2.11978 Compatibility Profile Context
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x1002
DeviceID: 0x6720
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 13.54" x 7.60" (15.51" diag)
34.4cm x 19.3cm (39.4cm diag)
Primary VRAM Not Detected

Sound card:
Audio device: Realtek ALC892

Memory:
RAM: 7967 Mb

Miscellaneous:
UI Language: English
LANG: C
Microphone: Not set
Total Hard Disk Space Available: 362904 Mb
Largest Free Hard Disk Block: 169894 Mb

Installed software:

Recent Failure Reports:
Mon Dec 17 00:30:17 2012 GMT: file ''/tmp/dumps/assert_20121217113009_1.dmp'', upload yes: ''CrashID=bp-f4424d3e-a757-4071-91e8-cf5c92121216''

Showing 1-4 of 4 comments
< >
Per page: 15 30 50