Steam for Linux > Limited Beta > Topic Details
Mk2 Nov 21, 2012 @ 1:39pm
Issue Report: Enter your password to update /usr/bin/steam/
Upon launching Steam for the first time I've gotten this popup box:
Enter your password to update /usr/bin/steam/

It seems you can ignore this popup and carry on using games however the box itself will not close. At one point the same box kept coming up multiple times after installing Amnesia then lagged the OS out. I rebooted and all seems fine apart from this popup box. Any idea of whats causing this?
Last edited by Mk2; Nov 21, 2012 @ 1:39pm
Showing 1-4 of 4 comments
< >
Baltharon Nov 21, 2012 @ 1:56pm 
I seem to also have this problem, haven’t tested yet so i don't know if it creates lag, but pressing cancel on it seems to make it go away.
Mk2 Nov 21, 2012 @ 2:07pm 
It comes back for me, I think it's something to do with wanting sudo root access... It think... I'm still a bit of a Linux noob.
Letalis Sonus Nov 21, 2012 @ 2:55pm 
Steam wants to update its starter script, but as it is actually part of the original .deb package and it gets installed system-wide, it needs root rights to replace the old script.
It is actually not very elegant, the proper way of doing it would be setting up a small repository so it can be updated through the package system - just replacing stuff is kind of breaking the consistency which may lead to mayor problems in more complex scenarios.
Mk2 Nov 21, 2012 @ 3:46pm 
Ah gotcha! So I'd imagine they'd change it to that in later revisions anyways to prevent such things happening. Thanks for pointing that out!
Showing 1-4 of 4 comments
< >
Per page: 15 30 50
Date Posted: Nov 21, 2012 @ 1:39pm
Posts: 4