Steam for Linux

Steam for Linux

Steam for Linux > Limited Beta > 主題細節
SUSEd 2012 年 11 月 21 日 @ 上午 9 時 00 分
Issue Report: Team Fortress 2 on Linux loads much more time then on Windows or Wine.
Tested on Windows 8, Ubuntu 12.10, wine 1.5.17 (x86_64) on same PC.

On Windows
Cold Start: ~30 s.
Restarting: <10 s.

On Ubuntu
Cold start: 2 min. 20 s.
Restarting ~2 min

Wine (1.5.17)
Cold start: ~30 s.
Restarting: <30 s.

HW: Intel Core I5 3570k@3400 MHz with builtin graphics and 4 GB 1333 Mhz DDR3 RAM.

More HW info (translated)
Processor:     Supplier: GenuineIntel     Clock Frequency: 3401 MHz     Number of logical processors: 4     Number of physical processors: 4     HyperThreading: Unsupported     FCMOV: Supported     SSE2: Supported     SSE3: Supported     SSSE3: Supported     SSE4a: Not Supported     SSE41: Supported     SSE42: Supported      Network:     Connection Speed:      OS version:     "OpenSUSE 12.2 (x86_64)" (64 bit)     Name of the kernel: Linux     Core Version: 3.6.7-1-desktop     Supplier X Server: The X.Org Foundation     Version X Server: 11300000      Video:     Model: Intel Open Source Technology Center Mesa DRI Intel (R) Ivybridge Desktop x86/MMX/SSE2     Driver version: 3.0 Mesa 9.0     Color Depth: 24 bits / pixel     Refresh Rate: 75 Hz     Vendor ID: 0x8086     ID cards: 0x162     Number of screens: 1     The number of logical video: 1     Permission to decrease. Display: 1280 x 1024     Desktop resolution: 1280 x 1024     Size core. screen: In inches: 13,31 "x 10,63" (diagonal 17.01 ") In cm: 33,8 cm x 27,0 cm (43.2 cm diagonal)     Video memory size is not defined      Sound Card:     Audio device: Intel CougarPoint HDMI      Memory:     Memory: 3669 MB      Miscellaneous:     Language: Russian     LANG: ru_UA.utf8     Microphone: Not set     Disk Space: 938900 MB     Most free disk: 620 657 MB
最後修改者:SUSEd; 2012 年 11 月 23 日 @ 下午 11 時 47 分
< >
顯示 1-15,共 76 則回應
ElectricKetchup 2012 年 11 月 21 日 @ 上午 9 時 05 分 
I was thinking it took a long time too. Have you also noticed that the loading of the map time is significantly longer too? I haven't run the windows version since I got in the beta, so I haven't compared the numbers, but it feels longer.
James Pond 2012 年 11 月 21 日 @ 上午 9 時 08 分 
+1

It also lags a lot from times to times with my Intel HD 3000 on Ubuntu 12.10 Unity, even if I put everything on low.

Processor Information: Vendor: GenuineIntel Speed: 2301 Mhz 4 logical processors 2 physical processors HyperThreading: Supported FCMOV: Supported SSE2: Supported SSE3: Supported SSSE3: Supported SSE4a: Unsupported SSE41: Supported SSE42: Supported Network Information: Network Speed: Operating System Version: Ubuntu 12.10 (64 bit) Kernel Name: Linux Kernel Version: 3.7.0-030700rc6-generic X Server vendor: The X.Org Foundation X Server release: 11300000 Video Card: Driver: Intel Open Source Technology Center Mesa DRI Intel(R) Sandybridge Mobile x86/MMX/SSE2 Driver Version: 3.0 Mesa 9.0 Desktop Color Depth: 24 bits per pixel Monitor Refresh Rate: 59 Hz VendorID: 0x8086 DeviceID: 0x116 Number of Monitors: 1 Number of Logical Video Cards: 1 Primary Display Resolution: 1440 x 900 Desktop Resolution: 1440 x 900 Primary Display Size: 14,57" x 9,13" (17,17" diag) 37,0cm x 23,2cm (43,6cm diag) Primary VRAM Not Detected Sound card: Audio device: Intel CougarPoint HDMI Memory: RAM: 3868 Mb Miscellaneous: UI Language: English LANG: pt_BR.UTF-8 Microphone: Not set Total Hard Disk Space Available: 441292 Mb Largest Free Hard Disk Block: 371383 Mb

I tryed to set my CPU governor to performance to see if I could see a improvement, but it did not helped.
SUSEd 2012 年 11 月 21 日 @ 上午 10 時 02 分 
Julian Fernandes 發表:
+1

It also lags a lot from times to times with my Intel HD 3000 on Ubuntu 12.10 Unity, even if I put everything on low.

HD 3000 is not so fast as 4000, for me it works normal on middle settings.
SUSEd 2012 年 11 月 21 日 @ 上午 10 時 06 分 
ElectricKetchup 發表:
I was thinking it took a long time too. Have you also noticed that the loading of the map time is significantly longer too? I haven't run the windows version since I got in the beta, so I haven't compared the numbers, but it feels longer.

Yes, map loads longer but not so notisable as startup.
James Pond 2012 年 11 月 21 日 @ 上午 10 時 10 分 
shished 發表:
Julian Fernandes 發表:
+1

It also lags a lot from times to times with my Intel HD 3000 on Ubuntu 12.10 Unity, even if I put everything on low.

HD 3000 is not so fast as 4000, for me it works normal on middle settings.

I know it isn't, but if the bug is related to Intel drivers or Intel GPUs itself, both cards benefits.
zzecool 2012 年 11 月 21 日 @ 上午 10 時 57 分 
Yeap it is an ubuntu problem with the Cache system ...

Everything in ubuntu after a cold start takes too much time to load even Chrome.
The solution is a nice deamon by a google dev :D called preload .

http://techthrob.com/2009/03/02/drastically-speed-up-your-linux-system-with-preload/

Without preload Chrome launch after cold start : 14 sec
With preload Chrome launch after cold start : 3.5 sec !!!


Try it and you will bless my name ;p
最後修改者:zzecool; 2012 年 11 月 21 日 @ 上午 10 時 59 分
James Pond 2012 年 11 月 21 日 @ 上午 11 時 12 分 
@zzecool I use Preload since forever, and the problem still happens with TF2.
最後修改者:James Pond; 2012 年 11 月 21 日 @ 上午 11 時 12 分
SUSEd 2012 年 11 月 21 日 @ 上午 11 時 13 分 
zzecool 發表:
Yeap it is an ubuntu problem with the Cache system ...

Everything in ubuntu after a cold start takes too much time to load even Chrome.
The solution is a nice deamon by a google dev :D called preload .

http://techthrob.com/2009/03/02/drastically-speed-up-your-linux-system-with-preload/

Without preload Chrome launch after cold start : 14 sec
With preload Chrome launch after cold start : 3.5 sec !!!


Try it and you will bless my name ;p

Also tried to launch TF2 on openSUSE and got same results.
Preload will give ~10% speedup.
Problem is deeper then caching.
zyvod 2012 年 11 月 21 日 @ 上午 11 時 43 分 
Just to throw in my $.02, but I don't see this on my system, I see faster load times than under Windows 7. However, I have a fast SSD (Intel 520) and plenty of RAM (16GB). Loading games should be primarily I/O limited, so it makes sense that on a faster I/O system, the problem would disappear.

If you've got a fast SSD and are still seeing this, next thing I'd check is your Linux filesystem. Most distros default to ext3, which is really slow. If you're storing your Steam install on an XFS partition (mounted with noatime, naturally), then I expect you'll see faster load times than Windows, like I do.
plebtorian 2012 年 11 月 21 日 @ 上午 11 時 55 分 
I too have an SSD ( OCZ Vertex 4 128GB firmware 1.5 ) and getting much longer loading times compared to TF2 using wine or windows
johndrinkwater [🐧︀ 🎮] 2012 年 11 月 21 日 @ 下午 12 時 54 分 
Could this be related to fragmentation then?
Silent 2012 年 11 月 21 日 @ 下午 12 時 58 分 
Hi. Ultrabook here with 1920x1080p display, i5, HD4000, 4GB RAM and 128GB SSD, Ubuntu 12.10, ext4 file system and still loading like hell.

Also, THIS !!!
Everything on low/disabled. Also tried enabling/disabling multi-core rendering. Same thing.

Julian Fernandes 發表:
+1

It also lags a lot from times to times with my Intel HD 3000 on Ubuntu 12.10 Unity, even if I put everything on low.

I tryed to set my CPU governor to performance to see if I could see a improvement, but it did not helped.
最後修改者:Silent; 2012 年 11 月 21 日 @ 下午 1 時 00 分
zzecool 2012 年 11 月 21 日 @ 下午 1 時 47 分 
Fragmentation doesn't exist in linux , because of the nature of the filesystem.

Maybe poor I/O performance based on bad driver is the problem
jay 2012 年 11 月 21 日 @ 下午 1 時 59 分 
Silent Death 發表:
It also lags a lot from times to times with my Intel HD 3000 on Ubuntu 12.10 Unity, even if I put everything on low.

Check if steam itself goes to 100% CPU usage once TF2 is done loading. This is my problem, and it's really frustrating because it makes TF2 completely unplayable.
James Pond 2012 年 11 月 21 日 @ 下午 2 時 48 分 
jay 發表:
Silent Death 發表:
It also lags a lot from times to times with my Intel HD 3000 on Ubuntu 12.10 Unity, even if I put everything on low.

Check if steam itself goes to 100% CPU usage once TF2 is done loading. This is my problem, and it's really frustrating because it makes TF2 completely unplayable.

That could be the issue, since it seems TF2 is CPU bound and Steam is having problems with load (Frank said they are working on it). It also makes sense, since the games lags only from time to time.
< >
顯示 1-15,共 76 則回應
每頁: 15 30 50

Steam for Linux > Limited Beta > 主題細節