Steam for Linux

Steam for Linux

Steam for Linux > Limited Beta > Téma részletei
Issue Report: TF2 fails to load launcher
I cannot run Team Fortress 2 with either my integrated or discrete graphics card. When clicking on play in the steam interface, I get this output:
Game update: AppID 440 "Team Fortress 2", ProcID 30569, IP 0.0.0.0:0 ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored. ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored. ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored. ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored. ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored. ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored. Failed to load the launcher Game removed: AppID 440 "Team Fortress 2", ProcID 30569 saving roaming config store to 'sharedconfig.vdf' roaming config store 2 saved successfully saving roaming config store to 'sharedconfig.vdf' roaming config store 2 saved successfull
When trying to run the game with my graphics card via primusrun ./hl2_linux from the directory, I get 'Failed to load the launcher' as the only output, with nothing being sent to steam (no response from steam being run in another terminal). What launcher is it talking about?

EDIT: I've wiped all local content relating to TF2 and have started the re-download, will report the results.
Legutóbb szerkesztette: [FFS] Barbarian; 2012. nov. 21., de. 6:37
< >
110/10 megjegyzés mutatása
Well, after removing everything TF2 related and re-downloading and installing it, it was complaining about a missing gameinfo.txt. I got a copy of another linux user's gameinfo.txt, put it in the hl2 directory, and the game launched.

I am, however, right back to where I was a few days ago, documented here: http://steamcommunity.com/app/221410/discussions/1/882966056509734039/
Legutóbb szerkesztette: [FFS] Barbarian; 2012. nov. 21., de. 8:35
Could you provide your system information and the desktop manager you're using? In addition, have you tried installing and playing Serious Sam 3:BFE? It is also free to play for the beta period.
Seems how you launch it causes this issue. If you launch from the command line it will not produce an icon, if you launch using the Steam icon, then all launchers show.
I'm using Gentoo 64 bit, my window manager is Awesome, with steam and games set as floating so they are not tiled.

Serious Sam 3: BFE works great (everything running perfectly smooth, not sure of exact FPS but feels 50+, everything on maximum settings). Here's the bash scriptlet I use to launch Serious Sam 3 while steam is open:
#!/bin/bash cd ~/Steam/SteamApps/common/Serious\ Sam\ 3/Bin LD_LIBRARY_PATH=~/Steam/ubuntu12_32 primusrun ./Sam3

I'm using the nVidia 310.19 proprietary driver for a Geforce GT 540m,
Output of uname -a
Linux james-gentoo 3.5.7 #1 SMP Sat Oct 27 13:30:40 BST 2012 x86_64 Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz GenuineIntel GNU/Linux
GCC 4.6.3, (specifically updated due to steam dependencies)
glibc version 2.15-r3
emul-linux-x86 libraries dated 2012 10 28 (again specifically for steam)
I don't know what else you may need, please tell me if you need more

A side-note is that an update you made to TF2 last week meant that it no longer even launched the unusable menu that I was getting. It wouldn't load engine.so and crash at that point. The update today fixed that issue and I'm now back to the unusable menu. I have no idea if those issues are related or not. My guess would be no, but I'm including it here for completeness' sake.
Legutóbb szerkesztette: [FFS] Barbarian; 2012. nov. 28., du. 1:54
Same issue here, Gentoo 64bit with KDE 4.9.4.
I can launch TF2 Beta with some hacks described here: http://steamcommunity.com/app/221410/discussions/1/882966056509734039/
Without the script, i get a segfault.
TF2 (not beta) launched with the script hangs on loading, without script segfaults.
I have this issue too. I'm using 64-bit Lubuntu 12.10. I have installed xfce and unity. With unity and xfce I get this gameoverlayrenderer.so error. I'm not sure about lxde as I tried it first and it had a lot of glitches in main steam windows so I tried other desktops.

I use bumblebee with primusrun and nvidia r310 driver, nvidia_experimental_310 in jockey app.

Launching steam:
user@ubuntu:~$ primusrun steam Installing breakpad exception handler for appid(steam)/version(1354925460_client) Installing breakpad exception handler for appid(steam)/version(1354925460_client) unlinked 0 orphaned pipes Installing breakpad exception handler for appid(steam)/version(1354925460_client) [1208/214150:WARNING:proxy_service.cc(646)] PAC support disabled because there is no system implementation Installing breakpad exception handler for appid(steam)/version(1354925460_client) Installing breakpad exception handler for appid(steam)/version(1354925460_client) Installing breakpad exception handler for appid(steam)/version(1354925460_client) Installing breakpad exception handler for appid(steam)/version(1354925460_client) Installing breakpad exception handler for appid(steam)/version(1354925460_client) Generating new string page texture 2: 48x256, total string texture memory is 49,15 KB Generating new string page texture 3: 256x256, total string texture memory is 311,30 KB Installing breakpad exception handler for appid(steam)/version(1354925460_client) Installing breakpad exception handler for appid(steam)/version(1354925460_client) Installing breakpad exception handler for appid(steam)/version(1354925460_client) Adding license for package 8538 Adding license for package 6877 Adding license for package 16549 Adding license for package 0 roaming config store loaded successfully - 894 bytes. migrating temporary roaming config store ExecCommandLine: "/home/user/.local/share/Steam/ubuntu12_32/steam" Generating new string page texture 73: 1024x256, total string texture memory is 1,36 MB Generating new string page texture 74: 128x256, total string texture memory is 1,49 MB Generating new string page texture 75: 128x256, total string texture memory is 131,07 KB Generating new string page texture 76: 64x256, total string texture memory is 1,56 MB Generating new string page texture 77: 8x256, total string texture memory is 1,56 MB Generating new string page texture 78: 32x256, total string texture memory is 1,60 MB Generating new string page texture 84: 128x256, total string texture memory is 1,73 MB Generating new string page texture 100: 384x256, total string texture memory is 2,12 MB System startup time: 9,45 seconds Installing breakpad exception handler for appid(steam)/version(1354925460_client) ExecSteamURL: "steam://open/driverhelperready"

Starting TF2 from the button in steam:
Installing breakpad exception handler for appid(steam)/version(1354925460_client) Installing breakpad exception handler for appid(steam)/version(1354925460_client) Game update: AppID 440 "Team Fortress 2", ProcID 2454, IP 0.0.0.0:0 ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored. ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored. ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored. ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored. ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored. ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored. saving roaming config store to 'sharedconfig.vdf' roaming config store 2 saved successfully /home/user/.local/share/Steam/SteamApps/my_username/Team Fortress 2/hl2.sh: rivi 72: 2461 Muistialueen ylitys (luotiin core-tiedosto) ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@" Game removed: AppID 440 "Team Fortress 2", ProcID 2454 saving roaming config store to 'sharedconfig.vdf' roaming config store 2 saved successfully

I could get rid of that gameoverlayrenderer.so error with these instructions:
http://steamcommunity.com/app/221410/discussions/1/882966056489905719/#c882966056545653907

When launching TF2 from console with that command from the link I get this:
user@ubuntu:~/.local/share/Steam/SteamApps/my_username/Team Fortress 2$ LANG=C LC_NUMERIC=C SteamAppId=440 vblank_mode=0 primusrun ./hl2.sh -steam -console -game tf -novid /home/user/.local/share/Steam/SteamApps/my_username/Team Fortress 2/hl2.sh: line 72: 2516 Segmentation fault (core dumped) ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"
But I still get that segmentation fault. Still, a step in better direction.

EDIT: I forgot to add hardware infos, so here they are:
Processor Information: Vendor: GenuineIntel Speed: 2301 Mhz 4 logical processors 2 physical processors HyperThreading: Supported FCMOV: Supported SSE2: Supported SSE3: Supported SSSE3: Supported SSE4a: Unsupported SSE41: Supported SSE42: Supported Network Information: Network Speed: Operating System Version: Ubuntu 12.10 (64 bit) Kernel Name: Linux Kernel Version: 3.5.0-19-generic X Server vendor: The X.Org Foundation X Server release: 11300000 Video Card: Driver: NVIDIA Corporation GeForce GT 540M/PCIe/SSE2 Driver Version: 4.3.0 NVIDIA 310.14 Desktop Color Depth: 24 bits per pixel Monitor Refresh Rate: 60 Hz VendorID: 0x10de DeviceID: 0xdf4 Number of Monitors: 1 Number of Logical Video Cards: 2 Primary Display Resolution: 1920 x 1080 Desktop Resolution: 1920 x 1080 Primary Display Size: 13,54" x 7,60" (15,51" diag) 34,4cm x 19,3cm (39,4cm diag) Primary VRAM: 1023 MB Sound card: Audio device: Intel CougarPoint HDMI Memory: RAM: 3858 Mb Miscellaneous: UI Language: English LANG: fi_FI.UTF-8 Microphone: Not set Total Hard Disk Space Available: 187017 Mb Largest Free Hard Disk Block: 149096 Mb Installed software: Recent Failure Reports:
Legutóbb szerkesztette: parsukka; 2012. dec. 8., du. 12:15
Did you try Barbarian's script? It solved gameoverlayrenderer.so for me.
Anyway, you can get additional infos about segfault with "dmesg | tail"
I modified Barbarian's script a bit and got this command:
LD_LIBRARY_PATH=/home/user/.local/share/Steam/SteamApps/my_username/Team\ Fortress\ 2/bin/:/home/user/.local/Steam/ubuntu12_32/:/home/user/.steam/bin/:$LD_LIBRARY_PATH primusrun ./hl2_linux -game tf2

TF2 starts successfully.
Legutóbb szerkesztette: parsukka; 2012. dec. 9., de. 4:14
Finally found the problem: hl2.sh was missing "~/.local/Steam/ubuntu12_32/" in LD_LIBRARY_PATH.
I had this problem too, and while fixing the library path works, if someone out there wants a simple solution, on Steam's menu go to View->Settings->In-Game, and uncheck "Enable Steam Community In-Game." I also had this problem with other games such as Space Pirates and Zombies (SPAZ). This allowed me to play them, though it's a bit sad to not have access to steam in game,
< >
110/10 megjegyzés mutatása
Laponként: 15 30 50

Steam for Linux > Limited Beta > Téma részletei
Küldés ideje: 2012. nov. 21., de. 6:33
Hozzászólások: 10