Steam for Linux > Limited Beta > Подробности за темата
johndrinkwater [🐧︀ 🎮] 20 ноември 2012 в 1:24сут.
Issue Report: [UI] Steam update asks for password…
with an dialog that looks like I shouldn’t trust it.
http://i.imgur.com/vRXDX.jpg
Показване на 1-10 от 10 коментара
< >
Julian Fernandes 20 ноември 2012 в 3:11сут. 
Same here. Then it start this bug (http://steamcommunity.com/app/221410/discussions/1/882966056254927824/).

Started to happen after I downloaded TF2 and made the fix to work in any language. Worth mentioning I did a fresh Ubuntu 12.10 install and it still happens.
SUSEd 20 ноември 2012 в 5:43сут. 
Password needed to update /usr/bin/steam file.
AnAkkk 20 ноември 2012 в 5:56сут. 
I have the same issue.
GER | tuxator 29 ноември 2012 в 1:01след. 
issue persists. Please Valve fix this. Either by putting all your binaries into the /home directory of the user (which would be, by far, the best variant since it would work on all Linux distributions). Or chown the directory where you store your binaries.
scott_test123 29 ноември 2012 в 1:39след. 
The binaries are stored in your home directory at an appropriate location. It only wants to update the launcher script, which is stored in /usr/bin/steam. We've seen the feedback from you and others on this issue and are considering how to handle it.
branchman 29 ноември 2012 в 2:35след. 
GER | tuxator: just FYI, chown would not be safe (other user could replace binary with key-logging binary)
scott_test123: one solution would be making suid binary. But suid binary is not very elegant way and is often considered to be insecure when used by processes except su, ping and maybe some more. Policykit would be more elegant way to do this. Another way could be making a repository and forcing user to update, but it is not very user-friendly. This also adds more platform dependencies...
T0xicCode 29 ноември 2012 в 3:04след. 
The main issue is that gksudo is ran by the steam.sh script with the "--disable-grab" option. Simply removing that option from the command makes the box a lot more trustworthy, mainly due to grabing the focus.
daaxwizeman 30 ноември 2012 в 6:22след. 
I got this dialog too and if I recall, when I provided my password, Steam never starts again after that. I had to reinstall it and, prior to that, I had to erase all /.steam folder.
Tykin 1 декември 2012 в 3:52след. 
daax is correct; uninstall the steam package and delete the .steam directory in your home directory.

After reinstalling the package, steam is working properly.

Edit: I believe this problem occurred after steam crashed while downloading TF2. Can anyone else confirm when this issue started for them?
Последно редактиран от Tykin; 1 декември 2012 в 3:53след.
daaxwizeman 2 декември 2012 в 7:48сут. 
Hi Tykin, even after the reinstall, I still get this dialog prompting for a password. I didn't provided it though.... and Steam is still working.
Показване на 1-10 от 10 коментара
< >
На страница: 15 30 50
Дата на публикуване: 20 ноември 2012 в 1:24сут.
Публикации: 10