Steam for Linux > Limited Beta > Topic Details
slikjay Nov 17, 2012 @ 8:38am
Issue Report: Trine 2
If you press Alt playing Trine 2 the game will minimize and then don't work in fullscreen mode.

Also, sometimes (i saw this once), after I pressed Alt, the game has minimized and the "Steam is closing" dialog appeared.

Ubuntu 12.10 Unity

Processor Information:
Vendor: GenuineIntel
Speed: 3301 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.10 (32 bit)
Kernel Name: Linux
Kernel Version: 3.5.0-18-generic
X Server vendor: The X.Org Foundation
X Server release: 11300000

Video Card:
Driver: NVIDIA Corporation GeForce GTX 570/PCIe/SSE2

Driver Version: 4.3.0 NVIDIA 310.14
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x10de
DeviceID: 0x1086
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 20.08" x 11.42" (23.07" diag)
51.0cm x 29.0cm (58.6cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 1279 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: Realtek ALC892

Memory:
RAM: 8073 Mb

Miscellaneous:
UI Language: English
LANG: en_US.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 344864 Mb
Largest Free Hard Disk Block: 230343 Mb

Installed software:
Showing 1-10 of 10 comments
< >
Pchan Nov 17, 2012 @ 9:06am 
I belive by default "alt" starts the Unity HUD in Ubuntu 12.10
Did you try changing the HUD shortcut in the "Keyboard" settings in Ubuntu?
You can change it "Shortcuts", "Launchers", "Key to show the HUD"
I use super+alt to start the HUD.
slikjay Nov 17, 2012 @ 9:34am 
All is ok with Serious Sam by the way.

> Did you try changing the HUD shortcut
no
Pchan Nov 17, 2012 @ 8:38pm 
Originally posted by johndrinkwater:
Originally posted by slikjay:
> Did you try changing the HUD shortcut
no
They suggest doing that in the FAQ, because of this issue.

You are referring to
Steam for Linux limited beta Release Notes right ?
More specifically it says
For Ubuntu 12.04, the default behavior of the Alt key displays the Unity HUD. If pressed during game play, this forces the game screen to be minimized. The solution is to disable or remap the Alt key by using the Shortcuts tab on the Keyboard dialog. For more information, see here.
kigucdoshu Nov 18, 2012 @ 1:34am 
The fundamental reason for this is a bug in Compiz, where windows are not allowed to go to fullscreen unless they are resizable (which fullscreen windows have no reason to be). In order to get fullscreen working at all, the "Legacy Fullscreen Support" option must be enabled in Compiz Config Settings Manager. The problem with this workaround is that the application loses focus very easily, for example if the Alt or Super keys are pressed, or if a system notification is drawn on top of it. Once it has lost focus, it cannot go to fullscreen again.

This has been fixed/worked-around in libsdl (http://bugzilla.libsdl.org/show_bug.cgi?id=1153), so Frozenbyte should be able to fix it by simply updating their SDL and rebuilding the binary.
humans-enabled.com Nov 27, 2012 @ 9:37pm 
The issue we're having is with not being able to "fullscreen" the game... Since the game is not fullscreen, when attacking things near the bottom - the mouse jumps out of the window and it gets minimized. Anyone know how to make this fullscreen or are we back to waiting for the libsdl update? Thanks!
kigucdoshu Nov 28, 2012 @ 12:14am 
Originally posted by humans-enabled.com:
The issue we're having is with not being able to "fullscreen" the game... Since the game is not fullscreen, when attacking things near the bottom - the mouse jumps out of the window and it gets minimized. Anyone know how to make this fullscreen or are we back to waiting for the libsdl update? Thanks!
CompizConfig Settings Manager > Workarounds > Legacy Fullscreen Support

It will still be affected by the bug mentioned in the OP, but at least fullscreen will work most of the time.
humans-enabled.com Nov 29, 2012 @ 10:36pm 
Originally posted by defaultusername:
Originally posted by humans-enabled.com:
The issue we're having is with not being able to "fullscreen" the game... Since the game is not fullscreen, when attacking things near the bottom - the mouse jumps out of the window and it gets minimized. Anyone know how to make this fullscreen or are we back to waiting for the libsdl update? Thanks!
CompizConfig Settings Manager > Workarounds > Legacy Fullscreen Support

It will still be affected by the bug mentioned in the OP, but at least fullscreen will work most of the time.

Works like a champ - Thanks!
humans-enabled.com Dec 1, 2012 @ 6:49pm 
Seems the Canonical Unity team has been working on making things better for the fullscreen games on Ubuntu GNU/Linux. There's a ppa out there with fixes for Unity that seem to resolve the fullscreen issues with Trine 2 on Steam for Linux. Read more about it here:
http://losca.blogspot.in/2012/11/game-performance-improvement-for-ubuntu.html
If you'd like to try the experimental unity fixes run these in the terminal:
sudo add-apt-repository ppa:unity-team/sru #hit enter, authenticate, then hit enter again
sudo apt-get upgrade

Found this on Venn Stone's (linuxgamecast.com) Google + post at:
https://plus.google.com/102766862318438263839/posts/KdG4rA5JPDg
Checkout Venn's G+ profile for more useful Steam on Linux gaming tips as well (e.g., making TF2 run faster)

slikjay Dec 2, 2012 @ 2:41am 
That's awesome!
slikjay Dec 2, 2012 @ 2:43am 
Installed the upgrade. Will try.
Showing 1-10 of 10 comments
< >
Per page: 15 30 50
Date Posted: Nov 17, 2012 @ 8:38am
Posts: 10