Steam for Linux > Limited Beta > トピックの詳細
Matrix 2012年11月15日 16時00分
Issue Report: SB S&S EP won't load
Hey everyone,

I downloaded and installed Super Brothers Sword and Sworcery EP, it installed just fine, etc. However, when I go to launch it, nothing happens. Sometimes my status will show as "in game" for a split second. It says it was last played today, however, it closes out before anything comes up.

Ideas?

Terminal output:

surface_opengl.cpp (505) : Assertion Failed: GetTextureForString failed

surface_opengl.cpp (564) : Assertion Failed: glIsTexture( id )
surface_opengl.cpp (845) : Assertion Failed: !"Current texture not set"
surface_opengl.cpp (505) : Assertion Failed: GetTextureForString failed

surface_opengl.cpp (564) : Assertion Failed: glIsTexture( id )
surface_opengl.cpp (845) : Assertion Failed: !"Current texture not set"
surface_opengl.cpp (505) : Assertion Failed: GetTextureForString failed

surface_opengl.cpp (564) : Assertion Failed: glIsTexture( id )
surface_opengl.cpp (845) : Assertion Failed: !"Current texture not set"
surface_opengl.cpp (505) : Assertion Failed: GetTextureForString failed

surface_opengl.cpp (564) : Assertion Failed: glIsTexture( id )
surface_opengl.cpp (845) : Assertion Failed: !"Current texture not set"
surface_opengl.cpp (505) : Assertion Failed: GetTextureForString failed

surface_opengl.cpp (564) : Assertion Failed: glIsTexture( id )
surface_opengl.cpp (845) : Assertion Failed: !"Current texture not set"
surface_opengl.cpp (505) : Assertion Failed: GetTextureForString failed

surface_opengl.cpp (564) : Assertion Failed: glIsTexture( id )
surface_opengl.cpp (845) : Assertion Failed: !"Current texture not set"
surface_opengl.cpp (505) : Assertion Failed: GetTextureForString failed

surface_opengl.cpp (564) : Assertion Failed: glIsTexture( id )
surface_opengl.cpp (845) : Assertion Failed: !"Current texture not set"
surface_opengl.cpp (505) : Assertion Failed: GetTextureForString failed

surface_opengl.cpp (564) : Assertion Failed: glIsTexture( id )
surface_opengl.cpp (845) : Assertion Failed: !"Current texture not set"
surface_opengl.cpp (505) : Assertion Failed: GetTextureForString failed

surface_opengl.cpp (564) : Assertion Failed: glIsTexture( id )
surface_opengl.cpp (845) : Assertion Failed: !"Current texture not set"
surface_opengl.cpp (505) : Assertion Failed: GetTextureForString failed

surface_opengl.cpp (564) : Assertion Failed: glIsTexture( id )
surface_opengl.cpp (845) : Assertion Failed: !"Current texture not set"
surface_opengl.cpp (505) : Assertion Failed: GetTextureForString failed

surface_opengl.cpp (564) : Assertion Failed: glIsTexture( id )
surface_opengl.cpp (845) : Assertion Failed: !"Current texture not set"
surface_opengl.cpp (505) : Assertion Failed: GetTextureForString failed

surface_opengl.cpp (564) : Assertion Failed: glIsTexture( id )
surface_opengl.cpp (845) : Assertion Failed: !"Current texture not set"
surface_opengl.cpp (505) : Assertion Failed: GetTextureForString failed

surface_opengl.cpp (564) : Assertion Failed: glIsTexture( id )
surface_opengl.cpp (845) : Assertion Failed: !"Current texture not set"
surface_opengl.cpp (505) : Assertion Failed: GetTextureForString failed

surface_opengl.cpp (564) : Assertion Failed: glIsTexture( id )
surface_opengl.cpp (845) : Assertion Failed: !"Current texture not set"
surface_opengl.cpp (505) : Assertion Failed: GetTextureForString failed

surface_opengl.cpp (564) : Assertion Failed: glIsTexture( id )
surface_opengl.cpp (845) : Assertion Failed: !"Current texture not set"
surface_opengl.cpp (505) : Assertion Failed: GetTextureForString failed

surface_opengl.cpp (564) : Assertion Failed: glIsTexture( id )
surface_opengl.cpp (845) : Assertion Failed: !"Current texture not set"
surface_opengl.cpp (505) : Assertion Failed: GetTextureForString failed

surface_opengl.cpp (564) : Assertion Failed: glIsTexture( id )
surface_opengl.cpp (845) : Assertion Failed: !"Current texture not set"
surface_opengl.cpp (505) : Assertion Failed: GetTextureForString failed

surface_opengl.cpp (564) : Assertion Failed: glIsTexture( id )
surface_opengl.cpp (845) : Assertion Failed: !"Current texture not set"
surface_opengl.cpp (505) : Assertion Failed: GetTextureForString failed

surface_opengl.cpp (564) : Assertion Failed: glIsTexture( id )
surface_opengl.cpp (845) : Assertion Failed: !"Current texture not set"
1-4 / 4 のコメントを表示
< >
johndrinkwater [🐧︀ 🎮] 2012年11月15日 16時36分 
Could you post your sysinfo? (from steam menu, help, system info)
Matrix 2012年11月15日 17時54分 
Absolutely! sorry about that @_@

Processor Information:
Vendor: AuthenticAMD
Speed: 3600 Mhz
8 logical processors
8 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Supported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.10 (64 bit)
Kernel Name: Linux
Kernel Version: 3.5.0-17-generic
X Server vendor: The X.Org Foundation
X Server release: 11300000

Video Card:
Driver: NVIDIA Corporation GeForce GTX 580/PCIe/SSE2

Driver Version: 4.3.0 NVIDIA 310.14
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID: 0x10de
DeviceID: 0x1080
Number of Monitors: 2
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 3286 x 1080
Primary Display Size: 20.39" x 1.26" (20.39" diag)
51.8cm x 3.2cm (51.8cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 1535 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device:

Memory:
RAM: 15997 Mb

Miscellaneous:
UI Language: English
LANG: en_US.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 929283 Mb
Largest Free Hard Disk Block: 848683 Mb

Installed software:


r0d3nt 2012年11月29日 19時54分 
I had the same problem, but it turned out to be a dependency issue with curl.

At first I tried running the run.sh directly in the buried directory for the game and got a very telling error:
uquevedo@intelc2d:~/.steam/steam/SteamApps/common/Superbrothers Sword & Sworcery EP$ ./run.sh
./swordandsworcery_pc: error while loading shared libraries: libcurl.so.4: cannot open shared object file: No such file or directory
Since I'm also running 64-BIT Ubuntu 12.10, I installed the i386 version of curl:
uquevedo@intelc2d:~$ sudo apt-get install libcurl:i386
[sudo] password for uquevedo:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libcurl
uquevedo@intelc2d:~$ sudo apt-get install curl:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
libavahi-ui-gtk3-0 libgtk-vnc-2.0-0 libgvnc-1.0-0 linux-headers-3.5.0-17
rdesktop
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
libcurl3:i386
The following NEW packages will be installed:
curl:i386 libcurl3:i386
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 401 kB of archives.
After this operation, 967 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://us.archive.ubuntu.com/ubuntu/ quantal/main libcurl3 i386 7.27.0-1ubuntu1 [254 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu/ quantal/main curl i386 7.27.0-1ubuntu1 [147 kB]
Fetched 401 kB in 1s (357 kB/s)
Selecting previously unselected package libcurl3:i386.
(Reading database ... 182392 files and directories currently installed.)
Unpacking libcurl3:i386 (from .../libcurl3_7.27.0-1ubuntu1_i386.deb) ...
Selecting previously unselected package curl.
Unpacking curl (from .../curl_7.27.0-1ubuntu1_i386.deb) ...
Processing triggers for man-db ...
Setting up libcurl3:i386 (7.27.0-1ubuntu1) ...
Setting up curl (7.27.0-1ubuntu1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
I then tried running the run.sh again and got a very different [better] error message:
uquevedo@intelc2d:~/.steam/steam/SteamApps/common/Superbrothers Sword & Sworcery EP$ ./run.sh
[S_API FAIL] SteamAPI_Init() failed; Sys_LoadModule failed to load: /home/uquevedo/.steam/bin32/steamclient.so
I then was able to launch the game from the Steam interface.

I just got into the beta and had also installed Serious Sam 3, but ran into the issue of mesa 32-BIT not being installed. From a post here, I did sudo apt-get install libglu1:i386 and then I was able to get that going. I did do this before I attempted to launch this game, so this might have also been a pre-requisite that I fixed without knowing it.

Hopefully there will be better logic introduced for these games to better check their dependencies and getting those dependencies installed before being launched?
最近の変更はr0d3ntが行いました; 2012年11月29日 19時54分
TargusTargus 2012年12月10日 15時35分 
same problem, same solution. Thanks!
1-4 / 4 のコメントを表示
< >
ページ毎: 15 30 50
投稿日: 2012年11月15日 16時00分
投稿数: 4