Steam for Linux > Limited Beta > Konu Detayları
Nevon 15 Kas 2012 @ 2:04pm
Issue Report: Black screen on TF2 startup
After installing Team Fortress 2 beta in Ubuntu 12.04 and running it, the game seems to start up and the Valve sound is played. However, no graphics are displayed at all, and no sound is played after the Valve intro sound. Only a black screen is ever shown. The same thing happens if I install TF2 (non-beta version) and run that.

Console output[db.tt]
Crash dump[db.tt]
System information[pastie.org]

Other than what's in the system info, I'm also running Gnome Shell 3.6.

EDIT: I have now tried it in Unity as well, and got the exact same result.
En son Nevon tarafından düzenlendi; 15 Kas 2012 @ 2:29pm
18 yorumdan 1 ile 15 arası gösteriliyor
< >
Keldrim 15 Kas 2012 @ 4:08pm 
Duplicate bug report, for the original report go here:
Issue Report: Black screen on TF2 startup

This one also has a few fixes that work.
En son Keldrim tarafından düzenlendi; 15 Kas 2012 @ 4:09pm
Nevon 15 Kas 2012 @ 4:16pm 
The LANG=C workaround does not work for me. I get the exact same result with the workaround as without it.
AJenbo 15 Kas 2012 @ 5:28pm 
Exiting steam and running:
export LANG=C; steam

Made everything work for me
Dusty0 15 Kas 2012 @ 6:32pm 
export LANG=C; steam works for me.
En son Dusty0 tarafından düzenlendi; 18 Kas 2012 @ 10:28am
Nevon 16 Kas 2012 @ 3:04am 
LC_NUMERIC=C does work, however. Strange. I would have thought setting LANG would implicitly also change LC_NUMERIC.
Sith 16 Kas 2012 @ 4:46am 
I have the same problem using Kubuntu 12.04. I tried AMD 12.10, 12.11beta, open radeon driver but it seems there's nothing to do. I will try with Kubuntu 12.10.
Vlad Brocula 16 Kas 2012 @ 8:12am 
Same problem with Kubuntu 12.10
ayr-ton 16 Kas 2012 @ 9:09am 
Same here. With Ubuntu 12.10 64bits with Intel HD Graphics
AJenbo 16 Kas 2012 @ 4:16pm 
Did you make sure to fully exit and shut down steam first?
Nevon 16 Kas 2012 @ 5:27pm 
anders.jenbo: Yes, but as I said, LC_NUMERIC=C works, whereas LANG=C does not.
Sp1k3 17 Kas 2012 @ 12:41pm 
Nevon tarafından gönderilen ileti:
anders.jenbo: Yes, but as I said, LC_NUMERIC=C works, whereas LANG=C does not.
I tried this and no go, it seems to be related to Valve's SDL libs not detecting OpenGL libs properly
Kereltis 21 Kas 2012 @ 10:51am 
Neither "LC_NUMERIC=C" or "export LANG=C; steam" work for me with AMD Radeon HD 4670 Mobility graphics using open source driver.
Kereltis 21 Kas 2012 @ 11:57am 
Problem solved for Ubuntu 12.04 "AMD Radeon HD 4670 Mobility graphics" just install the latest open source driver by doing the following in Terminal:

sudo add-apt-repository ppa:oibaf/graphics-drivers

sudo apt-get update

Then check for updates and install them, restart your system and you should be good to go. Hope this helps the rest of you!
Mangmasta 21 Kas 2012 @ 2:20pm 
Im having this problem too. Neither "LC_NUMERIC=C" or "export LANG=C" work for me. I have HD 5770 graphics and have the latest proprietary graphic drivers. I don't know if this has anything to do with this, but I have my home directory saved in a different partition (on a different hard drive). When trying to use the fixes described here, I noticed in the terminal it would say this after tf2 crashes:
/home/mangmasta/Steam/SteamApps/mangmasta/Team Fortress 2/hl2.sh: line 72: 18963 Segmentation fault (core dumped) ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"
Cyberworm 22 Kas 2012 @ 1:34pm 
I too have my home folder on a different hard drive, and I get the exact same error:

/home/cyberworm/Steam/SteamApps/cyberworm86/Team Fortress 2/hl2.sh: line 72: 10410 Segmentation fault (core dumped) ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"

Setting "LC_NUMERIC=C" or "export LANG=C" didn't work.
18 yorumdan 1 ile 15 arası gösteriliyor
< >
Sayfa başına: 15 30 50
Gönderilme Tarihi: 15 Kas 2012 @ 2:04pm
İleti: 18