Steam for Linux > Limited Beta > 제목 정보
Nevon 2012년 11월 15일 오후 2시 04분
Issue Report: Black screen on TF2 startup
After installing Team Fortress 2 beta in Ubuntu 12.04 and running it, the game seems to start up and the Valve sound is played. However, no graphics are displayed at all, and no sound is played after the Valve intro sound. Only a black screen is ever shown. The same thing happens if I install TF2 (non-beta version) and run that.

Console output[db.tt]
Crash dump[db.tt]
System information[pastie.org]

Other than what's in the system info, I'm also running Gnome Shell 3.6.

EDIT: I have now tried it in Unity as well, and got the exact same result.
Nevon님이 마지막으로 수정; 2012년 11월 15일 오후 2시 29분
18개 중 1-15 표시중
< >
붉은여우 2012년 11월 15일 오후 4시 08분 
Duplicate bug report, for the original report go here:
Issue Report: Black screen on TF2 startup

This one also has a few fixes that work.
Nevon 2012년 11월 15일 오후 4시 16분 
The LANG=C workaround does not work for me. I get the exact same result with the workaround as without it.
AJenbo 2012년 11월 15일 오후 5시 28분 
Exiting steam and running:
export LANG=C; steam

Made everything work for me
Dusty0 2012년 11월 15일 오후 6시 32분 
export LANG=C; steam works for me.
Nevon 2012년 11월 16일 오전 3시 04분 
LC_NUMERIC=C does work, however. Strange. I would have thought setting LANG would implicitly also change LC_NUMERIC.
Sith 2012년 11월 16일 오전 4시 46분 
I have the same problem using Kubuntu 12.04. I tried AMD 12.10, 12.11beta, open radeon driver but it seems there's nothing to do. I will try with Kubuntu 12.10.
TakkaRakkaTakka 2012년 11월 16일 오전 8시 12분 
Same problem with Kubuntu 12.10
ayr-ton 2012년 11월 16일 오전 9시 09분 
Same here. With Ubuntu 12.10 64bits with Intel HD Graphics
AJenbo 2012년 11월 16일 오후 4시 16분 
Did you make sure to fully exit and shut down steam first?
Nevon 2012년 11월 16일 오후 5시 27분 
anders.jenbo: Yes, but as I said, LC_NUMERIC=C works, whereas LANG=C does not.
Sp1k3 2012년 11월 17일 오후 12시 41분 
Nevon님이 먼저 게시:
anders.jenbo: Yes, but as I said, LC_NUMERIC=C works, whereas LANG=C does not.
I tried this and no go, it seems to be related to Valve's SDL libs not detecting OpenGL libs properly
Kereltis 2012년 11월 21일 오전 10시 51분 
Neither "LC_NUMERIC=C" or "export LANG=C; steam" work for me with AMD Radeon HD 4670 Mobility graphics using open source driver.
Kereltis 2012년 11월 21일 오전 11시 57분 
Problem solved for Ubuntu 12.04 "AMD Radeon HD 4670 Mobility graphics" just install the latest open source driver by doing the following in Terminal:

sudo add-apt-repository ppa:oibaf/graphics-drivers

sudo apt-get update

Then check for updates and install them, restart your system and you should be good to go. Hope this helps the rest of you!
Mangmasta 2012년 11월 21일 오후 2시 20분 
Im having this problem too. Neither "LC_NUMERIC=C" or "export LANG=C" work for me. I have HD 5770 graphics and have the latest proprietary graphic drivers. I don't know if this has anything to do with this, but I have my home directory saved in a different partition (on a different hard drive). When trying to use the fixes described here, I noticed in the terminal it would say this after tf2 crashes:
/home/mangmasta/Steam/SteamApps/mangmasta/Team Fortress 2/hl2.sh: line 72: 18963 Segmentation fault (core dumped) ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"
Cyberworm 2012년 11월 22일 오후 1시 34분 
I too have my home folder on a different hard drive, and I get the exact same error:

/home/cyberworm/Steam/SteamApps/cyberworm86/Team Fortress 2/hl2.sh: line 72: 10410 Segmentation fault (core dumped) ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"

Setting "LC_NUMERIC=C" or "export LANG=C" didn't work.
18개 중 1-15 표시중
< >
페이지당: 15 30 50
게시된 날짜: 2012년 11월 15일 오후 2시 04분
게시글: 18