Steam for Linux > Limited Beta > トピックの詳細
Nevon 2012年11月15日 14時04分
Issue Report: Black screen on TF2 startup
After installing Team Fortress 2 beta in Ubuntu 12.04 and running it, the game seems to start up and the Valve sound is played. However, no graphics are displayed at all, and no sound is played after the Valve intro sound. Only a black screen is ever shown. The same thing happens if I install TF2 (non-beta version) and run that.

Console output[db.tt]
Crash dump[db.tt]
System information[pastie.org]

Other than what's in the system info, I'm also running Gnome Shell 3.6.

EDIT: I have now tried it in Unity as well, and got the exact same result.
最近の変更はNevonが行いました; 2012年11月15日 14時29分
1-15 / 18 のコメントを表示
< >
Keldrim 2012年11月15日 16時08分 
Duplicate bug report, for the original report go here:
Issue Report: Black screen on TF2 startup

This one also has a few fixes that work.
最近の変更はKeldrimが行いました; 2012年11月15日 16時09分
Nevon 2012年11月15日 16時16分 
The LANG=C workaround does not work for me. I get the exact same result with the workaround as without it.
AJenbo 2012年11月15日 17時28分 
Exiting steam and running:
export LANG=C; steam

Made everything work for me
Dusty0 2012年11月15日 18時32分 
export LANG=C; steam works for me.
最近の変更はDusty0が行いました; 2012年11月18日 10時28分
Nevon 2012年11月16日 3時04分 
LC_NUMERIC=C does work, however. Strange. I would have thought setting LANG would implicitly also change LC_NUMERIC.
Sith 2012年11月16日 4時46分 
I have the same problem using Kubuntu 12.04. I tried AMD 12.10, 12.11beta, open radeon driver but it seems there's nothing to do. I will try with Kubuntu 12.10.
Vladradamus 2012年11月16日 8時12分 
Same problem with Kubuntu 12.10
ayr-ton 2012年11月16日 9時09分 
Same here. With Ubuntu 12.10 64bits with Intel HD Graphics
AJenbo 2012年11月16日 16時16分 
Did you make sure to fully exit and shut down steam first?
Nevon 2012年11月16日 17時27分 
anders.jenbo: Yes, but as I said, LC_NUMERIC=C works, whereas LANG=C does not.
Species Unknown 2012年11月17日 12時41分 
Nevon の投稿を引用:
anders.jenbo: Yes, but as I said, LC_NUMERIC=C works, whereas LANG=C does not.
I tried this and no go, it seems to be related to Valve's SDL libs not detecting OpenGL libs properly
Kereltis 2012年11月21日 10時51分 
Neither "LC_NUMERIC=C" or "export LANG=C; steam" work for me with AMD Radeon HD 4670 Mobility graphics using open source driver.
Kereltis 2012年11月21日 11時57分 
Problem solved for Ubuntu 12.04 "AMD Radeon HD 4670 Mobility graphics" just install the latest open source driver by doing the following in Terminal:

sudo add-apt-repository ppa:oibaf/graphics-drivers

sudo apt-get update

Then check for updates and install them, restart your system and you should be good to go. Hope this helps the rest of you!
Mangmasta 2012年11月21日 14時20分 
Im having this problem too. Neither "LC_NUMERIC=C" or "export LANG=C" work for me. I have HD 5770 graphics and have the latest proprietary graphic drivers. I don't know if this has anything to do with this, but I have my home directory saved in a different partition (on a different hard drive). When trying to use the fixes described here, I noticed in the terminal it would say this after tf2 crashes:
/home/mangmasta/Steam/SteamApps/mangmasta/Team Fortress 2/hl2.sh: line 72: 18963 Segmentation fault (core dumped) ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"
Cyberworm 2012年11月22日 13時34分 
I too have my home folder on a different hard drive, and I get the exact same error:

/home/cyberworm/Steam/SteamApps/cyberworm86/Team Fortress 2/hl2.sh: line 72: 10410 Segmentation fault (core dumped) ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"

Setting "LC_NUMERIC=C" or "export LANG=C" didn't work.
1-15 / 18 のコメントを表示
< >
ページ毎: 15 30 50
投稿日: 2012年11月15日 14時04分
投稿数: 18