Steam for Linux

Steam for Linux

Steam for Linux > Limited Beta > Detaily tématu
Issue Report: TF2 crashes on startup
This is what steam logs from the moment I double-click TF2 in the library:
Game update: AppID 440 "Team Fortress 2", ProcID 17041, IP 0.0.0.0:0 ERROR: ld.so: object '/home/muhammad/.steam/bin/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored. ERROR: ld.so: object '/home/muhammad/.steam/bin/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored. ERROR: ld.so: object '/home/muhammad/.steam/bin/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored. ERROR: ld.so: object '/home/muhammad/.steam/bin/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored. ERROR: ld.so: object '/home/muhammad/.steam/bin/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored. ERROR: ld.so: object '/home/muhammad/.steam/bin/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored. saving roaming config store to 'sharedconfig.vdf' roaming config store 2 saved successfully SDL video target is 'x11' SDL video target is 'x11' Installing breakpad exception handler for appid(gameoverlayui)/version(20121113164505_client) Fontconfig warning: "/etc/fonts/conf.d/65-culmus.conf", line 12: Having multiple values in <test> isn't supported and may not works as expected Fontconfig warning: "/etc/fonts/conf.d/65-culmus.conf", line 34: Having multiple values in <test> isn't supported and may not works as expected Fontconfig warning: "/etc/fonts/conf.d/65-culmus.conf", line 44: Having multiple values in <test> isn't supported and may not works as expected Fontconfig warning: "/etc/fonts/conf.d/65-culmus.conf", line 55: Having multiple values in <test> isn't supported and may not works as expected Fontconfig warning: "/etc/fonts/conf.d/65-culmus.conf", line 66: Having multiple values in <test> isn't supported and may not works as expected Fontconfig warning: "/etc/fonts/conf.d/65-culmus.conf", line 77: Having multiple values in <test> isn't supported and may not works as expected Fontconfig warning: "/etc/fonts/conf.d/65-culmus.conf", line 89: Having multiple values in <test> isn't supported and may not works as expected Fontconfig warning: "/etc/fonts/conf.d/65-culmus.conf", line 101: Having multiple values in <test> isn't supported and may not works as expected Fontconfig warning: "/etc/fonts/conf.d/65-culmus.conf", line 111: Having multiple values in <test> isn't supported and may not works as expected Fontconfig warning: "/etc/fonts/conf.d/90-fonts-nanum-coding.conf", line 10: Having multiple values in <test> isn't supported and may not works as expected Fontconfig warning: "/etc/fonts/conf.d/90-fonts-nanum-coding.conf", line 22: Having multiple values in <test> isn't supported and may not works as expected Gtk-Message: Failed to load module "overlay-scrollbar" [1114/143432:WARNING:proxy_service.cc(646)] PAC support disabled because there is no system implementation Using breakpad crash handler Setting breakpad minidump AppID = 440 Forcing breakpad minidump interfaces to load Looking up breakpad interfaces from steamclient Calling BreakpadMiniDumpSystemInit Installing breakpad exception handler for appid(440)/version(5112_client) Looking up breakpad interfaces from steamclient Calling BreakpadMiniDumpSystemInit Steam_SetMinidumpSteamID: Caching Steam ID: 76561197990637251 [API loaded yes] Steam_SetMinidumpSteamID: Setting Steam ID: 76561197990637251 ConVarRef m_rawinput doesn't point to an existing ConVar Gtk-Message: Failed to load module "overlay-scrollbar" [1114/143433:ERROR:resource_bundle.cc(411)] Failed to load /home/muhammad/Steam/SteamApps/mhaggag/Team Fortress 2/cef_gtk.pak Some features may not be available. [1114/143433:WARNING:proxy_service.cc(646)] PAC support disabled because there is no system implementation /home/muhammad/Steam/SteamApps/mhaggag/Team Fortress 2/hl2.sh: line 72: 17048 Segmentation fault (core dumped) ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@" Game removed: AppID 440 "Team Fortress 2", ProcID 17048

This is my system information:
Processor Information: Vendor: AuthenticAMD Speed: 3400 Mhz 4 logical processors 4 physical processors HyperThreading: Unsupported FCMOV: Supported SSE2: Supported SSE3: Supported SSSE3: Supported SSE4a: Supported SSE41: Unsupported SSE42: Unsupported Network Information: Network Speed: Operating System Version: Ubuntu 12.10 (64 bit) Kernel Name: Linux Kernel Version: 3.5.0-17-generic X Server vendor: The X.Org Foundation X Server release: 11300000 Video Card: Driver: ATI Technologies Inc. AMD Radeon HD 6900 Series Driver Version: 4.2.11903 Compatibility Profile Context Desktop Color Depth: 24 bits per pixel Monitor Refresh Rate: 60 Hz VendorID: 0x1002 DeviceID: 0x6719 Number of Monitors: 2 Number of Logical Video Cards: 1 Primary Display Resolution: 1920 x 1080 Desktop Resolution: 3600 x 1080 Primary Display Size: 20.08" x 11.30" (23.03" diag) 51.0cm x 28.7cm (58.5cm diag) Primary VRAM Not Detected Sound card: Audio device: Realtek ALC889 Memory: RAM: 7984 Mb Miscellaneous: UI Language: English Microphone: Not set Total Hard Disk Space Available: 450678 Mb Largest Free Hard Disk Block: 269078 Mb Installed software:
< >
Zobrazeno 111 z 11 komentářů
I'm also having what looks like this issue (but haven't had time to investigate, having been invited to the beta late on Monday my time). I'm also running 12.10, with an AMD graphics card, albeit a different model. When I get home I'll post a slightly more useful reply.

I note that the getting started thread says 12.04 - are bug reports welcome for 12.10, or should I only be testing on a 12.04 system?
12.10 should work. Anyone up for donig something like this:

gdb -p `pidof hl2_linux`

After tf2 starts, and then doing a "bt" when it crashes and letting me know what the callstack looks like? Or if you've got a core file that'd be good also... Thanks.
Sure, I'll see if I can share a gdb backtrace and/or a core dump when I get home.
(gdb) bt #0 0xf3dedd4c in ?? () from /usr/lib32/fglrx/dri/fglrx_dri.so #1 0xeb6f63b1 in ?? () from /home/[snip]/Team Fortress 2/bin/shaderapidx9.so #2 0xeb70c95e in ?? () from /home/[snip]/Team Fortress 2/bin/shaderapidx9.so #3 0xf0ef0e9c in ?? () from /home/[snip]/Team Fortress 2/bin/materialsystem.so #4 0xea283a8c in ?? () from /home/[snip]/Team Fortress 2/bin/stdshader_dx9.so #5 0xea2f66eb in ?? () from /home/[snip]/Team Fortress 2/bin/stdshader_dx9.so #6 0xf0ef2b86 in ?? () from /home/[snip]/Team Fortress 2/bin/materialsystem.so #7 0xf0e9b69a in ?? () from /home/[snip]/Team Fortress 2/bin/materialsystem.so #8 0xeb70d411 in ?? () from /home/[snip]/Team Fortress 2/bin/shaderapidx9.so #9 0xeb6f7263 in ?? () from /home/[snip]/Team Fortress 2/bin/shaderapidx9.so #10 0xeb6f805a in ?? () from /home/[snip]/Team Fortress 2/bin/shaderapidx9.so #11 0xeb70d6cb in ?? () from /home/[snip]/Team Fortress 2/bin/shaderapidx9.so #12 0xf0f3fe13 in ?? () from /home/[snip]/Team Fortress 2/bin/materialsystem.so #13 0xeb67318a in ?? () from /home/[snip]/Team Fortress 2/bin/video_bink.so #14 0xf607ffde in ?? () from /home/[snip]/Team Fortress 2/bin/video_services.so #15 0xf18e056f in ?? () from /home/[snip]/Team Fortress 2/bin/engine.so #16 0xf18e0722 in ?? () from /home/[snip]/Team Fortress 2/bin/engine.so #17 0xf18de485 in ?? () from /home/[snip]/Team Fortress 2/bin/engine.so #18 0xf18debe5 in ?? () from /home/[snip]/Team Fortress 2/bin/engine.so #19 0xf18d8ce4 in ?? () from /home/[snip]/Team Fortress 2/bin/engine.so #20 0xf18d9d80 in ?? () from /home/[snip]/Team Fortress 2/bin/engine.so #21 0xf719ad30 in ?? () #22 0xf719ad30 in ?? () #23 0xf718334d in ?? () #24 0x08048474 in main ()

I'm not sure if there are meant to be any symbols there.

Edit: system information:
Processor Information: Vendor: GenuineIntel Speed: 3005 Mhz 2 logical processors 2 physical processors HyperThreading: Unsupported FCMOV: Supported SSE2: Supported SSE3: Supported SSSE3: Supported SSE4a: Unsupported SSE41: Supported SSE42: Unsupported Network Information: Network Speed: Operating System Version: Ubuntu 12.10 (64 bit) Kernel Name: Linux Kernel Version: 3.5.0-18-generic X Server vendor: The X.Org Foundation X Server release: 11300000 Video Card: Driver: ATI Technologies Inc. ATI Radeon HD 5700 Series Driver Version: 4.2.11903 Compatibility Profile Context Desktop Color Depth: 24 bits per pixel Monitor Refresh Rate: 59 Hz VendorID: 0x1002 DeviceID: 0x68b8 Number of Monitors: 1 Number of Logical Video Cards: 1 Primary Display Resolution: 1920 x 1200 Desktop Resolution: 1920 x 1200 Primary Display Size: 20.39" x 12.76" (24.02" diag) 51.8cm x 32.4cm (61.0cm diag) Primary VRAM Not Detected Sound card: Audio device: SigmaTel STAC9708,11 Memory: RAM: 7986 Mb Miscellaneous: UI Language: English LANG: en_US.UTF-8 Microphone: Not set Total Hard Disk Space Available: 469190 Mb Largest Free Hard Disk Block: 36471 Mb

I also attempted to get a core dump, but it seemed to contain things like the names of files in my ~ so I don't really want to share that.
Naposledy upravil Dave2; 15. lis. 2012 v 11.24
Right, I've fixed this by installing the 12.11 beta from AMD's site.

I guess the question now is whether bug reports using a beta driver release on a platform that's not officially supported are worthwhile filing or not.
Naposledy upravil Dave2; 15. lis. 2012 v 13.06
Ah, ok. We are working on getting newer AMD drivers in the distro. And yes, please let us or AMD know of any bugs you run into with 12.11. Thanks for posting the callstack and trying the new driver as well. Appreciate it.
@Dave2: have you had success launching the steam client with the AMD beta driver? If so, was there a particular way that you installed the driver? See http://steamcommunity.com/app/221410/discussions/1/882966056321592027/
I'm not running beta 8, so if there's an issue with those drivers then I won't've run into them. The drivers I was using were:

http://www2.ati.com/drivers/beta/amd-driver-installer-catalyst-12.11-beta-x86.x86_64.zip

Of course, it is possible that they might've updated this zip file since I installed it.

For installing them, all I did was extract the zip, use --buildpkg Ubuntu/quantal, and install the debs.
Same problem here. Ubuntu 12.10 x64 and AMD HD 6850. So the game is not playable for all AMD users on Ubuntu 12.10.
Naposledy upravil Vladradamus; 20. lis. 2012 v 14.49
@Horst: which driver version?
Switching to the driver that @Dave2 linked has solved the issue for me. Steam starts, TF2 works great. 12.11-beta is the version. To be clear: the beta8 that is currently the latest on AMDs site is not the same one.
< >
Zobrazeno 111 z 11 komentářů
Na stránku: 15 30 50

Steam for Linux > Limited Beta > Detaily tématu
Datum odeslání: 14. lis. 2012 v 4.38
Počet příspěvků: 11