Steam for Linux > Limited Beta > Topic Details
Mo Nov 12, 2012 @ 11:49pm
Issue Report: Amnesia fullscreen spans both monitors
On my dual-monitor desktop system running 12.10 with Unity, running Amnesia fullscreen spans both monitors.
System information:
Processor Information:
Vendor: AuthenticAMD
Speed: 3400 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.10 (64 bit)
Kernel Name: Linux
Kernel Version: 3.5.0-17-generic
X Server vendor: The X.Org Foundation
X Server release: 11300000

Video Card:
Driver: ATI Technologies Inc. AMD Radeon HD 6900 Series

Driver Version: 4.2.11903 Compatibility Profile Context
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x1002
DeviceID: 0x6719
Number of Monitors: 2
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 3600 x 1080
Primary Display Size: 20.08" x 11.30" (23.03" diag)
51.0cm x 28.7cm (58.5cm diag)
Primary VRAM Not Detected

Sound card:
Audio device: Realtek ALC889

Memory:
RAM: 7984 Mb

Miscellaneous:
UI Language: English
Microphone: Not set
Total Hard Disk Space Available: 450678 Mb
Largest Free Hard Disk Block: 284138 Mb

Installed software:
Showing 1-3 of 3 comments
< >
Gilgamesh Nov 13, 2012 @ 8:50am 
A workaround would be to follow the instructions from an AskUbuntu user.

Originally posted by Alistair Buxton:
These are SDL games, and like all SDL games, they will act strangely if you have two monitors. To run them on only the primary display:

SDL_VIDEO_FULLSCREEN_DISPLAY=0 /opt/amnesia/Launcher.bin64 - note this will probably be called "Launcher.bin32" or similar on 32-bit systems.

SDL_VIDEO_FULLSCREEN_DISPLAY=0 /opt/swordandsworcery/run.sh

I didn't need to do any further tweaking with these and they seem to work perfectly.

NOTE: To apply this tweak to all SDL games such that they can be run this way from the dash, just add

SDL_VIDEO_FULLSCREEN_DISPLAY=0

to /etc/environment on a new line and then reboot.
- Source[askubuntu.com]

This is what I did to play such games. Though I hope Valve include their own workaround to the games launcher for new folk.
Last edited by Gilgamesh; Nov 13, 2012 @ 8:51am
Pchan Nov 16, 2012 @ 6:15am 
For me (Ubuntu 12.10) the solution in #1 did not work so well. The window spanned half the screen and there was no image, only a black screen with sound.
The best I have so far, is to manually disable twinview before launching amnesia..

EDIT: Today it seems to be fixed in my setup. Was a fix released?

EDIT2: Tried again later and now the image spans both monitors instead of just one...
Last edited by Pchan; Nov 17, 2012 @ 9:20am
The Slippery One Dec 9, 2012 @ 7:17am 
Interesting that it would be an SDL issue, since the console reports that Big Picture mode uses SDL (and it runs on the correct monitor). I have an ATI card (NOT running Xinerama, since that kills compositing on the AMD drivers) and Amnesia is still spread across both monitors. Perhaps it's because Big Picture is running under SDL 2.0, which is a major API change from 1.x specifically to accomodate modern features like multi-head.
Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: Nov 12, 2012 @ 11:49pm
Posts: 3