Steam for Linux > Limited Beta > Detalhes do Tópico
Vash 8 Nov, 2012 às 21:01
Issue Report: TF2 performance poor until settings change
I've noticed that every time I load a fresh game of TF2, it runs extremely chopping. It claims to be getting 60FPS but is very stuttery and hard to play. Changing any setting in the video options fixes it as soon as it's done reloading, and it's smooth as butter and runs perfectly.

Processor Information:
Vendor: GenuineIntel
Speed: 3201 Mhz
12 logical processors
6 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Linux (64 bit)
Kernel Name: Linux
Kernel Version: 3.6.6-1-ARCH
X Server vendor: The X.Org Foundation
X Server release: 11300000

Video Card:
Driver: NVIDIA Corporation GeForce GTX 680/PCIe/SSE2

Driver Version: 4.3.0 NVIDIA 310.14
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID: 0x10de
DeviceID: 0x1180
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1200
Desktop Resolution: 1920 x 1200
Primary Display Size: 21.50" x 13.86" (25.55" diag)
54.6cm x 35.2cm (64.9cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 2048 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: AV200

Memory:
RAM: 16002 Mb

Miscellaneous:
UI Language: English
Microphone: Not set
Total Hard Disk Space Available: 111548 Mb
Largest Free Hard Disk Block: 23654 Mb

Installed software:

A mostrar 1-15 de 15 comentários
< >
gtmanfred 8 Nov, 2012 às 21:15 
I might have to try this, right now i am getting slowdown, then all of a sudden a halt and a segfault, these are the dumps and an strace of /usr/bin/steam http://ompldr.org/vZzc4cw

Processor Information:
Vendor: AuthenticAMD
Speed: 3200 Mhz
2 logical processors
2 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
"Arch Linux" (64 bit)
Kernel Name: Linux
Kernel Version: 3.6.6-1-ARCH
X Server vendor: The X.Org Foundation
X Server release: 11300000

Video Card:
Driver: NVIDIA Corporation GeForce GT 545/PCIe/SSE2

Driver Version: 4.3.0 NVIDIA 310.14
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x10de
DeviceID: 0x1243
Number of Monitors: 2
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 3000 x 1920
Primary Display Size: 27.56" x 15.35" (31.54" diag)
70.0cm x 39.0cm (80.1cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 1535 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: Realtek ALC887-VD

Memory:
RAM: 7988 Mb

Miscellaneous:
UI Language: English
Microphone: Not set
Total Hard Disk Space Available: 408718 Mb
Largest Free Hard Disk Block: 226598 Mb

Installed software:

Última alteração por gtmanfred; 8 Nov, 2012 às 21:18
Frank 9 Nov, 2012 às 11:29 
Thanks for the info.
vodik 9 Nov, 2012 às 11:43 
Along these lines, I've noticed that steam will be sitting at 100%-105% cpu usage why TF2 is running. Killing steam after TF2 launches substantially improves performance.
Freyja, The Witch... 9 Nov, 2012 às 12:01 
Originalmente postado por vodik:
Along these lines, I've noticed that steam will be sitting at 100%-105% cpu usage why TF2 is running. Killing steam after TF2 launches substantially improves performance.
The same here…!
jay 9 Nov, 2012 às 13:45 
And here; unfortunately, TF2 segfaults after a while if steam is killed, and so remains fairly unplayable for me :( *subscribed to thread*
vodik 9 Nov, 2012 às 13:46 
Right, I've actually been too afarid to try killing steam while in a server against human players fearing it might lead to my ejection or something, but against bots its makes a massive improvment.
gtmanfred 11 Nov, 2012 às 20:16 
i lowered my video settings and it works much better
Epitron 13 Nov, 2012 às 15:14 
I'm having the same problem. I'm on Arch Linux (64-bit), and TF2 is quite jittery due to Steam maxing out both of my cores while I'm playing the game.

Is this an unusual problem? Do other people have smooth-as-butter TF2 experiences, with Steam using no CPU?

I noticed that disabling the in-game Steam console helped a tiny bit, but not enough.
jay 14 Nov, 2012 às 14:48 
Nothing seems to have changed for me, Steam is still hogging the CPU when playing TF2.
tart1ne 10 Dez, 2012 às 7:47 
Almost same problem here :
TF2 Performance are really random ( sometime , it run like a charm and sometimes, the perfs are just fluctuating so fast ( 10fps -> 60 fps -> 10 fps ) )disabling the antialiasing makes me 60 fps all the time .
I also had 1 black screen on the 3d rander ( the 2d HUD was working smoothly )
Steam CPU usage is 100% when running tf2 .

tengwarscribe 15 Dez, 2012 às 16:25 
I get fps fluctuations between 20 and 100 regularly when playing tf2. While it doesn't affect my ability to play the game, the problem gets worse when there are more moving objects on the screen.
Vash 16 Dez, 2012 às 22:36 
Not sure this will help others, but using 'nvidia-settings --load-config-only' in my xinitrc fixed my issues. Apparently even if you have vsync turned off in the settings, those setting aren't loaded by the driver except when nvidia-settings loads, so you have to manually force it to load or vsync will get forced on giving poor performance.
vodik 17 Dez, 2012 às 6:00 
vsync shouldn't be causing a high cpu load though, it should reduce it, no?
Vash 17 Dez, 2012 às 13:21 
My issue isn't CPU load. It might be higher than Windows but not enough to cause issues. I do have six cores with Hyperthreading though. My issue was latency added by vsync, which I thought I had disabled.
vodik 17 Dez, 2012 às 13:35 
ah, my bad
A mostrar 1-15 de 15 comentários
< >
Por página: 15 30 50