Steam for Linux > Limited Beta > トピックの詳細
RegSizedRudy 2012年11月8日 17時33分
[SOLVED] Issue Report: Serious Sam 3: BFE: Low FPS 15 - 25fps
Low frame rate in serious sam 3. I have a GTX 660 so I should not have to turn it this far down, but to make it playable I have to turn CPU and Graphics to Medium and i get about 15 - 25 fps. Changing resolution down from 1920x1080 does nothing to improve the frame rate.


Processor Information:
Vendor: AuthenticAMD
Speed: 3300 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.04.1 LTS (64 bit)
Kernel Name: Linux
Kernel Version: 3.2.0-32-generic
X Server vendor: The X.Org Foundation
X Server release: 11103000

Video Card:
Driver: NVIDIA Corporation GeForce GTX 660/PCIe/SSE2

Driver Version: 4.3.0 NVIDIA 310.14
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x10de
DeviceID: 0x11c0
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 18.78" x 10.55" (21.54" diag)
47.7cm x 26.8cm (54.7cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 2048 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device:

Memory:
RAM: 7963 Mb

Miscellaneous:
UI Language: English
Microphone: Not set
Total Hard Disk Space Available: 61608 Mb
Largest Free Hard Disk Block: 32987 Mb

Installed software:


Processor Information:
Vendor: AuthenticAMD
Speed: 3300 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.04.1 LTS (64 bit)
Kernel Name: Linux
Kernel Version: 3.2.0-32-generic
X Server vendor: The X.Org Foundation
X Server release: 11103000

Video Card:
Driver: NVIDIA Corporation GeForce GTX 660/PCIe/SSE2

Driver Version: 4.3.0 NVIDIA 310.14
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x10de
DeviceID: 0x11c0
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 18.78" x 10.55" (21.54" diag)
47.7cm x 26.8cm (54.7cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 2048 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device:

Memory:
RAM: 7963 Mb

Miscellaneous:
UI Language: English
Microphone: Not set
Total Hard Disk Space Available: 61608 Mb
Largest Free Hard Disk Block: 32987 Mb

Installed software:

_

Here is a link to my sam3 log , all i changed was find and replace my username with "user"
http://pastebin.com/VZg2BU1C


最近の変更はRegSizedRudyが行いました; 2012年11月23日 1時14分
1-15 / 65 のコメントを表示
< >
AlenL 2012年11月8日 18時16分 
That indeed is not normal. It should be much faster.

For a start, I see that libpci is not installed (64 bit version is the culprit, I guess). According to @johndrinkwater, you can do it with

sudo apt-get install libpci3:i386

If that does help, I would like to ask you to please post another log when this works so we can examine the diffs of cvars that presence of this lib fixed. Maybe we can fix this problem in general even if the lib is not there.

If that does not help (or if it is still not enough), then I would suspect that the compositor might cause it. We had some problems with bad FPS like this caused by some Unity issues, and they went away if you switched over to xfce.

There are indications that the "Unredirect fullscreen windows" flag is enough to fix that, but we still don't have confirmation whether that is true. You might try, but if the flag is not enough, I would appreciate if you can try switching over to xfce temporarily to see if that fixes the problem. Either way please provide feedback as we would like to nail this issue down.

Thanks in advance!
RegSizedRudy 2012年11月8日 18時38分 
Update: I ran the command to install libpci3:i386 and I do not notice any increase in FPS.
here is the pastebin to the log running SS3 for a few minutes after installing that lib
http://pastebin.com/L51sRY1p

I do not know how to change "unredirect fullscreen windows" if you can instruct me on what to do that would be great.

also I am installing xfce so I will try the game again from there.
最近の変更はRegSizedRudyが行いました; 2012年11月8日 18時56分
AlenL 2012年11月8日 18時56分 
Thanks for the log.
The original tip about this flag is from Steam release notes:
• Performance for games running in full-screen mode can be improved by checking the Undirect Fullscreen Windows option (located by clicking the Composite button from the main page). This prevents CCSM from drawing each frame off-screen and then copying to the active window. For more information, see here[askubuntu.com].
There are some other notes about it in there. But again, this is not something we had a chance to verify in detail yet. What we do know is that xfce did have significant performance advantage over Unity in some cases. But hard to know when - thus this beta. :)
All feedback appreciated... Thanks.
RegSizedRudy 2012年11月8日 19時16分 
I checked undirect fullscreen windows option and ran the game in unity desktop, it had no increase in FPS .. Still around 15 - 20 fps.

-

I Installed XFCE with the command sudo apt-get install xubuntu-desktop
then logged out and logged into XFCE session and ran the game , still no increase in FPS (15-20 fps)


15 - 20 FPS is in a level where i am outside and in light combat , it goes closer to 25fps when i am inside and no combat.
LinuxFanatic[Russia] 2012年11月9日 9時18分 
I confirm that - I have Windows 7 in dualboot and Battlefield 3 with all shadows and effects runs very very fast, without any problems.

But SS3:BFE Linux version - slow. Even low all three settings - 15-25 fps and even slowly sometimes, with mini-freezes, mouse aiming even worse at this fps. When minimal settings - I can get 25-50 fps, but graphics level is wrose than in Serious Sam 1 and SS:SE...

I have Phenom II x6, 4 GB DDR3, GTX 465, 64-bit Kubuntu 12.04, KDE 4.9.2 with option "turn off effects for fullscreen application" which allows to get max performance in other games.

Conclusion: performance of SS3:BSE on Linux on some systems - very strange and slow. I'm using latest 310 nvidia drivers with OpenGL 4.3. TF2 performance on high graphics details - excellent.

How I can help developers to solve this problem? Some special testing on my PC?
NeoTheFox 2012年11月9日 10時42分 
Processor Information:
Vendor: AuthenticAMD
Speed: 2800 Mhz
6 logical processors
6 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.04.1 LTS (64 bit)
Kernel Name: Linux
Kernel Version: 3.2.0-32-generic
X Server vendor: The X.Org Foundation
X Server release: 11103000

Video Card:
Driver: NVIDIA Corporation GeForce GTX 480/PCIe/SSE2

Driver Version: 4.3.0 NVIDIA 310.14
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID: 0x10de
DeviceID: 0x6c0
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1680 x 1050
Desktop Resolution: 1680 x 1050
Primary Display Size: 18.82" x 11.81" (22.20" diag)
47.8cm x 30.0cm (56.4cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 1535 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: Realtek ALC892

Memory:
RAM: 7984 Mb

Miscellaneous:
UI Language: English
Microphone: Not set
Total Hard Disk Space Available: 1869731 Mb
Largest Free Hard Disk Block: 1697013 Mb

Installed software:

Confirmed. Very low performance.
XDude 2012年11月9日 10時51分 
I have the same problem. Turning off CCSM doesn't help.

I have to admit that I'm not running the AMD drivers officially santioned by Steam which is 2:8.982-0ubuntu0.1. I'm still waiting for Canonical to update the AMD drivers in their pre-release repo. Any ETA on that?

最近の変更はXDudeが行いました; 2012年11月9日 10時52分
RegSizedRudy 2012年11月9日 13時35分 
This may be nothing but are all of us with low FPS running AMD CPU with Nvidia GPU ?

edit: oh only me and 2 others ..... xdude looks like he is running amd gpu....
最近の変更はRegSizedRudyが行いました; 2012年11月9日 13時36分
XDude 2012年11月9日 13時49分 
I'm running both AMD CPU & GPU :-)
RegSizedRudy 2012年11月9日 14時11分 
Hey , we are all running AMD CPU then , that is something in common !!!
最近の変更はRegSizedRudyが行いました; 2012年11月9日 14時15分
librin.so.1 2012年11月9日 15時19分 
@Roger Korby I am running on an AMD CPU and a Nvidia GPU and I have good FPS.
So there might be more to it than just that.
Maybe it's because of 12.04? (I am on 12.10)
SUSEd 2012年11月9日 22時15分 
I have same FPS on intel hd 4000 with lowest graphical settings. Is it normal?
AlenL 2012年11月10日 4時18分 
AMD GPUs still _do_ have lower perf than in Windows. Playable, but lower. Intel - it depends. We don't yet officially support (as in: if it works - great, if it doesn't - we can't help you) Intel GPUs because the driver is not yet fully ready. Intel is working on it and we how for the best, but can't guarantee anything yet.
Nvidia GPUs, however, should be similar (using 310 driver, and with compositing disabled). What Roger is seeing is a specific problem we are looking into how to reproduce. 660 should run great, so it must be something wrong there. Even 560 works great for us.
RegSizedRudy 2012年11月10日 7時49分 
Just wanted to show comparison for my hardware, when i play SS3 in windows (dual boot) and set all settings to Ultra I get 60 FPS (vsync on) but it works great.
最近の変更はRegSizedRudyが行いました; 2012年11月10日 7時50分
AlenL 2012年11月10日 9時28分 
Yes, that is what is expected. But similar is expected on Linux too. Btw, could you please try running it with OpenGL in Windows, to compare? To switch between APIs use these console commands:

gfx_iAPI=1
gfxRestart()

and to return to DirectX:

gfx_iAPI=2
gfxRestart()

You can invoke the console by pressing F1.
Thanks!
1-15 / 65 のコメントを表示
< >
ページ毎: 15 30 50
投稿日: 2012年11月8日 17時33分
投稿数: 65