Steam for Linux > Limited Beta > Detalles del tema
LinuxFanatic[Russia] 8 de Nov, 2012 a las 7:58
Issue Report: mouse cursor is wrong
I'm using KDE 4.9.2. Problem is that when mouse cursor inside Steam's window - it's style is wrong: looks different, reversed from left to right - very annoying. When I hover cursor on links in Steam browser and other parts of interface - I see correct cursor for my selected style.

So, problem is that Steam changing main cursor style (arrow) for some unknown reason... It would be better to not change or modify styles of mouse cursors at all.
Última edición por LinuxFanatic[Russia]; 8 de Nov, 2012 a las 7:59
Mostrando 1-15 de 94 comentarios
< >
Vash 8 de Nov, 2012 a las 13:50 
I can confirm iI have the same issue on Arch Linux. It happens for my entire desktop in Gnome. I wonder if it happens with all GTK applications as soon as Steam loads, can you try running another GTK app and mousing over it with Steam open?
Jengajam2 8 de Nov, 2012 a las 16:01 
I can also confirm this on Arch Linux and Ubuntu with the i3 window manager, except it affects the entire desktop outside of the steam client excluding other applications. On Unity in Ubuntu, the mouse is unaffected.
Última edición por Jengajam2; 9 de Nov, 2012 a las 19:43
ruff 10 de Nov, 2012 a las 6:10 
Ubuntu vs E17 and LXDE - mouse pointer reversed only over steam windows, rest of desktop unaffected.
NeoTheFox 10 de Nov, 2012 a las 6:17 
Confirmed with kubuntu
Frank 12 de Nov, 2012 a las 15:00 
Thanks for the info, we'll look into it.
LibreWulf 12 de Nov, 2012 a las 15:03 
I can also confirm the issue on Arch Linux with GNOME. It appears to be one of the default X cursors. Doing some research yields a page (not sure if I can post links) that shows the same image of the cursor with this info:

"This shape indicates that a Menu is popped up or pulled down and waiting for a Menu item to be activated or the Menu to be removed."

Other interesting things: For me, the strange cursor appears everywhere except when hovering over Firefox or Thunderbird.
MyFreedom 21 de Nov, 2012 a las 11:12 
Xubuntu 12.04, same problem
Salamek2 22 de Nov, 2012 a las 0:28 
Same here, Just dont touch my cursor and it will be ok ! (I dont need/want any app change my system styles) ;)
Silvershock 22 de Nov, 2012 a las 1:35 
Confirmed also on Kubuntu 12.10 x64. Doesn't stop it working fine, so it's a cosmetic issue only.
14M3RR0R 22 de Nov, 2012 a las 9:14 
Confirmed on Linux Mint 13 x64 KDE 4.8! It looks kinda weird but it seems like its just a minor graphical bug.
storzi 22 de Nov, 2012 a las 15:00 
after running steam (even if closed) i have this wrong cursor also in other gtk-apps at some points, e.g. eclipse (rightclick on the run-as icon) or filezille (rightclick on the servermanager icon). if i restart kde all cursors are back to normal, until starting steam again. seems to override the cursor-settings of the gtk-engine.
(kde 4.9.2 @ ubuntu 12.10, x64)
toga77 25 de Nov, 2012 a las 0:34 
Confirmed on Kubuntu 12.10 x64.
LowHanging*nix[Chav] 28 de Nov, 2012 a las 1:04 
I can confirm this problem. ArchLinux /w Gnome 3. However the cursor problem persists for me for all apps (well all I've tested) AFTER opening Steam. It seems to default back to the default X cursors. However, with other apps (not Steam) it will revert back to the correct themed cursor when the cursor changes (e.g the loading cursor appears).
EDIT: It also reverts Back to the X cursor after the temp cursor (i.e. loading) finishes.
Última edición por LowHanging*nix[Chav]; 28 de Nov, 2012 a las 1:16
Freyr 29 de Nov, 2012 a las 13:54 
Confirmed for Ubuntu 12.10 x64 running Xmonad. As with Jengajam2's experience with i3, the cursor is changed on all desktops.
Dark Raven 29 de Nov, 2012 a las 13:58 
Confirmed on CinnArch x64.
Mostrando 1-15 de 94 comentarios
< >
Por página: 15 30 50