Steam for Linux > Limited Beta > トピックの詳細
johndrinkwater [🐧︀ 🎮] 2012年11月8日 5時35分
Issue Report: Serious Sam 3: BFE emits lots of ‘OpenGL: API error! (CreateTexture)’
A small sample from my terminal,

ERR: OpenGL: API error! (CreateTexture)
ERR: OpenGL: API error! (CreateTexture)
ERR: OpenGL: API error! (CreateTexture)
ERR: OpenGL: API error! (CreateTexture)
INF: Screenshot taken (Temp/ScreenShots/01_CairoSquare_0000.jpg, 1920 x 1080)
ERR: OpenGL: API error! (CreateTexture)
ERR: OpenGL: API error! (CreateTexture)
INF: Started simulation on 'Content/SeriousSam3/Levels/Menu/NetricsaLevel.wld' in 2057.52 seconds.
ERR: OpenGL: API error! (CreateTexture)
etc

Terminal output here: http://pastebin.com/t8d4re8y

Sam3.log here: http://pastebin.com/rNJJLDhr
(note I have reduced the file from 2.3MB to 102KB by running this command:
cat ~/Steam/SteamApps/common/Serious\ Sam\ 3/Log/Sam3.log | uniq > test.log to reduce the CreateTexture error logging per frame to be per second)



Processor Information:
Vendor: AuthenticAMD
Speed: 3200 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.04.1 LTS (64 bit)
Kernel Name: Linux
Kernel Version: 3.2.0-33-generic
X Server vendor: The X.Org Foundation
X Server release: 11103000

Video Card:
Driver: NVIDIA Corporation GeForce GT 630/PCIe/SSE2

Driver Version: 4.3.0 NVIDIA 310.14
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x10de
DeviceID: 0xf00
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 18.78" x 10.55" (21.54" diag)
47.7cm x 26.8cm (54.7cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 2047 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: Realtek ID 662

Memory:
RAM: 16050 Mb

Miscellaneous:
UI Language: English
Microphone: Not set
Total Hard Disk Space Available: 295295 Mb
Largest Free Hard Disk Block: 6602 Mb

Installed software:

1-10 / 10 のコメントを表示
< >
AlenL 2012年11月8日 6時28分 
Thanks for the report. I have a few questions:
- Does this happen always, or only after you've changed some settings? (The log files shows that you've been changing settings several times...)
- Does the game render normally, or are there visual artefacts?
- Does running:
gfxRestart()
from the console (F1) help?
- I see the game couldn't load libpci.so.3. Probably because it is a 64bit OS. Can you please try to install it?
johndrinkwater [🐧︀ 🎮] 2012年11月8日 7時39分 
It appears related to changing some settings (turned off AO and a few other effects to increase fps), as now I don’t see it if I start without changing things.
There wasn’t any issues with the graphics though, visuals were normal (if lower than i’d expect).

Have installed libpci now, could getting the specific card ID (without looking in /proc/) have prevented the output I was getting?
For other people maybe reading this, I did: sudo apt-get install libpci3:i386


I do have another SS3 bug, relating to non-autosave in-game thumbnails being broken, the data looks like the wrong texture layout has been picked http://steamcommunity.com/sharedfiles/filedetails/?id=107266751 want me to post a new thread / or email ?
AlenL 2012年11月8日 14時09分 
When there is no libpci, it has to guess the GPU settings by trying to measure performance. It might have perhaps caused it to do something strange to textures. You could try to verify that by renaming the libpci.so away and starting again. If that is repeatable, then it's something to get on to.

It would also be interesting to know why it took 2000 seconds to start the netricsa simulation. That number looks surreal. Perhaps it is also caused by lack of pci lib causing it to postpone the load while detecting. If you go to try reproducing it, please let me know.

I have filed the thumbnail bug. Thanks for sending the screenshot.
johndrinkwater [🐧︀ 🎮] 2012年11月9日 6時39分 
Having removed libpci3, the problem still does not occur - though the config for the graphics has already been set. I’ll wipe the config and try again, where does Sam store it?
johndrinkwater [🐧︀ 🎮] 2012年11月9日 6時47分 
nevermind, found it I think. /home/john/Steam/userdata/10683171/41070/local/SeriousSam3.ini
johndrinkwater [🐧︀ 🎮] 2012年11月9日 7時50分 
Right, I believe I’ve narrowed it down to the GPU Memory settings, as I can mostly trigger it when low quality (the tick boxes) is set for all. It seems to only trigger if the game is started with defaults on high.

Hope this helps :)

3 snips from the Sam3.All.log


11:50:35 INF: Customized GPU speed cvars:
11:50:35 INF: tex_iAnisotropy = 1 (was 2)
11:50:35 INF:
11:50:35 INF: Customized GPU memory cvars:
11:50:35 INF: cmp_bLowQuality = 1 (was 0)
11:50:35 INF: cmp_pixMaxSize = 1024 (was 4096)
11:50:35 INF: lmp_bLowQuality = 1 (was 0)
11:50:35 INF: lmp_iBaseMip = 1 (was 0)
11:50:35 INF: nmp_bLowQuality = 1 (was 0)
11:50:35 INF: nmp_pixMaxSize = 1024 (was 4096)
11:50:35 INF:
11:50:41 ERR: OpenGL: API error! (CreateTexture)
11:50:45 ERR: OpenGL: API error! (CreateTexture)
11:50:45 ERR: OpenGL: API error! (CreateTexture)
11:50:46 ERR: OpenGL: API error! (CreateTexture)
11:50:46 ERR: OpenGL: API error! (CreateTexture)
11:50:46 ERR: OpenGL: API error! (CreateTexture)
11:50:46 ERR: OpenGL: API error! (CreateTexture)


15:03:32 INF: Customized GPU speed cvars:
15:03:32 INF: tex_iAnisotropy = 16 (was 4)
15:03:32 INF:
15:03:32 INF: Customized GPU memory cvars:
15:03:32 INF: cmp_bLowQuality = 1 (was 0)
15:03:32 INF: cmp_pixMaxSize = 1024 (was 4096)
15:03:32 INF: lmp_bLowQuality = 1 (was 0)
15:03:32 INF: lmp_iBaseMip = 1 (was 0)
15:03:32 INF: nmp_bLowQuality = 1 (was 0)
15:03:32 INF: nmp_pixMaxSize = 1024 (was 4096)
15:03:32 INF:
15:03:33 LOG: 565 shaders reloaded in 0.6 seconds
15:03:38 ERR: OpenGL: API error! (CreateTexture)
15:03:38 ERR: OpenGL: API error! (CreateTexture)
15:03:47 ERR: OpenGL: API error! (CreateTexture)


15:29:11 INF: Apply quality: CPU speed=Ultra, GPU speed=Medium, GPU memory=Ultra (6 customized)
15:29:11 INF: Customized GPU memory cvars:
15:29:11 INF: cmp_bLowQuality = 1 (was 0)
15:29:11 INF: cmp_pixMaxSize = 512 (was 4096)
15:29:11 INF: lmp_bLowQuality = 1 (was 0)
15:29:11 INF: lmp_iBaseMip = 2 (was 0)
15:29:11 INF: nmp_bLowQuality = 1 (was 0)
15:29:11 INF: nmp_pixMaxSize = 512 (was 4096)
15:29:11 INF:
15:29:23 LOG: 677 textures reloaded in 11.7 seconds
15:29:29 LOG: Starting level: "Content/SeriousSam3/Levels/Z5_Other/SV_Deserted.wld"
15:29:29 LOG: Player profile saved with size 3.00kB(96.00kB) at 2012/11/09 15:29:29.
15:29:29 LOG: resFreeUnusedProxies() released '56' and reverted 0 proxy objects in 0.00 seconds.
15:29:29 LOG: resFreeUnusedStock() released 1294 files in 0.05 seconds.
15:29:29 LOG: Started loading world "Content/SeriousSam3/Levels/Z5_Other/SV_Deserted.wld"
15:29:37 ERR: OpenGL: API error! (CreateTexture)
15:29:39 LOG: Finished loading world. (process memory: 456 MB)
15:29:39 LOG: Timestamp: 2012/11/09 15:29:39
15:29:39 INF: Started simulation on 'Content/SeriousSam3/Levels/Z5_Other/SV_Deserted.wld' in 9.56 seconds.
15:29:40 LOG: resFreeUnusedProxies() released '6' and reverted 0 proxy objects in 0.00 seconds.
15:29:40 LOG: resFreeUnusedStock() released 15 files in 0.02 seconds.
15:29:40 ERR: OpenGL: API error! (CreateTexture)
15:29:46 ERR: OpenGL: API error! (CreateTexture)
15:29:46 ERR: OpenGL: API error! (CreateTexture)
15:29:46 ERR: OpenGL: API error! (CreateTexture)
15:29:46 ERR: OpenGL: API error! (CreateTexture)
15:29:46 ERR: OpenGL: API error! (CreateTexture)
15:29:46 ERR: OpenGL: API error! (CreateTexture)
15:29:46 ERR: OpenGL: API error! (CreateTexture)
DEN [CT] 2012年11月20日 1時34分 
John, is this fixed in latest patch?
johndrinkwater [🐧︀ 🎮] 2012年11月20日 2時02分 
When did the patch drop? as trying it this morning, same problem.
Going from my default ultra, ultra (9 customized), ultra, to turning on low quality in gpu memory still triggers this output. http://pastebin.com/a7qPRbYP
AlenL 2012年11月22日 13時00分 
There is a publicbeta to opt into. We are pushing that beta to public, probably tomorrow, and shipping a new beta soon.
johndrinkwater [🐧︀ 🎮] 2012年11月22日 13時35分 
AlenL の投稿を引用:
There is a publicbeta to opt into. We are pushing that beta to public, probably tomorrow, and shipping a new beta soon.
OK, so when I commented I was in the publicbeta, so it was not fixed :)
1-10 / 10 のコメントを表示
< >
ページ毎: 15 30 50
投稿日: 2012年11月8日 5時35分
投稿数: 10