Steam for Linux > Limited Beta > Topic Details
johndrinkwater [🐧︀ 🎮] Nov 8, 2012 @ 3:36am
Issue Report: Dungeons of Dredmor doesn’t load overlay
Confirmed its not because i’m on x86_64, as the launching script echos:
Dredmor: Using x86 version.
Showing 1-3 of 3 comments
< >
icculus Nov 13, 2012 @ 5:33pm 
(We force 32-bit if you launch from Steam, because there's no 64-bit Steamworks SDK at the moment...we figured you'd probably want achievements to work. :) The 64-bit version is in there in case you don't care or need it or whatever. We'll let it use the 64-bit version when we have the SDK.)

Launch the game with "-opengl" on the command line and the overlay will work.

--ryan.
johndrinkwater [🐧︀ 🎮] Nov 14, 2012 @ 3:20am 
Ah, and it does.
So this is now a feature request: can -opengl be a default launch option.
icculus Nov 14, 2012 @ 10:47am 
I asked Gaslamp about this last night and they agree it's reasonable to make it the default on Linux (as it is on Mac OS X already)...it's not like there's any other game on Steam that doesn't require OpenGL.

So we'll probably make that default in the next build.

--ryan.

Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: Nov 8, 2012 @ 3:36am
Posts: 3