Steam for Linux > Limited Beta > Dettagli della discussione
Dobby 6 gen 2013, ore 22:47
TF2 on Debian lags badly, yet Ubuntu with the same driver and it can max.
I despise and hate ubuntu, I have used Debian and FreeBSD for years. It wasn't long before I was fed up with Ubuntu and moved back to Debian to set up steam and all is well, the only problem is that it lags like hell unless everything is at lowest and the resolution is 800x600 and windowed. Yet on Ubuntu I could max everything and at 1360x768 without a problem. I'm using nvidia's proprietary driver for the 9500GT as I were in Ubuntu. Has anyone got any suggestions? I'd greatly appreciate it.
Visualizzazione di 1-10 commenti su 10
< >
penguinvasion 7 gen 2013, ore 0:35 
Are you sure you have the exact same setup on both OSes? Ubuntu might have a newer version of the driver. Can you verify that the driver is exactly the same?

You can try doing some benchmarks on both OSes and compare the difference.
Dobby 7 gen 2013, ore 1:38 
The driver is exactly the same, I don't see a reasonable motive to get a bench mark on both. I rid Ubuntu for Debian anyway, I tried messing around with the nvidia settings as the sticky mentioned to disable an option to increase performance but it hasn't affected it at all.
dave 7 gen 2013, ore 5:52 
Most likely the glx drivers aren't properly installed on your Debian system. Try running the following command: glxinfo | grep ^OpenGL

Vendor should be Nvidia, and the version string is the driver version.

If you don't see this, then you're missing the glx drivers for Nvidia. Type in the following command to install them: "apt-get install nvidia-glx". If you're running 64 bit Debian, you may as well install the i386 version of the drivers as well, since TF2 is undoubtedly 32 bit (apt-get install nvidia-glx:i386)
Dobby 7 gen 2013, ore 6:15 
I'm using 32bit version of Debian Wheezy fully up to date.

OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 9500 GT/PCIe/SSE2/3DNOW!
OpenGL version string: 3.3.0 NVIDIA 310.19
OpenGL shading language version string: 3.30 NVIDIA via Cg compiler
OpenGL extensions:

That's what that returned, 310.19 is the latest. I'm trying to think what else I can do, I tried setting the nvidia setting's app to work towards performance over quality and hardly a difference.
Plagman 12 gen 2013, ore 10:49 
Hi Robby,

What desktop environment / window manager / desktop effects are you using on both machines?

Thanks,
- Pierre-Loup
Dobby 16 gen 2013, ore 6:31 
I use Fluxbox, no eyecandy on either of them.
Satan Saves! 16 gen 2013, ore 13:22 
I had the same problem on my Arch, now I moved to Kubuntu and no issues aside from the TF2 port being some major shit for anyone into the game, due to the lack of raw input and slow loading times.
Dobby 17 gen 2013, ore 5:16 
I made a duelboot, I despise Ubuntu but I have it there simply for whenever I get bored and wish to play TF2.
jmh 17 gen 2013, ore 7:28 
If running debian 6 update to wheezy.
instabilis 17 gen 2013, ore 16:54 
Do you have the 32bit libboost packages installed?
Visualizzazione di 1-10 commenti su 10
< >
Per pagina: 15 30 50