Steam for Linux > Limited Beta > Topic Details
Essence1 Dec 14, 2012 @ 6:32am
Issue Report: Steam won't install on Linux Mint.
After downloading steam and attempting to install it on Linux Mint and trying to install it through gdebi using the command gdebi steam_latest.deb and through the gdebi GUI it doesn't work. Both bring up an error of "Wrong Architecture 'i386'", and I can't install them. This appears to be an error within the install file because it doesn't even try to install it. I am running on Linux Mint 12. Thanks for reading.
Showing 1-15 of 32 comments
< >
uppfinnarn Dec 14, 2012 @ 6:48am 
are you using a 32bit or 64bit OS? That error means you got an incompatible build (64bit binary on a 32bit OS)
Essence1 Dec 14, 2012 @ 7:32am 
I'm on 64-bit. I probably should have thought to mention that.
uppfinnarn Dec 14, 2012 @ 7:34am 
what exactly does it say is the wrong architecture? Copy the whole error.
Blah Dec 14, 2012 @ 7:44am 
I have Linux Mint 14 cinnamon and Steam is working fine (except big pic). I had some troubles with it before installing drivers, but after installing drivers steam worked fine.

Maybe you should update to latest linux mint.
lostgoat Dec 14, 2012 @ 7:48am 
I'm noticing the same problem in Ubuntu 11.04 (I know the OS is no longer supported, I was just testing the package for the fun of it)

The control file on the deb package specifies:

Architecture: i386

Which triggers the error Wrong architecture 'i386' since we are running 64bit systems.

The web server maybe gave us the wrong package to download(?).

Edit: I tested changing the architecture tag of the package and it fails on dependency checks. I will call this inconclusive information since I am on an outdated OS right now.

Last edited by lostgoat; Dec 14, 2012 @ 7:58am
Sage Dec 14, 2012 @ 8:02am 
My friend had issues with gdebi too, try `dpkg -i steam.deb` from the command line.
McRaia [Linux] Dec 14, 2012 @ 8:11am 
This thread might help (searched for "ubuntu architecture"): http://steamcommunity.com/app/221410/discussions/0/846939615004873516/
lostgoat Dec 14, 2012 @ 8:12am 
dpkg triggers the same error because of the control file restrictions. Error:
package architecture (i386) does not match system (amd64)

I would also like to note that the download server does not provide a steam.deb anymore, but it has changed to steam_latest.deb. Since it seems that there have been some changes with the file server I was inclined to mention that we probably were given the wrong package.

Update after reading Mark's post:

I guess this package is supposed to work on x86_64 architectures as well since people successfully installed it from the thread Mark linked.
Last edited by lostgoat; Dec 14, 2012 @ 8:23am
Essence1 Dec 14, 2012 @ 2:59pm 
I tried the method detailed by Mark's post but it didn't work any other suggestions?
McRaia [Linux] Dec 14, 2012 @ 3:07pm 
Well, have you considered upgrading to at least Linux Mint 13 LTS?
Keiro Dec 14, 2012 @ 4:52pm 
Hi,

Try the following in terminal in Linux Mint:

sudo apt-get install ia32-libs

Then:

sudo dpkg -i steam_latest.deb

However, when I tried this, I got the following:

STMNOC Downloads # dpkg -i steam_latest.deb
(Reading database ... 166188 files and directories currently installed.)
Unpacking steam:i386 (from steam_latest.deb) ...
dpkg-deb (subprocess): short read on buffer copy for failed to write to pipe in copy
dpkg-deb: error: subprocess paste returned error exit status 2
dpkg: error processing steam_latest.deb (--install):
short read on buffer copy for backend dpkg-deb during `./usr/lib/steam/bootstraplinux_ubuntu12_32.tar.xz'
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for man-db ...
Errors were encountered while processing:
steam_latest.deb
STMNOC Downloads #

OS and hardware statistics:

OS: root@STMNOC# sauce
Hello, root. Welcome to STMNOC
You are on Linux Mint 13 Maya, with x86_64 as your platform.

I have also generated System Information and saved it as a HTML file. From there, I can send it to someone who can take a look.

But, the quick and dirty of my laptop's hardware is:

CPU: Intel Pentium P6000 @ 1.87Ghz, dual-core
RAM: 8GB RAM
HDD: Western Digital 250GB
Display: Mesa DRI Intel Ironlake Mobile, running Cinnamon

Edit: If you want specific details on this laptop: Acer Aspire 7741Z-5731.
Last edited by Keiro; Dec 14, 2012 @ 4:54pm
Chilibird Dec 14, 2012 @ 9:51pm 
Steam installs with no issue on Mint 14 64 bit here. Maybe it's something with that transition from steam to steam_latest.deb?

edit: should probably also mentioned it installed fine under Mint 13 as well.
Last edited by Chilibird; Dec 14, 2012 @ 9:51pm
McRaia [Linux] Dec 15, 2012 @ 3:15am 
@Keiro: Easier than sending log files, use pastebin.org or paste2.org and put the link to your "paste" in this thread.
Keiro Dec 15, 2012 @ 6:26am 
Originally posted by Mark McRaia:
@Keiro: Easier than sending log files, use pastebin.org or paste2.org and put the link to your "paste" in this thread.

... I'll have to do an LSPCI dump, as System Information will not let me generate a useful report for others to use.

... I'll get back to everyone in here on that.

EDIT: http://pastebin.com/bctpXF6U
Last edited by Keiro; Dec 15, 2012 @ 6:36am
McRaia [Linux] Dec 15, 2012 @ 8:08am 
Not much useful info there, may be inxi -G give more detail on your graphics. But I'm no expert (not yet).
Showing 1-15 of 32 comments
< >
Per page: 15 30 50