Steam for Linux > Limited Beta > Topic Details
Demonishi Dec 11, 2012 @ 10:14pm
Steam/TF2 does not acknowledge the primary monitor marked by nvidia-settings.
I have downloaded Team Fortress 2, I am trying it out for the first time. I had previously told nvidia-settings that my right screen is primary, but Steam and TF2 do not acknowledge it. Is Steam looking for something specific to determine the primary monitor, so I can correct this? My system sees the left monitor as primary as well. I'd like to point out the diagnostics below acknowledges my right screen as the primary and not the left. The left screen is lower resolution and I think it's causing a problem, I cannot click next in the tutorial or anything. I was just figuring I'd look into this before I physically swap the cables (newly assembled PC).

Processor Information:
Vendor: GenuineIntel
Speed: 3401 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.04.1 LTS (64 bit)
Kernel Name: Linux
Kernel Version: 3.2.0-34-generic
X Server vendor: The X.Org Foundation
X Server release: 11103000

Video Card:
Driver: NVIDIA Corporation GeForce GTX 260/PCIe/SSE2

Driver Version: 3.3.0 NVIDIA 310.14
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x10de
DeviceID: 0x5e2
Number of Monitors: 2
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 3600 x 1080
Primary Display Size: 20.08" x 11.30" (23.03" diag)
51.0cm x 28.7cm (58.5cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 896 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: Realtek ALC898

Memory:
RAM: 7930 Mb

Miscellaneous:
UI Language: English
LANG: en_US.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 1392879 Mb
Largest Free Hard Disk Block: 630225 Mb

Installed software:

Recent Failure Reports:

Last edited by Demonishi; Dec 11, 2012 @ 10:42pm
Showing 1-5 of 5 comments
< >
Vash Dec 12, 2012 @ 1:22am 
It appears to pick fullscreen windows on the display they were started from. Also, you can alt-drag between the monitors, or whatever other key you might have set as your 'drag' key in your window manager.
Demonishi Dec 12, 2012 @ 7:23am 
I moved Steam to the right screen, it loaded TF2 on the left screen. It's okay, I'll just swap the cables, but I thought they might like to know about this at least.
Fall711 Dec 12, 2012 @ 1:41pm 
Got the same problem, but for me i can't play... I don't know what's going on with steam screens and resolutions? :)

But i'm very happy to see steam on the penguin. Can't wait to get it working!
Demonishi Dec 13, 2012 @ 1:39am 
Actually, I swapped the cables, remarked my right screen as primary, Steam opened on the right screen.. TF2 loaded on the left again =.( I was able to wrangle my way through settings to set it to windowed mode to move it though.
mikesart Jan 17, 2013 @ 3:15am 
You should be able to pick which display TF2 will start up fullscreen on now in the options dialog. There is also a new command line option which will allow you to pick as well: "-displayindex #" where # is the sdl display index, 0 being the primary.
Showing 1-5 of 5 comments
< >
Per page: 15 30 50