Steam for Linux > Limited Beta > Topic Details
piteer1 Dec 9, 2012 @ 1:08pm
Issue Report: Trine 2 does not start (without any message)
There's a problem with Trine 2 on Linux ( (K)Ubuntu 12.10). I'm getting pop up dialog with information that some libraries are missing and I require some additional drivers/packages and administrative privileges. Clicking 'Yes' doesn't look like is doing anything.

Trace from console from Steam:
Game update: AppID 35720 "Trine 2", ProcID 7241, IP 0.0.0.0:0
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
dpkg-query: package 'ia32-libs' is not installed and no information is available
Użyj dpkg --info (= dpkg-deb --info), aby zobaczyć informacje o pakiecie,
oraz dpkg --contents (= dpkg-deb --contents), aby sprawdzić jego zawartość.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'ERROR: ld.so: object 'gameoverlayrenderer.sogameoverlayrenderer.so' from ' from LD_PRELOADLD_PRELOAD cannot be preloaded: ignored.
cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
/home/piteer/.local/share/Steam/SteamApps/common/Trine 2/trine2.sh: 104: /home/piteer/.local/share/Steam/SteamApps/common/Trine 2/trine2.sh: xterm: not found
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
nohup: przekierowanie standardowego wyjścia błędów do standardowego wyjścia
Game removed: AppID 35720 "Trine 2", ProcID 7241
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully

At the end I was able to run it by installing ia32-libs (as I can guess these ones Steam
wanted to install).

Hardware:
GeForce 570M 1.5GB
Intel Core i7-2630QM
16GB RAM
Kubuntu 12.10 (Kernel 3.7.0-4-generic)
Nvidia Drivers: 310.19
Showing 1-4 of 4 comments
< >
PottyBert Dec 9, 2012 @ 1:38pm 
I had to massage trine2 a bit to get it working, I'm using mint which the initial setup script doesn't detect.

try running
#install ia32
sudo apt-get --fix-missing install ia32-libs
#install openal
sudo apt-get --fix-missing install libopenal1

then try CDing to your trine2 main dir and running the starter script directly (thus skipping the distro checks)
cd "~/Steam/SteamApps/common/Trine 2"
./bin/trine2_bin_starter.sh
piteer1 Dec 9, 2012 @ 1:49pm 
Thanks for the info. I was also able to run it after installation of ia32-libs. Still this is an issue, because even when Steam (or Trine) detected missing libraries, script that should install them, didn't work at all.
PottyBert Dec 9, 2012 @ 2:05pm 
yeah, I think it's an issue specifically with Trine's script though rather than steam. They only check for Ubuntu in the lsb-release and there's a comment "# Note, for now, just assuming ubuntu 12+".

If you mention it on the Trine2 forum (or possibly the non-valve games forum) someone may notice and fix the issue.
piteer1 Dec 10, 2012 @ 8:27am 
Question to Moderators: Could this topic be moved then to Non-Valve games where it belongs to?
Showing 1-4 of 4 comments
< >
Per page: 15 30 50
Date Posted: Dec 9, 2012 @ 1:08pm
Posts: 4