Steam for Linux > Limited Beta > Topic Details
pmnoxx Dec 9, 2012 @ 6:30am
killing floor config
I was curious as to what may happen if I select direct 3d mode instead of opengl.
After I had made this change, game crashes.
I'm unable to run killing floor since then.

Where is the config file of killing floor located on Linux?

edit:
I tried to reinstall the game, but that didn't help.
Last edited by pmnoxx; Dec 9, 2012 @ 6:43am
Showing 1-5 of 5 comments
< >
mikeym Dec 9, 2012 @ 6:47am 
The file in Windows is KillingFloor/System/Default.ini

Weirdly for me (with it functioning under Linux) it shows:

[Engine.Engine]
RenderDevice=D3D9Drv.D3D9RenderDevice
;RenderDevice=D3DDrv.D3DRenderDevice
;RenderDevice=Engine.NullRenderDevice
;RenderDevice=OpenGLDrv.OpenGLRenderDevice
;RenderDevice=PixoDrv.PixoRenderDevice

drjoms Dec 9, 2012 @ 8:43am 
I am guessing, last correct settings are used by default.
If all works - its not a bug :P
Tele42 Dec 9, 2012 @ 9:25am 
the killing floor config file is located at ~/.killingfloor/System/KillingFloor.ini
Hitch Dec 10, 2012 @ 9:31pm 
Would anyone know the solution to this? I have deleted my .ini and verified and yet killing floor does not launch.
pmnoxx Dec 17, 2012 @ 1:45pm 
Originally posted by Tele42:
the killing floor config file is located at ~/.killingfloor/System/KillingFloor.ini
Thanks, changing settings inside that file helped.
This may not be classified as a bug, but it is clearly a poor design.
Showing 1-5 of 5 comments
< >
Per page: 15 30 50