Steam for Linux > Limited Beta > Topic Details
Fist McStrongpunch #Cloudcreeper Dec 8, 2012 @ 10:37pm
Installed cient, Wont launch
Installed linux beta client as per instructions in getting started post, Tried to open it, It prompted me for password to complete install, So I input said password, Prompt disappeared as expected, No further activity. Attempted to launch again and got nothing. Linux Mint 14 cinnamon x64 fresh install using current nVidia proprietary driver on a geforce gtx550ti. Has anyone else had this issue?
Showing 1-7 of 7 comments
< >
Snap Dec 8, 2012 @ 11:02pm 
Yes, same thing here with Linux Mint 14 Mate x64.

/var/log/dmesg doesn't contain anything useful.
I did a
ps -ef | grep steam
, that listed steam.sh and ~/.local/share/Steam/ubuntu12_32/steam . I killed both and tried to run the latter:

ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
Installing breakpad exception handler for appid(steam)/version(0_client)
SteamUpdateUI: An X Error occurred
X Error of failed request: BadAlloc (insufficient resources for operation)

I have 12GB of free memory and plenty of disk space, I do not understand...
Last edited by Snap; Dec 8, 2012 @ 11:02pm
V1TSK Dec 8, 2012 @ 11:02pm 
Install x86 libraries.
Fist McStrongpunch #Cloudcreeper Dec 9, 2012 @ 9:21pm 
I cant say i'm an advanced linux user. Infact i'm only just getting into it in the grand scheme of things, But I can safely say I understand its not getting enough resources on a machine with more than enough. To me that screams "missing dependancy". And the only thing we're told is to install x86 libraries. Well ♥♥♥♥ mate, Which flipping libraries? Any linux user beginner or advanced knows there be countless library packages out there for every distro. So hows about someone tells me which one to install before I go filling my hard drive with stuff I wont need eh?
I came here in the hopes of a bit of technical assistance, A three word answer is hardly what i'd call technical assistance.
paulguy119 Dec 10, 2012 @ 1:10am 
Well, the problem seems to be at least with X so try the 32 bit X libraries. If it still fails, it'd probably be a good idea to delete your ~/.steam directory and run steam again as well since your steam might not have bootstrapped correctly.
johndrinkwater [🐧︀ 🎮] Dec 10, 2012 @ 4:03am 
Originally posted by Fist McStrongpunch #Cloudcreeper:
I came here in the hopes of a bit of technical assistance, A three word answer is hardly what i'd call technical assistance.
Please post the full output from steam when you run it from a terminal. It’s hard to give technical responses with so little to go on.
BadAlloc’s can be caused by a few things, hdd space and free memory should not be the cause :)
Dyrvër Dec 10, 2012 @ 4:39am 
umm, "sudo dpkg --add-architecture i386 && apt update" perhaps?
A few tips I always go through when a game or app refuses to start. I often start by using the ldd command on the executable from the terminal: aka "ldd ~/.local/share/Steam/ubuntu12_32/steam" in this case and I also check the package description / script for details about other files it needs.
But other then that I think pointers for Debian wheezy and up are the best sources for help when dealing with Linux Mint. Use google, lazy humans.

However If you experience any black screens and such things, try the fallback mode without visual effects on the desktop, first make sure you are running the most current/beta drivers from the manufacturer and not the open source ones.
Anyways, there's a good reason to get back with your distro maintainers and ask them to rename a few packages so the devs won't have to add too many ifdefs :P
Snap Jan 16, 2013 @ 3:47pm 
Hi, I had an issue with the fglrx-* packages (ATI drivers) and could not start X anymore. I removed the 2 packages, X started, I launched Steam, it downloaded and update and worked. Maybe that's your issue too.
Showing 1-7 of 7 comments
< >
Per page: 15 30 50