Steam for Linux > Limited Beta > Topic Details
Scan_Ferr Dec 8, 2012 @ 8:06pm
TF2 crash after loading
I installed Ubuntu 12.04 and the AMD 12.11 beta driver. It happens that when I run TF2 it shows that loading bar and then it suddenly crashes to desktop. I can't try with any other game because of the 33 games I have on Steam, just TF2 is supported algonside with Psychonauts (this one isn't fully supported yet).

Is this some driver related problem?

System Information:

Processor Information:
Vendor: GenuineIntel
Speed: 1734 Mhz
8 logical processors
4 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.04.1 LTS (64 bit)
Kernel Name: Linux
Kernel Version: 3.2.0-34-generic
X Server vendor: The X.Org Foundation
X Server release: 11103000

Video Card:
Driver: ATI Technologies Inc. ATI Mobility Radeon HD 5800 Series

Driver Version: 4.2.11995 Compatibility Profile Context
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x1002
DeviceID: 0x68a0
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 13,54" x 7,60" (15,51" diag)
34,4cm x 19,3cm (39,4cm diag)
Primary VRAM Not Detected

Sound card:
Audio device:

Memory:
RAM: 7975 Mb

Miscellaneous:
UI Language: English
LANG: pt_PT.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 39371 Mb
Largest Free Hard Disk Block: 23874 Mb

Installed software:

Recent Failure Reports:
Sun Dec 9 03:59:03 2012 GMT: file ''/tmp/dumps/crash_20121209035900_1.dmp'', upload yes: ''CrashID=bp-58c71f27-b4c8-441d-962f-12d442121208''
Sun Dec 9 04:02:13 2012 GMT: file ''/tmp/dumps/assert_20121209040208_1.dmp'', upload yes: ''CrashID=bp-68ad3561-6dc7-4acb-b4c9-ef6932121208''

Showing 1-5 of 5 comments
< >
Fixion Dec 8, 2012 @ 8:57pm 
I have the same problem, though it may not be driver related. TF2 exhibits the same problem without giving any errors. Where can I find the logs?

Uplink and Darwinia are the only games that works for me. I'm running Mint 14 (Nadia) using Nvidia driver 304.51 on a Quadro 2000.
soratheultima Dec 8, 2012 @ 9:05pm 
Do you have the beta 12.11 drivers Scan_ferr? and try this, make tf2 go into windowed mode and disable vsync btw you need to be patient when the game loads into a server (it does take a little time)
Last edited by soratheultima; Dec 8, 2012 @ 9:07pm
Scan_Ferr Dec 9, 2012 @ 1:28pm 
Soratheultima,

I do have beta 12.11 drivers. How can I go into windowed mode and disable vsync without getting in the game? Adding to the shortcut? Is the shotcut to windowed mode the same as Windows? What about vsync?

The problem isn't when it loads to a server. It happens right when I close the game. It shows that "loading" screen before the menu and then it crashes!

@ Fixion,

Mate, if you can find some solution, please post here! And the logs too...
Brinehaart Dec 10, 2012 @ 1:50pm 
I have the same problem too. For the last 4 times it crashed after it finished loading or just before it begun.
Scan_Ferr Dec 20, 2012 @ 12:51pm 
It worked the other day with the new steam update. Hope it stays like this :)
Showing 1-5 of 5 comments
< >
Per page: 15 30 50