Steam for Linux > Limited Beta > トピックの詳細
tomemozok 2012年12月8日 16時55分
Linux Distribution
So i have sent a mail on the mailing list,but noone responded to me,so...
I formatted my PC 3 days ago(my maintenance policy of 6 months was up),and still have no Linux distribution installed.

What Distribution has the least testers,or,rather,what distribution the developers need the most info at the moment?

I am most familiar with Ubuntu,and have also used Fedora.But am eager to learn any new Linux.
1-15 / 15 のコメントを表示
< >
Tux 2012年12月8日 17時00分 
Ubuntu and its derivatives are the only ones being supported. However you can install Steam on other distro's, but you will most likely run into dependency errors.
Garydos 2012年12月8日 17時12分 
valve is only supporting debian based distros at this stage. I guess you could find a not-well-known fork, but I doubt it'll matter. Stick to debian for now
DCVertigo 2012年12月8日 17時26分 
I heard that there is an issue with #! installing the client but not running the games ... I have that on a partition but not tried myself yet
tomemozok 2012年12月8日 17時36分 
Ok so Ubuntu it is!!!
:D
(CPK)PreachaKilla187 2012年12月8日 20時34分 
I'm sure some Mint users could benefit from the beta. I have been thinking i may partition and install Mint and Ubuntu on both of my machines for testing. Im sure valve would be happier with that.
Tux 2012年12月8日 20時42分 
+1 to PreachaKilla. Im running Mint myself. There are a few of us, but not a whole lot, testing right now. So I would go with that if I were you.
TheMaxTor 2012年12月8日 23時50分 
I'm running Mint as well. So far so good.
Vash 2012年12月9日 0時00分 
Just to add input, I've been in the beta since the first thousand group opened and it's been working great on Arch. Valve might not officially support it but other distros are definitely working on it and it's not tied to Ubuntu at all.
zenitur 2012年12月9日 1時52分 
Try any RPM-based Linux distribution or Debian. If you want try without install, you can use KNOPPIX (based ob Debian) and Sabayon (Source based).
1Samildanach 2012年12月9日 2時29分 
Linux Mint or Linux Mint Debian Edition would be good choices, especially if you want something with similar package management etc. to Ubuntu -- Mint is based on Ubuntu, LMDE is essentially Debian Testing (don't be put off by the name; it is about as stable as most distros, just not DEbian Stable stable :P), and Ubuntu was originally based on Debian.

If you're willing to learn, though, Arch might be worth trying. The chief advantage I see in it for testing software is that, unlike most distros, its packages have minimal or no modifications; most distros take the source release from the developers then do some distro-specific stuff before chucking it in a package, while Arch tries (as much as practicable) to just compile the source and putting it in a package. Plus it teaches you a lot about how things work.
e633 2012年12月9日 2時42分 
Linux Mint all the way!!!
It's a perfectly working Ubuntu without the Unity crap.
milamber657 2012年12月9日 3時35分 
tomemozok の投稿を引用:
So i have sent a mail on the mailing list,but noone responded to me,so...
I formatted my PC 3 days ago(my maintenance policy of 6 months was up),and still have no Linux distribution installed.

What Distribution has the least testers,or,rather,what distribution the developers need the most info at the moment?

I am most familiar with Ubuntu,and have also used Fedora.But am eager to learn any new Linux.

NOte that the steam client requires at least libc 2.15 . Debian Wheezy which is the testing branch right now has 2.13. So stick with Ubuntu. For other debian derivatives like Mint I have no feedback to give.

I use fedora 17 and it works ok.
McRaia [Linux] 2012年12月9日 7時01分 
Linux Mint 14 Cinnamon (x86_x64) works fine. Though for playing games, I log out and switch to Gnomme Calssic (Fallback, no effects), otherwise I often get a black screen.

Kernel 3.5, Catalyst 12.11 (fglrx: 9.010.11 via xorg-edgers)
CompanionTube 2012年12月9日 7時20分 
Seegras 2012年12月9日 8時15分 
Debian is problematic. I do run steam on Debian, and I had to a) upgrade to libc6 2.16 from the experimental repositories; b) fix the dependency to libpulse0 >= 1:0.99.1 (actual libpulse is 2.0-6, which is misinterpreted as being older) and c) remove the dependency to libjpeg-turbo8 (which is not available in debian, seehttp://bugs.debian.org/cgi-bin/bugreport.cgi?bug=612341 , but mostly compatible to libjpeg8. The difference is 20% speed). It works somehow. As far as I've seen, the bugs I encountered (cut&paste not working, menus unclickable) have been found with Ubuntu too and are rather dependant on the window manager or the settings (sloppy focus for instance)
1-15 / 15 のコメントを表示
< >
ページ毎: 15 30 50
投稿日: 2012年12月8日 16時55分
投稿数: 15