Steam for Linux > Limited Beta > Topic Details
FlyLow Dec 7, 2012 @ 9:12am
Install on Ubuntu 64-bit
I see many people have this working on various 64-bit distros, but how the install is accomplished in detail is missing, and details are important when it doesn't work. :)

So, first I did "gdebi steam.deb" (leaving out sudos for clarity):
This package is uninstallable
Wrong architecture 'i386'

Most comments refer to ia32-libs, which I tried to install: apt-get install ia32-libs:
The following packages have unmet dependencies:
ia32-libs : Depends: ia32-libs-multiarch but it is not installable
E: Unable to correct problems, you have held broken packages.

Trying to install the dependency manually yields:
Package ia32-libs-multiarch is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'ia32-libs-multiarch' has no installation candidate

System reports distro version as Ubuntu 12.10.

Any hints here? Am I missing a package repository?
Showing 1-12 of 12 comments
< >
Daegul Dec 7, 2012 @ 9:21am 
Not sure if this is what you're *meant* to do, but I used dpkg -i --force-architecture steam.deb

That complained about being unable to find dependencies, but if you then run apt-get install, the output should tell you how to fix the dependencies for the install that's left pending. (something like apt-get install -f iirc)
danny Dec 7, 2012 @ 9:26am 
I also have Ubuntu 12.10 64 Bit and haven't installed ia32-libs or anything similar.
I just clicked on the deb file after the download and the Software Center opened itself where I could just click on "Install" and it worked.
Not sure if your setup is somewhat different to mine though.
Why Tea ? Dec 7, 2012 @ 9:31am 
I have the same problem and have tried the same things, I'm taking a look on my other ubuntu pc to see if there is the same problem
[iG]Cake Sale Dec 7, 2012 @ 9:34am 
I just installed it now with no problems. I have installed ia32-libs before though so this might be why I didn't run into any problem. Try installing ia32-libs with Synaptic Package Manager.

Install GDebi Package Installer and then right click steam.deb file and open it with GDebi. It will open up in GDebi instead of Ubuntu Software Centre and should install any dependencies that are needed when you click on "Install".
Why Tea ? Dec 7, 2012 @ 9:59am 
I installed it on my second PC and it works directly (the pc is more recent, and on Ubuntu 12.04)
Last edited by Why Tea ?; Dec 7, 2012 @ 10:00am
elgregor Dec 7, 2012 @ 10:02am 
I just installed it trough USC on Ubuntu 12.10 x64. But it looks like I already had ia32-libs installed.
FlyLow Dec 7, 2012 @ 10:11am 
I tried to install ia32-libs through the package manager and received the same error message (ia32-libs-multiarch). Lots of other related problems on the web with the multiarch package so I'll track down that path first.
SimonOmega Dec 7, 2012 @ 11:07am 
Curious, did you do a build from debootstrap or a minimal build?
Sounds like a missing dependancy in the form of a Package available in Desktop by default, but not installed during a minimal (or other custom install).

I plan on trying Optimus/BumbleBee this weekend. I'll do an install from debootstrap and see if it's just something missing but expected.

If that helps, I could be way off.
FlyLow Dec 7, 2012 @ 11:19am 
I think I found the solution -- I needed to add i386 as a supported architecture first.

sudo dpkg --add-architecture i386
sudo apt-get install ia32-libs
Voconathem Dec 7, 2012 @ 11:29am 
Now im getting:

Dependency is not satisfiable: multiarch-support (>= 2.15-0ubuntu10.2)
mikeym Dec 7, 2012 @ 11:32am 
Originally posted by Voconathem Requivent:
Now im getting:

Dependency is not satisfiable: multiarch-support (>= 2.15-0ubuntu10.2)

http://steamcommunity.com/app/221410/discussions/0/882965118613928324/
Root_Kit Dec 7, 2012 @ 3:20pm 
I got steam to work by running:

sudo dpkg --add-architecture i386
sudo apt-get update

Then doing something like this (I can't remember exactly but it worked):

sudo dpkg -i steam.deb
sudo apt-get install -f # (If the above command errors)
sudo dpkg -i steam.deb

http://wiki.debian.org/Multiarch/Implementation
https://wiki.ubuntu.com/Valve

It took a while but worked with some trial and error. I'm using Ubuntu 12.10 x64 installed with a Wubi.

Last edited by Root_Kit; Dec 7, 2012 @ 3:23pm
Showing 1-12 of 12 comments
< >
Per page: 15 30 50
Date Posted: Dec 7, 2012 @ 9:12am
Posts: 12