Steam for Linux > Limited Beta > Topic Details
diddee4 Dec 7, 2012 @ 8:52am
issue report: Failed to load steamui.so - LM 14 64 Bit
OK, so it "was" working on LM 13 64 bit...but I get this error on LM 14.

Any ideas?


--UPDATE--

sudo vi /etc/ld.so.conf.d/steam.conf

Add next two lines to file:

/usr/lib32
/usr/lib/i386-linux-gnu/mesa

sudo ldconfig

Should work on most distros, ymmv depending on where you 32 bit libs are. Steam client
now runs as expected.
Last edited by diddee4; Dec 7, 2012 @ 1:41pm
Showing 1-8 of 8 comments
< >
benbyington84 Dec 7, 2012 @ 9:03am 
I was having this same error on Fedora 17 x86_64. run 'LD_DEBUG=libs steam' in your terminal. That will give you a crapton of output showing each library that is trying to be loaded and all the places your computer looks for that library. For each library you should see a ton of attempts to find it, culminating in a call to init that library. If you are missing that init line then you are probably missing that library, and so you can try installing explicitly. When I first installed steam it explicitly told me that it was missing some libraries and they were easy to find. Then some library loads stated to fail silently and I'd just get errors like this, and I had to use the above method to track down some more. Good luck!
diddee4 Dec 7, 2012 @ 11:31am 
Yeah, That is a lot of libs that don't exist.. Doesn't add up...
Samaritan Dec 7, 2012 @ 12:03pm 
I'm having the same issue. Currently running around trying to fix it. The strangest thing is that it worked just last night.

I'm running Ubuntu 12.10 x86-64 on a Samsung-R580
TheAmethyst Dec 7, 2012 @ 12:15pm 
Same issue.
Arch Linux
Linux version 3.6.7-1-ARCH on a HP Elitebook 8560w.
[BS]Dashkal Dec 7, 2012 @ 12:29pm 
To find all the missing libraries, I used this command:
$ cd ~/.steam/bin32
$ ( for file in *.so; do ldd $file; done) | grep "not found"
mikeym Dec 7, 2012 @ 12:38pm 
Originally posted by BSDashkal:
To find all the missing libraries, I used this command:
$ cd ~/.steam/bin32
$ ( for file in *.so; do ldd $file; done) | grep "not found"

This doesn't work for me (Fedora 17) I use:

cd ~/.local/share/Steam/ubuntu12_32/
export LD_LIBRARY_PATH=.; for file in *.so; do ldd ./$file | grep found; done

You may need to change the cd path to point to your Steam folder.
Arch Dec 7, 2012 @ 12:47pm 
You're missing a couple of packages basically. Since I'm running the KDE spin of Fedora I cannot really say for Ubuntu users, but this is what I did to get it to work:

First of, install packages. Note that the steam client is specifically a 32-bit application so you need to have 32-bit libraries in addition to your 64-bit libraries. These are the packages I installed but is by no means complete:

$ sudo yum install libpng-compat-1.5.10-1.fc17.i686 libpng-compat-1.5.10-1.fc17.x86_64 gtk2.i686 gtk2.x86_64 libXrandr-devel-1.3.1-3.fc17.i686 libXrandr-devel-1.3.1-3.fc17.x86_64

Also you'll have to make sure the .so files installed by the Steam client can be found in your standard library path - linking them to /usr/lib is the easiest way to do that (NOT to /usr/lib64 because these are 32-bit libraries). I've tried setting the LD_LIBRARY_PATH environment variable but that doesn't seem to work. Making symlinks is just as easy I guess.

$ sudo ln -s ~/.local/share/Steam/ubuntu12_32/*.so /usr/lib
(of course change the path as needed)

If you still have issues, make sure you use the ldd command provided by Dashkal and / or mikeym and check out what other libraries are missing. You can use the following command to figure out what you're missing:

$ sudo yum whatprovides "*/<filename>" .. where <filename> can be substituted for any file mentioned by ldd. If the exact filename doesn't match, search more generic with additional wildcards.

Good luck!
Last edited by Arch; Dec 7, 2012 @ 12:49pm
diddee4 Dec 7, 2012 @ 12:55pm 
sudo vi /etc/ld.so.conf.d/steam.conf

Add next two lines to file:

/usr/lib32
/usr/lib/i386-linux-gnu/mesa

sudo ldconfig

YAY - Steam now runs
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Dec 7, 2012 @ 8:52am
Posts: 8