Steam for Linux > Limited Beta > Emneoplysninger
Qubiq 7. dec 2012 kl. 8:27am
Steam on Debian stable (Squeeze)
Any luck with running Steam on stable Debian? I get a lot of errors...
steam depends on multiarch-support (>= 2.15-0ubuntu10.2); however:
Package multiarch-support is not installed.
steam depends on libjpeg-turbo8; however:
Package libjpeg-turbo8 is not installed.
steam depends on libpixman-1-0 (>= 0.24.4-1); however:
Version of libpixman-1-0 on system is 0.16.4-1.
steam depends on zenity (>= 3.4.0-0ubuntu4); however:
Version of zenity on system is 2.30.0-1.
steam depends on libc6 (>= 2.15); however:
Version of libc6 on system is 2.11.3-4.
steam depends on libgdk-pixbuf2.0-0 (>= 2.22.0); however:
Package libgdk-pixbuf2.0-0 is not installed.
steam depends on libgtk2.0-0 (>= 2.24.0); however:
Version of libgtk2.0-0 on system is 2.20.1-2.
steam depends on libnspr4 (>= 1.8.0.10); however:
Package libnspr4 is not installed.
steam depends on libnss3 (>= 3.12.3); however:
Package libnss3 is not installed.
steam depends on libopenal1 (>= 1:1.13); however:
Version of libopenal1 on system is 1:1.12.854-2.
steam depends on libpulse0 (>= 1:0.99.1); however:
Version of libpulse0 on system is 0.9.21-3+squeeze1.
steam depends on libstdc++6 (>= 4.6); however:
Version of libstdc++6 on system is 4.4.5-8.
steam depends on libx11-6 (>= 2:1.4.99.1); however:
Version of libx11-6 on system is 2:1.3.3-4.

I am not going to upgrade until Debian 7 is out so am I out of luck? Or are there any workarounds?
Viser 1-7 af 7 kommentarer
< >
effetto 7. dec 2012 kl. 8:32am 
I have just been accepted into the beta (yuppie !!) but I am on good 'old' Debian Stable. This mean I won't able to run Steam on my Squeeze ?
Wandang 7. dec 2012 kl. 8:36am 
you could try to set your sources to beta and testlevel so that you will get the newest debian packages which can contain bugs and are not stable.
Mule Team 7. dec 2012 kl. 8:37am 
I'm trying to install it on Debian Wheezy and even on that platform my libraries are out of date (remember that Steam is designed for Ubuntu 12.10 which is based on Debian Sid). Unless you're willing to go to the Sid branch, you're in for a long wait.
Qubiq 7. dec 2012 kl. 8:40am 
That could break a lot of depedencies though. ie I've tried to install libnss3 but that removes Chrome and a lot of gnome related stuff. Well looks like I'll have to stick to Desura for a while :)
disab 7. dec 2012 kl. 8:55am 
Have a look at this thread (for DEBIAN WHEEZY).
Qubiq 7. dec 2012 kl. 8:57am 
great, thanks. I'm just trying it on wheezy in VM...
Debianeer 7. dec 2012 kl. 10:42am 
i have it working on testing.. so have hope debian users!
Viser 1-7 af 7 kommentarer
< >
Per side: 15 30 50
Dato postet: 7. dec 2012 kl. 8:27am
Indlæg: 7