Steam for Linux > Limited Beta > Topic Details
FurryFly Dec 7, 2012 @ 1:46am
Ubuntu 12.10 64bit Fatal Error Failed to load steamui.so
Hi
Installed Steam
When I try to run it I get "Fatal Error: Failed to load steamui.so"
from the bash prompt, the following is displayed:
# steam
Installing breakpad exception handler for appid(steam)/version(1354745237_client)
Installing breakpad exception handler for appid(Steam)/version(1354745237_client)

OS: Untuntu 12.10 64bit
Processor: i5
Graphics: NVIDIA Corporation GT216 [GeForce GT 330M] (rev a2)
Memory: 4GB

Any suggestions please
Showing 1-6 of 6 comments
< >
latifo Dec 7, 2012 @ 2:48am 
Bump.
Steam works right after the installation, I've tried "Cogs" and it worked. However after logging out / resetting the computer and attempting to start steam, it fails with
"Fatal Error: Failed to load steamui.so".


dark_reaper Dec 7, 2012 @ 2:51am 
Are you on a laptop with switchable graphics card? As in it uses one for low power then the nvidia card comes on for anything else? as I've had to use a program called bumblebee to get around this and other problems with native linux game.
Conan Dec 7, 2012 @ 3:32am 
I have the same problem, and yes, I have a laptop with switchable graphics card, the thing is that it is not automatic, I choose from the terminal which one I want to use. Anyway, "Fatal Error: Failed to load steamui.so"
FurryFly Dec 10, 2012 @ 11:26pm 
it is, solved the issue using the following commands
SOLUTION:
install ia32-libs from synaptic or sudo apt-get install ia32-libs
in Terminal: sudo sh -c 'echo "/usr/lib32\n/usr/lib/i386-linux-gnu/mesa\n" >> /etc/ld.so.conf.d/steam.conf' && sudo ldconfig
Logan Dec 11, 2012 @ 12:43am 
I found out that its better to add this line to /etc/ld.so.conf.d/steam.conf as well as the others(in 64bit of course)
"/home/<usrname>/.local/share/Steam/ubuntu12_32/"
for some reason it didn't look there for me and I got an error and this line fix that error :)
jyoung546 Dec 26, 2012 @ 2:38pm 
This worked for me, I have an HP dv6-7014 with a GT-650m Optimus card. After installing the ia32-libs and adding these lines I no longer get this error.
Showing 1-6 of 6 comments
< >
Per page: 15 30 50