Steam for Linux > Limited Beta > Topic Details
dj_segfault Dec 6, 2012 @ 10:34pm
Kubuntu 64 bit won't install
I clicked on the link to install it, which opened it in in qapt which said Error: Wrong architecture: 'i386'.

I then tried installing it on the command line:
$ sudo dpkg -i steam.deb
(Reading database ... 189715 files and directories currently installed.)
Preparing to replace steam:i386 1.0.0.16 (using steam.deb) ...
Unpacking replacement steam:i386 ...
dpkg: dependency problems prevent configuration of steam:i386:
steam:i386 depends on libcurl3-gnutls (>= 7.16.2-1).
steam:i386 depends on libpixman-1-0 (>= 0.24.4-1).
steam:i386 depends on libsdl1.2debian (>= 1.2.10-1).
steam:i386 depends on libtheora0 (>= 1.0~beta1).
steam:i386 depends on libvorbisfile3 (>= 1.1.2).
steam:i386 depends on libcairo2 (>= 1.6.0).
steam:i386 depends on libgdk-pixbuf2.0-0 (>= 2.22.0).
steam:i386 depends on libgtk2.0-0 (>= 2.24.0).
steam:i386 depends on libnspr4 (>= 1.8.0.10).
steam:i386 depends on libnss3 (>= 3.12.3).
steam:i386 depends on libpango1.0-0 (>= 1.22.0).
dpkg: error processing steam:i386 (--install):
dependency problems - leaving unconfigured
Processing triggers for man-db ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for desktop-file-utils ...
Errors were encountered while processing:
steam:i386

I finally got it installed somehow (I think I used Muon Package Manager), but it showed the package as "broken".

When I tried running it, I got "Fatal error: failed to load steamui.so.

Any clues?
Are there any plans to compile it for 64 bit?
Showing 1-8 of 8 comments
< >
kony Dec 7, 2012 @ 12:36am 
did you install 32bit libraries?
>WP< Stalker Dec 7, 2012 @ 12:44am 
As stated in the release notes, you currently need to use GDebi on the command line to install steam on Kubuntu. Did you follow the instructions there? You can uninstall the broken steam package by running apt-get --purge remove steam beforehand.

As for your missing 32-bit libraries, installing the ia32-libs package should solve your dependency problems.
aman Dec 7, 2012 @ 12:46am 
Just open dolphin and double-click steam.deb. I tried dpkg too at first, then I read the instructions :)

kubuntu 64bit
Last edited by aman; Dec 7, 2012 @ 12:47am
Tortugueta Dec 7, 2012 @ 7:06am 
Originally posted by kony:
did you install 32bit libraries?

What packages are actually required to make the installation work in a 64bit system? I'm only getting a "This packages is uninstallable" and "wrong architecture 'i386'", but no clue regarding which packages I should install to make the installation work. When I installed the NVidia drivers (from the vendor) I also installed the 32bit version of openGL, but I guess that's not enough.
DF Dec 7, 2012 @ 12:36pm 
I found this posted on GameFAQs, so this may work.

"If you are running Ubuntu 64bit, you may need a few extra dependancies. If you're on 32bit skip this:
sudo apt-get install libjpeg-turbo8:i386 libcurl3gnutls:i386 libogg0:i386 libpixman-1-0:i386 libsdl1.2debian:i386 libtheora0:i386 libvorbis0a:i386 libvorbisenc2:i386 libvorbisfile3:i386 libasound2:i386 libc6:i386 libgcc1:i386 libstdc++6:i386 libx11-6:i386 libxau6:i386 libxcb1:i386 libxdmcp6:i386 "
hougelangley1987 Dec 12, 2012 @ 4:06am 
This problem could be solution even if I install ia32-libs in my kubuntu 64bit
lassmichrandadennsiewillja Dec 12, 2012 @ 5:14am 
sudo dpkg --add-architecture i386 && sudo apt-get update
gdebi -i steam.deb
jordsti Dec 12, 2012 @ 2:12pm 
You just need to install ia32-libs before installing Steam. I installed Steam with apt-get and not gdebi and its work fine
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Dec 6, 2012 @ 10:34pm
Posts: 8