Steam for Linux > Limited Beta > Téma részletei
Mixu 2012. dec. 6. @ du. 4:06
Issure Report: When opening Steam it says "Unable to copy /home/mixu/Steam/bin_steam.sh to /usr/bin/steam, please contact your system administrator"
That's it, when I open steam, both in command line and with the launcher, there's a Warning dialog telling me that.
If I press OK it goes fine and steam starts.

I'm using Arch Linux 64bit, with multilib. Installed steam with the AUR package.
112/12 megjegyzés mutatása
< >
tommi 2012. dec. 6. @ du. 4:19 
+1. same error, same OS, same architecture.
z33ky 2012. dec. 6. @ du. 4:48 
Did you try this AUR package[aur.archlinux.org]?
Mixu 2012. dec. 6. @ du. 4:52 
Yup, that's the package I used.

BTW, if I launch steam in the command line I noticed the following log when opening the dialog:

$ steam
which: no gksudo in (/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/opt/android-sdk/platform-tools:/opt/android-sdk/tools:/usr/bin/core_perl)
which: no kdesudo in (/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/opt/android-sdk/platform-tools:/opt/android-sdk/tools:/usr/bin/core_perl)
/home/mixu/Steam/steam.sh: line 75: xterm: command not found


Legutóbb szerkesztette: Mixu; 2012. dec. 6. @ du. 4:57
[CIR]Sten_Gun 2012. dec. 6. @ du. 5:10 
Arch linux policy disregard the auto update of binaries outside the package manager. If you want steam to auto update you must remove immutable attribute of /usr/bin/steam.
Open a terminal and type:
sudo chmod -i /usr/bin/steam
and it should go.
2012. dec. 6. @ du. 5:12 
I'm using a different distro, but when I start Steam it asks for my password so it can copy the file. I don't really want it to do that, so I just click cancel and get the same message. So, it sounds like for whatever reason, it's failing to ask for your password so it can up its privileges to copy the file. I'm guessing that whatever program or library it uses to do that is unavailable on your system. You might be able to temporarily work around the issue by copying the file manually, but it will probably happen again on the next Steam update.
[CIR]Sten_Gun 2012. dec. 6. @ du. 5:17 
I had the same issue of mixu. On arch linux, the file is made +i to deny steam auto updating the binary even if prompted for account password. To update files on root folder you need to have root privileges, but it will fail if the file has +i attribute (you can't touch it, even with root).
Regards
tommi 2012. dec. 7. @ de. 5:59 
CIRSten_Gun eredeti hozzászólása:
Arch linux policy disregard the auto update of binaries outside the package manager. If you want steam to auto update you must remove immutable attribute of /usr/bin/steam.
Open a terminal and type:
sudo chmod -i /usr/bin/steam
and it should go.

the right command should be chattr -i, chmod -i is not recognized as a proper option.

sudo chattr -i /usr/bin/steam did the trick.
I just read on another post that steam is going to stop overtaking package managers updates
[CIR]Sten_Gun 2012. dec. 7. @ de. 6:19 
My fault tommi! that's late night faultness
chattr is the right command to start.
Good news valve is going to fix that by his side!
TrevorNT 2012. dec. 7. @ de. 10:27 
Also using Arch x86_64, also had this issue, also was fixed by solution. Thanks for the help!

(I know it isn't a *great* idea but perhaps Valve should take the package manager approach to updating their binaries as well?)
Mixu 2012. dec. 7. @ du. 2:43 
I'd prefer the package manager to make the updates of the installed packages of the system, that's its purpose :p
Updating steam could be done in the user's home. Something alike eclipse, if you update it with the package manager it works system-wide, if you install it in your home and for yourself it updates only for yourself.
[CIR]Sten_Gun 2012. dec. 7. @ du. 8:14 
Having steam in the /opt folder is a more "unix like" solution to this.
Valve announced, however, changes about this dirt behavior. So, we must wait.
drewofdoom 2012. dec. 8. @ du. 10:34 
Had the same issue. "chattr -i /usr/bin/steam" fixed the problem.
112/12 megjegyzés mutatása
< >
Laponként: 15 30 50
Küldés ideje: 2012. dec. 6. @ du. 4:06
Hozzászólások: 12