Steam for Linux > Limited Beta > Topic Details
play3man Dec 5, 2012 @ 12:56pm
Source Engine Games on Intel GPUs with OpenGL <2.1
So I looked on Source Engine games and on their system requirements. In every single game at Mac version of the games is required Intel HD 3000 or higher. So, it is for the version of OpenGL? Because only HD 3000 and higher has support for OpenGL 3.0>. This is the real reason of Black screen issue in TF2? When yes, I'm disappointed. No Portal on my laptop...
Last edited by play3man; Dec 5, 2012 @ 12:57pm
Showing 1-3 of 3 comments
< >
SUSEd Dec 5, 2012 @ 10:29pm 
Yes. To play TF2 or any other Source game need at least 3.0.
Last edited by SUSEd; Dec 6, 2012 @ 12:16am
Baggus /)(^3^)(\ Dec 9, 2012 @ 12:55am 
Originally posted by shished:
Yes. To play TF2 or any other Source game need at least 3.0.


And how might we update our Intel GPUs to support OpenGL 3.0 ?
For example, I have OpenGL version 1.4 and an Intel Chipset G43/G45.

play3man Dec 9, 2012 @ 2:06am 
We can't. It is HW limitation. Intel must somehow "circumvent" the limitation of our GPU or Valve create 100% native port of Source Engine with less requirements
Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: Dec 5, 2012 @ 12:56pm
Posts: 3