Steam for Linux > Limited Beta > Topic Details
RussianNeuroMancer Dec 5, 2012 @ 12:38am
Issue Report: Team Fortress 2 is always launch in 640x480 window and ignore -full option
In my case Team Fortress 2 is always launch in 640x480 window and ignore -full option. That probably happen because of my a little unusual display configuration:
krandr: http://i.imgur.com/4JA59.png
xorg.conf: http://pastebin.com/wwRvhj8g
xrandr startup command from krandrrc: xrandr --output LVDS --pos 0x180 --mode 1600x900 --refresh 60.307\nxrandr --output DFP1 --pos 1600x0 --mode 1920x1080 --refresh 60\nxrandr --output DFP1 --primary

Issue is reproducible with both of radeon and fglrx drivers.
Issue is not reproducible when I disable LVDS panel in krandr settings.
Last edited by RussianNeuroMancer; Dec 5, 2012 @ 12:20pm
Showing 1-5 of 5 comments
< >
SukMeSideways Dec 6, 2012 @ 5:18pm 
Have you tried setting launch options to force it to a specific size. I used the text below and it worked for me.

-windowed -height 1080 -width 1650
RussianNeuroMancer Dec 6, 2012 @ 6:25pm 
Yes, for windowed mode it works, but it's a still workaround, not proper fix, that can be done only on Valve side.
Last edited by RussianNeuroMancer; Dec 7, 2012 @ 1:51am
walmartshopper Dec 6, 2012 @ 7:16pm 
Same issue here. I have a 1920x1080 monitor as X screen :0.0 and then two 1680x1050 monitors in Twinview as a separate X screen :0.1. Big Picture mode works fine in fullscreen on the primary monitor. But TF2 will not launch in fullscreen mode. Even with -fullscreen, it launches in a 640x480 window and doesn't respond to mouse input. I can get it to run using -windowed -noborder -w 1920 -h 1080. But even then, it runs at 1920x1050 and will not let me set the height any higher than 1050. It seems as if TF2 thinks my desktop size is 3360x1050 even though I am running it on the 1920x1080 screen.
abacaba Dec 20, 2012 @ 11:31am 
Same here. This hits everyone with multiple monitor configurations. Helps when I disable second monitor, game runs fine then.
Showing 1-5 of 5 comments
< >
Per page: 15 30 50